Search
Question: cannot get GRanges() to load
0
gravatar for wrab425
10 weeks ago by
wrab4250
United Kingdom
wrab4250 wrote:

I am starting Bioconductor by following Kasper Hansens lectures. Now I cannot get the GenomicRanges library to load. I can see the package in my package tab in R studio so it seems to be there but it will not run. I loaded biocLite() freshly to start . There seems to be a problem with GenomeInfoDb() but what is it?

 

Thanks a lot for any help.

 

Here is the output;

> biocLite()

BioC_mirror: https://bioconductor.org

Using Bioconductor 3.5 (BiocInstaller 1.26.1), R 3.4.1 (2017-06-30).

installation path not writeable, unable to update packages: boot, Matrix, mgcv

Old packages: 'GenomicRanges', 'IRanges', 'manipulate', 'S4Vectors'

Update all/some/none? [a/s/n]: 

a

Warning: packages ‘IRanges’, ‘S4Vectors’ are in use and will not be installed

trying URL 'https://bioconductor.org/packages/3.5/bioc/bin/windows/contrib/3.4/GenomicRanges_1.28.5.zip'

Content type 'application/zip' length 3005132 bytes (2.9 MB)

downloaded 2.9 MB

 

trying URL 'http://cran.rstudio.com/bin/windows/contrib/3.4/manipulate_1.0.1.zip'

Content type 'application/zip' length 35982 bytes (35 KB)

downloaded 35 KB

 

package ‘GenomicRanges’ successfully unpacked and MD5 sums checked

package ‘manipulate’ successfully unpacked and MD5 sums checked

 

The downloaded binary packages are in

C:\Users\William Brown\AppData\Local\Temp\RtmpEvBBDz\downloaded_packages

> biocLite(GenomicRanges)

Error in "BiocUpgrade" %in% pkgs : object 'GenomicRanges' not found

> library("GenomicRanges", lib.loc="~/R/win-library/3.4")

Loading required package: GenomeInfoDb

Error: package or namespace load failed for ‘GenomeInfoDb’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):

 there is no package called ‘GenomeInfoDbData’

Error: package ‘GenomeInfoDb’ could not be loaded

> biocLite(GenomicRanges)

Error in "BiocUpgrade" %in% pkgs : object 'GenomicRanges' not found

> library("GenomeInfoDb", lib.loc="~/R/win-library/3.4")

Error: package or namespace load failed for ‘GenomeInfoDb’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):

 there is no package called ‘GenomeInfoDbData’

 

and 

 

> sessionInfo()
R version 3.4.1 (2017-06-30)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 7 x64 (build 7601) Service Pack 1

Matrix products: default

locale:
[1] LC_COLLATE=English_United Kingdom.1252  LC_CTYPE=English_United Kingdom.1252   
[3] LC_MONETARY=English_United Kingdom.1252 LC_NUMERIC=C                           
[5] LC_TIME=English_United Kingdom.1252    

attached base packages:
[1] stats4    parallel  stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] BiocInstaller_1.26.1 IRanges_2.10.2       S4Vectors_0.14.3     BiocGenerics_0.22.0 

loaded via a namespace (and not attached):
[1] compiler_3.4.1 tools_3.4.1    RCurl_1.95-4.8 bitops_1.0-6

ADD COMMENTlink modified 10 weeks ago by nitesh.turaga120 • written 10 weeks ago by wrab4250
0
gravatar for nitesh.turaga
10 weeks ago by
nitesh.turaga120
United States
nitesh.turaga120 wrote:

Hi

Can you try to install GenomeInfoDbData ?

That seems to be your problem.

ADD COMMENTlink written 10 weeks ago by nitesh.turaga120

Thanks That was helpful I just needed to use biocLite("GenomeInfoDbData"). It was the inverted commas that were missing.

 

ADD REPLYlink written 9 weeks ago by wrab4250

I was wrong; it seemed to have loaded but when I came to load GRnages() it could not be seen.

> biocLite("GenomeInfoDbData")

BioC_mirror: https://bioconductor.org

Using Bioconductor 3.5 (BiocInstaller 1.26.1), R 3.4.1 (2017-06-30).

Installing package(s) ‘GenomeInfoDbData’

installing the source package ‘GenomeInfoDbData’

 

trying URL 'https://bioconductor.org/packages/3.5/data/annotation/src/contrib/GenomeInfoDbData_0.99.0.tar.gz'

Content type 'application/x-gzip' length 16238792 bytes (15.5 MB)

downloaded 15.5 MB

 

Error: '\P' is an unrecognized escape in character string starting ""C:\P"

Execution halted

 

The downloaded source packages are in

‘C:\Users\William Brown\AppData\Local\Temp\RtmpS8HQDc\downloaded_packages’

installation path not writeable, unable to update packages: boot, Matrix, mgcv

Old packages: 'IRanges', 'manipulate', 'S4Vectors'

Update all/some/none? [a/s/n]: 

a

Warning: packages ‘IRanges’, ‘S4Vectors’ are in use and will not be installed

trying URL 'http://cran.rstudio.com/bin/windows/contrib/3.4/manipulate_1.0.1.zip'

Content type 'application/zip' length 35982 bytes (35 KB)

downloaded 35 KB

 

package ‘manipulate’ successfully unpacked and MD5 sums checked

 

The downloaded binary packages are in

C:\Users\William Brown\AppData\Local\Temp\RtmpS8HQDc\downloaded_packages

Warning messages:

1: running command '"C:/PROGRA~1/R/R-34~1.1/bin/x64/R" CMD INSTALL -l "C:\Users\William Brown\Documents\R\win-library\3.4" C:\Users\WILLIA~1\AppData\Local\Temp\RtmpS8HQDc/downloaded_packages/GenomeInfoDbData_0.99.0.tar.gz' had status 1 

2: In install.packages(pkgs = doing, lib = lib, ...) :

  installation of package ‘GenomeInfoDbData’ had non-zero exit status

> library("GenomeInfoDb", lib.loc="~/R/win-library/3.4")

Error: package or namespace load failed for ‘GenomeInfoDb’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):

 there is no package called ‘GenomeInfoDbData’

 

ADD REPLYlink written 9 weeks ago by wrab4250
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 135 users visited in the last hour