Question: flowQ: Unable to install flowQ on Mac R v3.4.1
0
gravatar for kelly.joanne.andrews
22 months ago by
kelly.joanne.andrews0 wrote:

I am unable to install flowQ on my mac running R v3.4.1. I have tried installing 2 ways.

> source("https://bioconductor.org/biocLite.R")
Bioconductor version 3.5 (BiocInstaller 1.26.1), ?biocLite for help
> biocLite("flowQ")
BioC_mirror: https://bioconductor.org
Using Bioconductor 3.5 (BiocInstaller 1.26.1), R 3.4.1 (2017-06-30).
Installing package(s) ‘flowQ’
installing the source package ‘flowQ’

trying URL 'https://bioconductor.org/packages/3.5/bioc/src/contrib/flowQ_1.36.0.tar.gz'
Content type 'application/x-gzip' length 4593077 bytes (4.4 MB)
==================================================
downloaded 4.4 MB

* installing *source* package ‘flowQ’ ...
** R
** data
** inst
** preparing package for lazy loading
** help
*** installing help indices
** building package indices
** installing vignettes
** testing if installed package can be loaded
Error: package or namespace load failed for ‘flowQ’:
 .onAttach failed in attachNamespace() for 'flowQ', details:
  call: system("convert -list configure", intern = TRUE, ignore.stderr = TRUE)
  error: error in running command
Error: loading failed
Execution halted
ERROR: loading failed
* removing ‘/Library/Frameworks/R.framework/Versions/3.4/Resources/library/flowQ’

The downloaded source packages are in
    ‘/private/var/folders/gh/fc6sldq90_d1_5gnk_jvdvd80000gp/T/RtmpJ1vKyL/downloaded_packages’
Warning message:
In install.packages(pkgs = doing, lib = lib, ...) :
  installation of package ‘flowQ’ had non-zero exit status

 

> install.packages("flowQ")
Warning in install.packages :
  package ‘flowQ’ is not available (for R version 3.4.1)

 

Is it true that this package is unable to be installed on v3.4.1? Is there an ETA on an update for this package? There are some useful functions that I would like to be able to use on my flow data.

Thanks

Kelly

flowq • 370 views
ADD COMMENTlink modified 22 months ago by Jiang, Mike1.2k • written 22 months ago by kelly.joanne.andrews0
Answer: flowQ: Unable to install flowQ on Mac R v3.4.1
0
gravatar for Jiang, Mike
22 months ago by
Jiang, Mike1.2k
(Private Address)
Jiang, Mike1.2k wrote:

Make sure ImageMagick is installed properly and can be found in default path.

ADD COMMENTlink written 22 months ago by Jiang, Mike1.2k

I downloaded ImageMagick, https://www.imagemagick.org/script/download.php#macosx

ImageMagick-x86_64-apple-darwin16.7.0.tar.gz

I moved the folders it downloaded to my applications folder. I don't know what you mean by default path. The install still isn't working, so I guess something still isn't right. I should note that v7.0 appears to be for MacSierra and I'm running El Capitan, so perhaps that is the issue.

Thanks

Kelly

ADD REPLYlink written 22 months ago by kelly.joanne.andrews0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 255 users visited in the last hour