Search
Question: Opencyto - detector name not found in flow data, but pretty sure it's there
1
gravatar for Andrew Box
12 months ago by
Andrew Box10
Kansas City, MO - Stowers Institute for Medical Research
Andrew Box10 wrote:

Hi, I've saved a wsp workspace in flowjo X that I'm attempting to import into R using opencyto using this code below.  The files are from a ZE5 analyzer.

flowDataPath <- getwd()
wsfile <- list.files(flowDataPath, pattern="FJ.wsp",full = TRUE)
ws <- openWorkspace(wsfile)
gs <- parseWorkspace(ws, name=1, isNcdf = TRUE)

But I get an error during parseWorkspace:

loading data: E:/17cy1713_TSK_96wellSet/TestFiles/G1.fcs
Compensating
gating ...
Error in .cpp_gating(gs@pointer, mat, guid, gains, nodeInd, recompute,  : 
  FL03-A not found in flowData!

​If I load in one of these files and check parameter names like this below, I can see that FL03-A is indeed one of the parameters present, also the files in my wd are the same as those used in the flowjo workspace.

> myframe@parameters@data
       name               desc      range minRange   maxRange
$P1      T0               TLSW 2147483647        0 2147483646
$P2      T1               TMSW 2147483647        0 2147483646
$P3    INFO         Event Info 2147483647        0 2147483646
$P4  FS00-H       FSC 488/10-H 2147483647        0 2147483646
$P5  FS00-A       FSC 488/10-A 2147483647        0 2147483646
$P6  FS00-W       FSC 488/10-W 2147483647        0 2147483646
$P7  FS01-H FSC 405/10 (spd)-H 2147483647        0 2147483646
$P8  FS01-A FSC 405/10 (spd)-A 2147483647        0 2147483646
$P9  FS01-W FSC 405/10 (spd)-W 2147483647        0 2147483646
$P10 SS02-H       SSC 488/10-H 2147483647        0 2147483646
$P11 SS02-A       SSC 488/10-A 2147483647        0 2147483646
$P12 SS02-W       SSC 488/10-W 2147483647        0 2147483646
$P13 FL03-H            Donor-H 2147483647        0 2147483646
$P14 FL03-A            Donor-A 2147483647        0 2147483646
$P15 FL03-W            Donor-W 2147483647        0 2147483646
$P16 FL04-H             FRET-H 2147483647        0 2147483646
$P17 FL04-A             FRET-A 2147483647        0 2147483646
$P18 FL04-W             FRET-W 2147483647        0 2147483646
$P19 FL10-H         Acceptor-H 2147483647        0 2147483646
$P20 FL10-A         Acceptor-A 2147483647        0 2147483646
$P21 FL10-W         Acceptor-W 2147483647        0 2147483646
$P22 FL13-H      AcceptorAlt-H 2147483647        0 2147483646
$P23 FL13-A      AcceptorAlt-A 2147483647        0 2147483646
$P24 FL13-W      AcceptorAlt-W 2147483647        0 2147483646
$P25 FL17-H           460/22-H 2147483647        0 2147483646
$P26 FL17-A           460/22-A 2147483647        0 2147483646
$P27 FL17-W           460/22-W 2147483647        0 2147483646
$P28   TIME               TIME 2147483647        0 2147483646

Am I making a mistake somewhere, or is there an issue with how opencyto is dealing with either my workspace or ZE5 fcs files?

Thanks.

 

> sessionInfo()
R version 3.3.3 (2017-03-06)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

locale:
[1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United States.1252    LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                           LC_TIME=English_United States.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] openCyto_1.12.1           flowWorkspace_3.20.5      ncdfFlow_2.20.2           BH_1.65.0-1               RcppArmadillo_0.8.100.1.0
[6] flowCore_1.40.6           BiocInstaller_1.24.0      flowClust_3.12.2         

loaded via a namespace (and not attached):
Error in x[["Version"]] : subscript out of bounds
In addition: Warning message:
In FUN(X[[i]], ...) :
  DESCRIPTION file of package 'Rcpp' is missing or broken

 

ADD COMMENTlink modified 25 days ago by Jiang, Mike1.2k • written 12 months ago by Andrew Box10
2
gravatar for Jiang, Mike
25 days ago by
Jiang, Mike1.2k
(Private Address)
Jiang, Mike1.2k wrote:

This typically indicates that gate in xml was referring to the raw dimension name 'FL03-A', which is no longer present in the compensated flow data (flowJo adds prefix after compensation, i.e. <FL03-A> or comp-FL03-A).

So double check your xml workspace and make sure the gates are defined on the correct dimensions.

ADD COMMENTlink written 25 days ago by Jiang, Mike1.2k

Thanks, I ended up taking a different path for this project besides using flowWorkspace since it was giving me trouble, but I'll try and find some time to revisit this issue and confirm whether this name mismatch was in fact the issue.

ADD REPLYlink written 19 days ago by Andrew Box10
0
gravatar for jd841029
10 months ago by
jd8410290
Australia
jd8410290 wrote:

Can the problem be solved? I also get the error during parseWorkspace? Any questions?

ADD COMMENTlink written 10 months ago by jd8410290
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 440 users visited in the last hour