Search
Question: Error UseMethod ("select_"): from bioconductor dplyr select package
0
gravatar for abedini.jaleh
28 days ago by
abedini.jaleh0 wrote:

I am running this code using the rat database

select(rat2302.db, PROBES, "ENTREZID")

to look in the rat database and get the  ENTREZID with the probes I extracted before.

and this error pops

Error in USEMethod("select_"):

no application method for 'select_' applied to an object of clad "c('ChipDB', 'AnnotationDb', 'envaRefClass', '.environment', 'refClass', 'environment' , refObject', 'AssayData')"

I tried this on both R version 3.4.1 and 3.3-PreUgrade and I could only make it work once it the pre-ugrade, but the error appeared again upon using it in a function. Now the code doesn't run at all.

I reinstalled Bioconductor and all the libraries and still have the same issue.

 

Does anybody knows what else I need to do?

 

ADD COMMENTlink modified 28 days ago by Martin Morgan ♦♦ 20k • written 28 days ago by abedini.jaleh0
1
gravatar for Martin Morgan
28 days ago by
Martin Morgan ♦♦ 20k
United States
Martin Morgan ♦♦ 20k wrote:

Make sure that you're using the correct generic, from AnnotationDbi rather than dplyr

AnnotationDbi::select(rat2302.db, PROBES, "ENTREZID")

 

ADD COMMENTlink written 28 days ago by Martin Morgan ♦♦ 20k

Thank you so much it worked

ADD REPLYlink written 28 days ago by abedini.jaleh0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 157 users visited in the last hour