QSEA: Error while addLibraryFactors
1
0
Entering edit mode
geekyvt • 0
@geekyvt-15045
Last seen 3.9 years ago

Hi,

I am using QSEA for analyzing the MeDIPseq data. In middle, I am stuck with the below error. Could someone help?

group <- c("treatment", "treatment", "control", "control") and all are female samples

qseaSet=addLibraryFactors(qseaSet)

Results in,

deriving TMM library factors for 4 samples
Error in seq.default(1, length(wd), ceiling(length(wd)/nReg)) : 
  object 'wd' not found
Calls: addLibraryFactors -> estimateLibraryFactors -> seq -> seq.default
Execution halted

I am using R 3.4 and all latest packages.Thanks in Advance,

Vivek

 

===============================================================================

R version 3.4.1 (2017-06-30)
Platform: x86_64-redhat-linux-gnu (64-bit)
Running under: CentOS release 6.7 (Final)

Matrix products: default
BLAS: /usr/lib64/R/lib/libRblas.so
LAPACK: /usr/lib64/R/lib/libRlapack.so

locale:
 [1] LC_CTYPE=en_IN       LC_NUMERIC=C         LC_TIME=en_IN       
 [4] LC_COLLATE=en_IN     LC_MONETARY=en_IN    LC_MESSAGES=en_IN   
 [7] LC_PAPER=en_IN       LC_NAME=C            LC_ADDRESS=C        
[10] LC_TELEPHONE=C       LC_MEASUREMENT=en_IN LC_IDENTIFICATION=C 

attached base packages:
[1] stats4    parallel  methods   stats     graphics  grDevices utils    
[8] datasets  base     

other attached packages:
 [1] BiocParallel_1.12.0               qsea_1.4.0                       
 [3] BSgenome.Hsapiens.UCSC.hg19_1.4.0 BSgenome_1.46.0                  
 [5] rtracklayer_1.38.3                Biostrings_2.46.0                
 [7] XVector_0.18.0                    GenomicRanges_1.30.2             
 [9] GenomeInfoDb_1.14.0               IRanges_2.12.0                   
[11] S4Vectors_0.16.0                  BiocGenerics_0.24.0              

loaded via a namespace (and not attached):
 [1] HMMcopy_1.20.0             zlibbioc_1.24.0           
 [3] GenomicAlignments_1.14.1   lattice_0.20-35           
 [5] tools_3.4.1                SummarizedExperiment_1.8.1
 [7] grid_3.4.1                 Biobase_2.38.0            
 [9] gtools_3.5.0               matrixStats_0.53.1        
[11] Matrix_1.2-12              GenomeInfoDbData_1.0.0    
[13] bitops_1.0-6               RCurl_1.95-4.10           
[15] limma_3.34.8               DelayedArray_0.4.1        
[17] compiler_3.4.1             Rsamtools_1.30.0          
[19] XML_3.98-1.10              zoo_1.8-1 

QSEA • 512 views
ADD COMMENT
1
Entering edit mode
@matthias-lienhard-6292
Last seen 8 months ago
Max Planck Institute for molecular Gene…

Hi Vivek,

I did some tests and could reproduce your error, if I don't add the CpG density to the qsea set before calling addLibraryFactors - I guess this was also the case for you. For now I recommend calling addPatternDensity before addLibraryFactors. If this does not help, please let me know.

I will improve the handling of the case without CpG density in development branch, it will be made available with the next release.

Thanks for reporting on this issue, best whishes, Matthias

ADD COMMENT
0
Entering edit mode

Dear Matthias,

Thank you so much for your help. The issue got solved after changing the order of commands and I am able to proceed further.

Thanks,

Vivek

ADD REPLY

Login before adding your answer.

Traffic: 217 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6