Question: Why does the Glimma package require R >= 3.4.0 ?
0
gravatar for gil.hornung
19 months ago by
gil.hornung0 wrote:

Hi,

 

The Glimma package is great for exploring Differential Expression results, but it requires R version >= 3.4.0 

Unfortunately, in my organisation the production pipeline relies on R 3.2.1 

If I "hack" the Glimma package and change the `Depends` line in the DESCRIPTION file to `Depends: R (>= 3.2.0)` then the package still compiles.

Is there a reason why Glimma requires R version >= 3.4.0  ?

 

Thank you,

Gil Hornung

glimma • 272 views
ADD COMMENTlink modified 19 months ago by Shian Su20 • written 19 months ago by gil.hornung0
Answer: Why does the Glimma package require R >= 3.4.0 ?
0
gravatar for Shian Su
19 months ago by
Shian Su20
Walter and Eliza Hall Institute of Medical Research, Melbourne, Australia
Shian Su20 wrote:

It doesn’t use any features from the latest R release, however it is Bioconductor policy to use require the latest R version on all packages. If you know how to change the dependency in the DESCRIPTION file then the package will work perfectly fine on an older version of R.

ADD COMMENTlink written 19 months ago by Shian Su20
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 333 users visited in the last hour