Why does the Glimma package require R >= 3.4.0 ?
1
0
Entering edit mode
@gilhornung-9503
Last seen 2.0 years ago

Hi,

 

The Glimma package is great for exploring Differential Expression results, but it requires R version >= 3.4.0 

Unfortunately, in my organisation the production pipeline relies on R 3.2.1 

If I "hack" the Glimma package and change the `Depends` line in the DESCRIPTION file to `Depends: R (>= 3.2.0)` then the package still compiles.

Is there a reason why Glimma requires R version >= 3.4.0  ?

 

Thank you,

Gil Hornung

glimma • 424 views
ADD COMMENT
0
Entering edit mode
Shian Su ▴ 40
@shian-su-9869
Last seen 14 months ago
Walter and Eliza Hall Institute of Medi…

It doesn’t use any features from the latest R release, however it is Bioconductor policy to use require the latest R version on all packages. If you know how to change the dependency in the DESCRIPTION file then the package will work perfectly fine on an older version of R.

ADD COMMENT

Login before adding your answer.

Traffic: 246 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6