Cannot install clusterProfiler
2
0
Entering edit mode
dtatarak • 0
@dtatarak-15870
Last seen 3.4 years ago

I am using the following code to install clusterProfiler:

 

source("https://bioconductor.org/biocLite.R")

BiocInstaller::biocLite("clusterProfiler")

 

I get the following error:

 

Error: package or namespace load failed for ‘AnnotationDbi’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):

 there is no package called ‘bit’

Error : package ‘AnnotationDbi’ could not be loaded

ERROR: lazy loading failed for package ‘GO.db’
  • removing ‘/Library/Frameworks/R.framework/Versions/3.5/Resources/library/GO.db’
The downloaded source packages are in

‘/private/var/folders/jm/lw5pqpvs0_j025smc3qkpl5c0000gn/T/RtmpnPsdF8/downloaded_packages’

Warning message:

In install.packages(pkgs = doing, lib = lib, ...) :

  installation of package ‘GO.db’ had non-zero exit status

 

I'm really not sure what to do here. When I search online, everyone pretty much says to do exactly what I did, and that it should install the required packages. I am new to R, and this is beyond me. Thanks for any help you can provide!

clusterprofiler biocinstaller • 2.0k views
ADD COMMENT
0
Entering edit mode
@james-w-macdonald-5106
Last seen 11 hours ago
United States

It looks like you have AnnotationDbi installed, but are missing dependencies. Or actually, dependencies of dependencies, as bit isn't a direct dependency of AnnotationDbi. You probably need to re-install AnnotationDbi to get all the dependencies.

ADD COMMENT
0
Entering edit mode

I tried that. It installs successfully, but I still get the exact same error when installing clusterProfiler.

ADD REPLY
0
Entering edit mode

Then install bit using biocLite

ADD REPLY
0
Entering edit mode
Guangchuang Yu ★ 1.2k
@guangchuang-yu-5419
Last seen 8 months ago
China/Guangzhou/Southern Medical Univer…
ADD COMMENT

Login before adding your answer.

Traffic: 359 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6