cannot find function even though KEGGgraph package supposedly installed
1
0
Entering edit mode
kathleenfix ▴ 10
@kathleenfix-16649
Last seen 4.2 years ago

Hello,

I'm working on a newly updated Mac osx 10.11. I freshly updated R and XQuartz and then tried to install KEGGgraph using biocLite. When I list installed packages KEGGgraph is listed but when I try to use a function I get the error (for example):

Error in getKGMLurl("hsa00020") : could not find function "getKGMLurl"

Please help!  Sample output is below

_______________________
R version 3.5.1 (2018-07-02) -- "Feather Spray"
Copyright (C) 2018 The R Foundation for Statistical Computing
Platform: x86_64-apple-darwin15.6.0 (64-bit)

> source("https://bioconductor.org/biocLite.R")
Bioconductor version 3.7 (BiocInstaller 1.30.0), ?biocLite for help

> ?biocLite
starting httpd help server ... done

> biocLite("KEGGgraph")
BioC_mirror: https://bioconductor.org
Using Bioconductor 3.7 (BiocInstaller 1.30.0), R 3.5.1 (2018-07-02).
Installing package(s) ‘KEGGgraph’
trying URL 'https://bioconductor.org/packages/3.7/bioc/bin/macosx/el-capitan/contrib/3.5/KEGGgraph_1.40.0.tgz'
Content type 'application/x-gzip' length 1783868 bytes (1.7 MB)
==================================================
downloaded 1.7 MB
The downloaded binary packages are in
/var/folders/ls/sglxhr9s5yb0sr0f4sr7hbqr0000gn/T//RtmpWlv3qu/downloaded_packages

> pkgs <- rownames(installed.packages())
> pkgs
[1] "AnnotationDbi" "assertthat"    "base"          "BH"           
[5] "Biobase"       "BiocGenerics"  "BiocInstaller" "bit"         
 [9] "bit64"         "blob"          "boot"          "class"       
[13] "cluster"       "codetools"     "compiler"      "datasets"     
[17] "DBI"           "digest"        "foreign"       "graph"       
[21] "graphics"      "grDevices"     "grid"          "IRanges"     
[25] "KEGGgraph"     "KernSmooth"    "lattice"       "magrittr"     
[29] "MASS"          "Matrix"        "memoise"       "methods"     
[33] "mgcv"          "nlme"          "nnet"          "parallel"     
[37] "pkgconfig"     "plogr"         "prettyunits"   "Rcpp"         
[41] "rpart"         "RSQLite"       "S4Vectors"     "spatial"     
[45] "splines"       "stats"         "stats4"        "survival"     
[49] "tcltk"         "tools"         "utils"         "XML"          

> getKGMLurl("hsa00020")
Error in getKGMLurl("hsa00020") : could not find function "getKGMLurl"

> sfile <- system.file("extdata/hsa04010.xml",package="KEGGgraph")
> sfile
[1] "/Library/Frameworks/R.framework/Versions/3.5/Resources/library/KEGGgraph/extdata/hsa04010.xml"
> gR <- parseKGML2Graph(sfile,expandGenes=TRUE)
Error in parseKGML2Graph(sfile, expandGenes = TRUE) : 
  could not find function "parseKGML2Graph"

> sessioninfo()
Error in sessioninfo() : could not find function "sessioninfo"
 

 

kegggraph biocinstaller • 659 views
ADD COMMENT
0
Entering edit mode
Mike Smith ★ 5.8k
@mike-smith
Last seen 5 hours ago
EMBL Heidelberg / de.NBI

You need to load the library before you can use the functions it contains. Try:

library(KEGGgraph)
getKGMLurl("hsa00020")
ADD COMMENT
1
Entering edit mode

Yes, finally figured that out. Thank you for helping a newb. :(

ADD REPLY

Login before adding your answer.

Traffic: 303 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6