R package Installation Errors
1
0
Entering edit mode
@zhang-jacob-zhongfa-1416
Last seen 7.9 years ago
Hello, everybody: I just installed the latest version of R and trying to install the packages. The eriee thing is: while for some package, it works fine, for others, it won't install. Here is one of the similar error messages from one failed installation. Can anybody take a look and figure out a solution? I sense it is something related to the shared library. Jacob install.packages("aws") trying URL 'http://www.biometrics.mtu.edu/CRAN/src/contrib/aws_1.3-2.tar.gz' Content type 'application/x-gzip' length 52774 bytes opened URL ================================================== downloaded 51Kb * Installing *source* package 'aws' ... ** libs g77 -fPIC -g -O2 -c aws.f -o aws.o g77 -fPIC -g -O2 -c dgemm.f -o dgemm.o g77 -fPIC -g -O2 -c eaws.f -o eaws.o g77 -fPIC -g -O2 -c hawsuni.f -o hawsuni.o g77 -fPIC -g -O2 -c laws.f -o laws.o gcc -shared -L/usr/local/lib64 -o aws.so aws.o dgemm.o eaws.o hawsuni.o laws.o -lg2c -lm -lgcc_s -L/usr/home/jacob/R-2.2.1/lib -lR /usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse- linux /bin/ld: cannot find -lR collect2: ld returned 1 exit status make: *** [aws.so] Error 1 ERROR: compilation failed for package 'aws' ** Removing '/usr/home/jacob/R-2.2.1/library/aws' The downloaded packages are in /tmp/Rtmpe25813/downloaded_packages Warning message: installation of package 'aws' had non-zero exit status in: install.packages("aws") > sessionInfo() R version 2.2.1, 2005-12-20, x86_64-unknown-linux-gnu attached base packages: [1] "tools" "splines" "methods" "stats" "graphics" "grDevices" [7] "utils" "datasets" "base" other attached packages: affy Biobase ctv survival xgobi "1.8.1" "1.8.0" "0.3-1" "2.20" "1.2-13" This email message, including any attachments, is for the so...{{dropped}}
Survival Biobase affy Survival Biobase affy • 3.2k views
ADD COMMENT
0
Entering edit mode
@martin-morgan-1513
Last seen 2 days ago
United States
Hi Jacob -- It looks like you're using a non-Windows R. You probably need to re-configure R to build a shared library, and then to re-make R. Do this with something like ./configure --enable-R-shlib make to build R in the source tree (better to build R 'out-of-tree', though by first making a directory in some convenient location, cd to the directory, then path/to/R source/configure --enable-R-shlib and make). See configure --help for more options, and the R installation and administration manual, section 2, e.g., at http://cran.fhcrc.org/doc/manuals/R-admin.html for more information. Hope that helps, Martin "Zhang, Jacob" <jacob.zhang at="" vai.org=""> writes: > Hello, everybody: > > I just installed the latest version of R and trying to install the > packages. The eriee thing is: while for some package, it works fine, for > others, it won't install. Here is one of the similar error messages from > one failed installation. > > > Can anybody take a look and figure out a solution? I sense it is > something related to the shared library. > > Jacob > > > > install.packages("aws") > trying URL > 'http://www.biometrics.mtu.edu/CRAN/src/contrib/aws_1.3-2.tar.gz' > Content type 'application/x-gzip' length 52774 bytes > opened URL > ================================================== > downloaded 51Kb > > * Installing *source* package 'aws' ... > ** libs > g77 -fPIC -g -O2 -c aws.f -o aws.o > g77 -fPIC -g -O2 -c dgemm.f -o dgemm.o > g77 -fPIC -g -O2 -c eaws.f -o eaws.o > g77 -fPIC -g -O2 -c hawsuni.f -o hawsuni.o > g77 -fPIC -g -O2 -c laws.f -o laws.o > gcc -shared -L/usr/local/lib64 -o aws.so aws.o dgemm.o eaws.o hawsuni.o > laws.o -lg2c -lm -lgcc_s -L/usr/home/jacob/R-2.2.1/lib -lR > /usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse- linux > /bin/ld: cannot find -lR > collect2: ld returned 1 exit status > make: *** [aws.so] Error 1 > ERROR: compilation failed for package 'aws' > ** Removing '/usr/home/jacob/R-2.2.1/library/aws' > > The downloaded packages are in > /tmp/Rtmpe25813/downloaded_packages > Warning message: > installation of package 'aws' had non-zero exit status in: > install.packages("aws") >> sessionInfo() > R version 2.2.1, 2005-12-20, x86_64-unknown-linux-gnu > > attached base packages: > [1] "tools" "splines" "methods" "stats" "graphics" > "grDevices" > [7] "utils" "datasets" "base" > > other attached packages: > affy Biobase ctv survival xgobi > "1.8.1" "1.8.0" "0.3-1" "2.20" "1.2-13" > > This email message, including any attachments, is for the so...{{dropped}} > > _______________________________________________ > Bioconductor mailing list > Bioconductor at stat.math.ethz.ch > https://stat.ethz.ch/mailman/listinfo/bioconductor
ADD COMMENT

Login before adding your answer.

Traffic: 225 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6