Question: trouble with installing "affyio"
0
gravatar for shidaxia
13 months ago by
shidaxia0
shidaxia0 wrote:

Hi list,

I was trying to install GEOsubmission and got the following error message, which was caused during the installation of a required package: affyio.  Another piece of information is that I was trying do this inside a "rocker/rstudio:3.5.0" docker image.  Not sure if that has anything to do with the error.

Thanks!

Tao

===============================================================================

> .libPaths(new="/home/rstudio/R/R_3.5.1/")
> if (!requireNamespace("BiocManager", quietly = TRUE))
+     install.packages("BiocManager")
Installing package into ‘/home/rstudio/R/R_3.5.1’
(as ‘lib’ is unspecified)
trying URL 'https://mran.microsoft.com/snapshot/2018-09-30/src/contrib/BiocManager_1.30.2.tar.gz'
Content type 'application/octet-stream' length 240719 bytes (235 KB)
==================================================
downloaded 235 KB


The downloaded source packages are in
	‘/tmp/RtmpMXIr67/downloaded_packages’
> BiocManager::install("GEOsubmission", version = "3.8")
Bioconductor version 3.8 (BiocManager 1.30.2), R 3.5.0 (2018-04-23)
Installing package(s) 'BiocVersion', 'GEOsubmission'
also installing the dependencies ‘affyio’, ‘affy’

trying URL 'https://bioconductor.org/packages/3.8/bioc/src/contrib/affyio_1.52.0.tar.gz'
Content type 'application/x-gzip' length 109516 bytes (106 KB)
==================================================
downloaded 106 KB

trying URL 'https://bioconductor.org/packages/3.8/bioc/src/contrib/affy_1.60.0.tar.gz'
Content type 'application/x-gzip' length 1316870 bytes (1.3 MB)
==================================================
downloaded 1.3 MB

trying URL 'https://bioconductor.org/packages/3.8/bioc/src/contrib/BiocVersion_3.8.0.tar.gz'
Content type 'application/x-gzip' length 994 bytes
==================================================
downloaded 994 bytes

trying URL 'https://bioconductor.org/packages/3.8/bioc/src/contrib/GEOsubmission_1.34.0.tar.gz'
Content type 'application/x-gzip' length 136725 bytes (133 KB)
==================================================
downloaded 133 KB

checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for main in -lz... no
checking for pthread_create in -lpthread... yes
checking if we can use pthreads... yes
checking if PTHREAD_STACK_MIN is defined... yes
configure: Enabling threading for affyio
configure: creating ./config.status
config.status: creating src/Makevars
gcc -I"/usr/local/lib/R/include" -DNDEBUG -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_LIBPTHREAD=1 -DUSE_PTHREADS=1  -I/usr/local/include  -g -O2   -fpic  -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g  -c fread_functions.c -o fread_functions.o
/usr/local/lib/R/etc/Makeconf:159: recipe for target 'fread_functions.o' failed

The downloaded source packages are in
	‘/tmp/RtmpMXIr67/downloaded_packages’
Update old packages: 'Biobase', 'BiocGenerics', 'BiocInstaller', 'BiocManager', 'data.table', 'digest', 'dplyr', 'DT', 'evaluate', 'fansi', 'ggplot2', 'htmlwidgets', 'limma', 'mime', 'preprocessCore', 'R6',
  'Rcpp', 'rlang', 'rstudioapi', 'shiny', 'tidyselect', 'zlibbioc', 'docopt', 'glue', 'littler', 'stringi'
Update all/some/none? [a/s/n]: 
n
Warning messages:
1: In install.packages(pkgs = doing, lib = lib, repos = repos, ...) :
  installation of package ‘affyio’ had non-zero exit status
2: In install.packages(pkgs = doing, lib = lib, repos = repos, ...) :
  installation of package ‘affy’ had non-zero exit status
3: In install.packages(pkgs = doing, lib = lib, repos = repos, ...) :
  installation of package ‘GEOsubmission’ had non-zero exit status
> sessionInfo()
R version 3.5.0 (2018-04-23)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Debian GNU/Linux 9 (stretch)

Matrix products: default
BLAS: /usr/lib/openblas-base/libblas.so.3
LAPACK: /usr/lib/libopenblasp-r0.2.19.so

locale:
 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C               LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8     LC_MONETARY=en_US.UTF-8    LC_MESSAGES=C              LC_PAPER=en_US.UTF-8      
 [8] LC_NAME=C                  LC_ADDRESS=C               LC_TELEPHONE=C             LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C       

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
 [1] BiocManager_1.30.2 bit_1.1-14         compiler_3.5.0     hms_0.4.2          DBI_1.0.0          tools_3.5.0        Rcpp_0.12.18       bit64_0.9-7        pkgconfig_2.0.2    rlang_0.2.2      
affyio rstudio docker r 3.5.0 • 229 views
ADD COMMENTlink written 13 months ago by shidaxia0

Guessing a little, but it looks like you don't have zlib

checking for main in -lz... no

but the R code seems to assume that it is available

affyio/src master$ grep ZLIB fread_functions.h
#define HAVE_ZLIB 1

You could try to install (the '-devel') version of the system library libz; I'm not sure how to do that exactly on your docker image.

ADD REPLYlink written 13 months ago by Martin Morgan ♦♦ 24k

Thank you very much, Martin! You're right about this. After

sudo apt-get install zlib1g-dev

And re-run the installation script. It worked! Similar error occurred when I was trying to install XVector package. This solved both problems.

Tao

ADD REPLYlink written 10 months ago by shidaxia0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 157 users visited in the last hour