Question: atacseqQC error while splittin the bamfile
0
gravatar for theodore.georgomanolis
5 months ago by
Germany

Hi all, anyone can help with the following from the ATACseqQC package:

objs <- splitBam(bamfile, tags=tags, outPath=outPath,
+                  txs=txs, genome=genome,
+                  conservation=phastCons100way.UCSC.hg19)

ERROR as follows:

[E::sam_parse1] unrecognized type N

[W::sam_read1] Parse error at line 26

[E::sam_parse1] unrecognized type N

[W::sam_read1] Parse error at line 26

Error in shiftGAlignmentsList(chunk0, positive = positive,negative = negative) : all(elementNROWS(gal) < 3) is not TRUE

this happens while I am trying to split the bam file into nucleosomefree, mono/di/trinucleosome areas

thank you beforehand

ADD COMMENTlink modified 5 months ago by contact0 • written 5 months ago by theodore.georgomanolis0
Answer: atacseqQC error while splittin the bamfile
0
gravatar for Ou, Jianhong
5 months ago by
Ou, Jianhong1.1k
United States
Ou, Jianhong1.1k wrote:

Hi,

Could you share me the bamfile which can repeat the error?

Jianhong.

From: "theodore.georgomanolis [bioc]" noreply@bioconductor.org Reply-To: "reply+316c39ef+code@bioconductor.org" <reply+316c39ef+code@bioconductor.org> Date: Sunday, May 5, 2019 at 10:22 AM To: "Jianhong Ou, Ph.D." jianhong.ou@duke.edu Subject: [bioc] atacseqQC error while splittin the bamfile

Activity on a post you are following on support.bioconductor.orghttps://urldefense.proofpoint.com/v2/url?u=https-3A__support.bioconductor.org&d=DwMCaQ&c=imBPVzF25OnBgGmVOlcsiEgHoG1i6YHLR0Sj_gZ4adc&r=PXg851DHXyo-Gs3eMIfeo49gUXVh-JSZu_MZDDxGun8&m=mjeKwwdmBi7GscOXZ286PlRB-INjIVKONsDUc7gNBxg&s=At4vkeLtZXEDjKUiw9QI6KxWogokoMCvxR-i56_Uv1o&e=

User theodore.georgomanolishttps://urldefense.proofpoint.com/v2/url?u=https-3A__support.bioconductor.org_u_7993_&d=DwMCaQ&c=imBPVzF25OnBgGmVOlcsiEgHoG1i6YHLR0Sj_gZ4adc&r=PXg851DHXyo-Gs3eMIfeo49gUXVh-JSZu_MZDDxGun8&m=mjeKwwdmBi7GscOXZ286PlRB-INjIVKONsDUc7gNBxg&s=41tnwQPRGp33poa-p_H_nax962uRWWJsGfLFfoPMcfQ&e= wrote Question: atacseqQC error while splittin the bamfilehttps://urldefense.proofpoint.com/v2/url?u=https-3A__support.bioconductor.org_p_120707_&d=DwMCaQ&c=imBPVzF25OnBgGmVOlcsiEgHoG1i6YHLR0Sj_gZ4adc&r=PXg851DHXyo-Gs3eMIfeo49gUXVh-JSZu_MZDDxGun8&m=mjeKwwdmBi7GscOXZ286PlRB-INjIVKONsDUc7gNBxg&s=ch79-dHbzeEhQfPpR42yt0ytiKSaEIb4EH84lwBnzp0&e=:

Hi all, anyone can help with the following from the ATACseqQC package:

objs <- splitBam(bamfile, tags=tags, outPath=outPath,

  • txs=txs, genome=genome,

  • conservation=phastCons100way.UCSC.hg19)

ERROR as follows:

[E::samparse1] unrecognized type N [W::samread1] Parse error at line 26 [E::samparse1] unrecognized type N [W::samread1] Parse error at line 26 Error in shiftGAlignmentsList(chunk0, positive = positive, negative = negative) : all(elementNROWS(gal) < 3) is not TRUE

this happens while I am trying to split the bam file into nucleosomefree, mono/di/trinucleosome areas

thank you beforehand

ADD COMMENTlink written 5 months ago by Ou, Jianhong1.1k

sorry for replying after so long I am sending you an email with the bam file

ADD REPLYlink written 5 months ago by theodore.georgomanolis0

by the way the script I used was the one provided I changed nothing in order to see if it works in my case. Session info:

> sessionInfo() R version 3.6.0 (2019-04-26) Platform: x86_64-pc-linux-gnu (64-bit) Running under: Linux Mint 18.3

Matrix products: default BLAS: /usr/lib/libblas/libblas.so.3.6.0 LAPACK: /usr/lib/lapack/liblapack.so.3.6.0

Random number generation: RNG: Mersenne-Twister Normal: Inversion Sample: Rounding locale: [1] LCCTYPE=enUS.UTF-8
LCNUMERIC=C LCTIME=enUS.UTF-8
LC
COLLATE=enUS.UTF-8 [5] LCMONETARY=deDE.UTF-8
LC
MESSAGES=enUS.UTF-8 LCPAPER=deDE.UTF-8 LCNAME=C
[9] LCADDRESS=C LCTELEPHONE=C
LCMEASUREMENT=deDE.UTF-8 LC_IDENTIFICATION=C

attached base packages: [1] grid parallel stats4 stats
graphics grDevices utils datasets methods base

other attached packages: [1] phastCons100way.UCSC.hg193.7.2
GenomicScores
1.8.0 [3] BSgenome.Hsapiens.UCSC.hg191.4.0 BSgenome1.52.0
[5] ATACseqQC1.8.0
TxDb.Hsapiens.UCSC.hg19.knownGene
3.2.2 [7] rGREAT1.16.0
ChIPpeakAnno
3.18.0 [9] VennDiagram1.6.20
futile.logger
1.4.3 [11] Biostrings2.52.0
XVector
0.24.0 [13] RMariaDB1.0.6
org.Hs.eg.db
3.8.2 [15] GenomicFeatures1.36.0
AnnotationDbi
1.46.0 [17] Biobase2.44.0
rtracklayer
1.44.0 [19] ChIPseeker1.20.0
GenomicRanges
1.36.0 [21] GenomeInfoDb1.20.0
IRanges
2.18.0 [23] S4Vectors0.22.0
BiocGenerics
0.30.0

ADD REPLYlink written 5 months ago by theodore.georgomanolis0

Hi, Have a try with newest version of ATACseqQC. The error should be handled by the program.

Jianhong.

ADD REPLYlink written 4 months ago by Ou, Jianhong1.1k

Hi, I am getting the same error with mm10 with v1.8.5 downloaded 8/2/19. Is there any resolution or recommendation for this? Thanks!

Edit - it is giving the same error with 'splitBam' function in v1.9.7 downloaded from github. However, this error has disappeared when using shiftGAlignmentsList in v1.9.7. With v1.8.5 from Bioconductor, both functions gave the error.

ADD REPLYlink modified 10 weeks ago • written 10 weeks ago by ian.beddows0

you can update to the development version. Or set flag=scanBamFlag(isSecondaryAlignment = FALSE, isUnmappedQuery=FALSE, isNotPassingQualityControls = FALSE, isSupplementaryAlignment = FALSE) for readBamFile in released version to overcome the issue of all(elementNROWS(gal) < 3) is not TRUE

see https://support.bioconductor.org/p/122819/#123135

From: "ian.beddows [bioc]" noreply@bioconductor.org Reply-To: "reply+9ee280d2+code@bioconductor.org" <reply+9ee280d2+code@bioconductor.org> Date: Friday, August 2, 2019 at 9:40 AM To: "Jianhong Ou, Ph.D." jianhong.ou@duke.edu Subject: [bioc] C: atacseqQC error while splittin the bamfile

Activity on a post you are following on support.bioconductor.orghttps://urldefense.proofpoint.com/v2/url?u=https-3A__support.bioconductor.org&d=DwMCaQ&c=imBPVzF25OnBgGmVOlcsiEgHoG1i6YHLR0Sj_gZ4adc&r=PXg851DHXyo-Gs3eMIfeo49gUXVh-JSZu_MZDDxGun8&m=VtppQj4W1krIwaMiKKEZyV4S7oN-rHihMqROuu_fRio&s=QV61Y4n6aFg1XovygloDRAUEr9nemJtoQd7Pbin2nyw&e=

User ian.beddowshttps://urldefense.proofpoint.com/v2/url?u=https-3A__support.bioconductor.org_u_21527_&d=DwMCaQ&c=imBPVzF25OnBgGmVOlcsiEgHoG1i6YHLR0Sj_gZ4adc&r=PXg851DHXyo-Gs3eMIfeo49gUXVh-JSZu_MZDDxGun8&m=VtppQj4W1krIwaMiKKEZyV4S7oN-rHihMqROuu_fRio&s=h2KjbO0EffKD6uFncnz6W2MFhn9u-6oR34jtnO97CWQ&e= wrote Comment: atacseqQC error while splittin the bamfilehttps://urldefense.proofpoint.com/v2/url?u=https-3A__support.bioconductor.org_p_120707_-23123438&d=DwMCaQ&c=imBPVzF25OnBgGmVOlcsiEgHoG1i6YHLR0Sj_gZ4adc&r=PXg851DHXyo-Gs3eMIfeo49gUXVh-JSZu_MZDDxGun8&m=VtppQj4W1krIwaMiKKEZyV4S7oN-rHihMqROuu_fRio&s=C1XzjEp81u7RUI9Y8ODcLb3409zIpBPkXXD3gQZLGJg&e=:

Hi, I am getting the same error with mm10 with v1.8.5 downloaded 8/2/19. Is there any resolution or recommendation for this? Thanks!

ADD REPLYlink written 10 weeks ago by Ou, Jianhong1.1k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 231 users visited in the last hour