Question: Error: Bioconductor version '3.8' requires R version '3.5'
1
gravatar for romanowska.j
5 months ago by
romanowska.j10
romanowska.j10 wrote:

Hi, I have been using bioconductor for a while now, but today suddenly I got this error message when trying to run BiocManager::install()

Error: Bioconductor version '3.8' requires R version '3.5'; see https://bioconductor.org/install

I have R 3.6, so I have no idea why this error appears. I've also re-installed BiocManager, but this didn't help.

software error • 4.5k views
ADD COMMENTlink modified 5 months ago by Mike Smith4.0k • written 5 months ago by romanowska.j10
Answer: Error: Bioconductor version '3.8' requires R version '3.5'
11
gravatar for Mike Smith
5 months ago by
Mike Smith4.0k
EMBL Heidelberg / de.NBI
Mike Smith4.0k wrote:

It looks like maybe you've updated R, but are using the same library of packages that were installed when running R 3.5. If you're now using R 3.6 then you want to be using Bioconductor version 3.9. Try running the following to update everything to the newer version of Bioconductor:

BiocManager::install(version = "3.9")
ADD COMMENTlink written 5 months ago by Mike Smith4.0k

I am having the same problems after installing R 3.6. BiocManager version is 3.9 but I am unable to upgrade any bioconductor package. Even using BiocUpgrade fails.

> BiocManager::install(version = "3.9")
Bioconductor version 3.9 (BiocManager 1.30.4), R 3.6.0 (2019-04-26)
> source("https://bioconductor.org/biocLite.R")
Bioconductor version 3.7 (BiocInstaller 1.30.0), ?biocLite for help
A newer version of Bioconductor is available for this version of R, ?BiocUpgrade for help
> biocLite("phyloseq")
BioC_mirror: https://bioconductor.org
Using Bioconductor 3.7 (BiocInstaller 1.30.0), R 3.6.0 (2019-04-26).
Installing package(s) ‘phyloseq’
also installing the dependencies ‘Rhdf5lib’, ‘zlibbioc’, ‘rhdf5’, ‘S4Vectors’, ‘IRanges’, ‘XVector’, ‘Biobase’, ‘biomformat’, ‘Biostrings’, ‘multtest’

Warning: unable to access index for repository https://bioconductor.org/packages/3.7/bioc/bin/macosx/el-capitan/contrib/3.6:
  cannot open URL 'https://bioconductor.org/packages/3.7/bioc/bin/macosx/el-capitan/contrib/3.6/PACKAGES'
Warning: unable to access index for repository https://bioconductor.org/packages/3.7/data/annotation/bin/macosx/el-capitan/contrib/3.6:
  cannot open URL 'https://bioconductor.org/packages/3.7/data/annotation/bin/macosx/el-capitan/contrib/3.6/PACKAGES'
Warning: unable to access index for repository https://bioconductor.org/packages/3.7/data/experiment/bin/macosx/el-capitan/contrib/3.6:
  cannot open URL 'https://bioconductor.org/packages/3.7/data/experiment/bin/macosx/el-capitan/contrib/3.6/PACKAGES'
Warning: unable to access index for repository https://bioconductor.org/packages/3.7/workflows/bin/macosx/el-capitan/contrib/3.6:
  cannot open URL 'https://bioconductor.org/packages/3.7/workflows/bin/macosx/el-capitan/contrib/3.6/PACKAGES'
Packages which are only available in source form, and may need compilation of C/C++/Fortran:
  ‘Rhdf5lib’ ‘zlibbioc’ ‘rhdf5’ ‘S4Vectors’ ‘IRanges’ ‘XVector’ ‘Biobase’ ‘Biostrings’ ‘multtest’
Do you want to attempt to install these from sources? (Yes/no/cancel) no
> biocLite("BiocUpgrade")
Upgrade all packages to Bioconductor version 3.8? [y/n]: 
y
Installing package into ‘/Users/eugenioparente/Library/R/3.6/library’
(as ‘lib’ is unspecified)
Bioconductor version 3.7 (BiocInstaller 1.30.0), ?biocLite for help
A newer version of Bioconductor is available for this version of R, ?BiocUpgrade for help
'BiocInstaller' changed to version 1.30.0
BioC_mirror: https://bioconductor.org
Using Bioconductor 3.7 (BiocInstaller 1.30.0), R 3.6.0 (2019-04-26).
ADD REPLYlink written 5 months ago by parenteeug0
2

You do not need to use source("https://bioconductor.org/biocLite.R") or biocLite() any more - these have been been deprecated for a while now.

There's more information at http://bioconductor.org/install/ but to summarise you can install a package using BiocManager::install() e.g.

BiocManager::install("phyloseq")
ADD REPLYlink modified 5 months ago • written 5 months ago by Mike Smith4.0k

biocLite is used for the R older version of R (<3.5).

ADD REPLYlink written 5 months ago by ravisaroch0

Thanks, I've actually restarted my PC and tried re-installing once more and it worked. Sometimes one just needs to tell the problem out loud and the solution appears ;)

ADD REPLYlink written 5 months ago by romanowska.j10
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 176 users visited in the last hour