S4Vectors (and others) install error
0
0
Entering edit mode
@zcrane-smith-20828
Last seen 2.5 years ago

Hi all

I am trying to install packages into my Rstudio. Running R version: 3.4.4. However the packages seem to download fine but then won't load for a lot of them? So for S4Vectors the download proceeded as follows:

biocLite("S4Vectors")
BioC_mirror: https://bioconductor.org
Using Bioconductor 3.6 (BiocInstaller 1.28.0), R 3.4.4 (2018-03-15).
Installing package(s) ‘S4Vectors’
trying URL 'https://bioconductor.org/packages/3.6/bioc/bin/windows/contrib/3.4/S4Vectors_0.16.0.zip'
Content type 'application/zip' length 2653765 bytes (2.5 MB)
downloaded 2.5 MB

package ‘S4Vectors’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in
    C:\Users\sejjzcr\AppData\Local\Temp\Rtmp8MmDrg\downloaded_packages
Old packages: 'checkmate', 'cluster', 'nlme', 'RcppArmadillo'
Update all/some/none? [a/s/n]: 
a

  There are binary versions available but the source versions are later:
                   binary      source needs_compilation
checkmate           1.9.1       1.9.3              TRUE
cluster             2.0.8       2.0.9              TRUE
nlme              3.1-137     3.1-140              TRUE
RcppArmadillo 0.9.300.2.0 0.9.400.3.0              TRUE

  Binaries will be installed
trying URL 'https://cran.rstudio.com/bin/windows/contrib/3.4/checkmate_1.9.1.zip'
Content type 'application/zip' length 735324 bytes (718 KB)
downloaded 718 KB

trying URL 'https://cran.rstudio.com/bin/windows/contrib/3.4/cluster_2.0.8.zip'
Content type 'application/zip' length 588040 bytes (574 KB)
downloaded 574 KB

trying URL 'https://cran.rstudio.com/bin/windows/contrib/3.4/nlme_3.1-137.zip'
Content type 'application/zip' length 2344000 bytes (2.2 MB)
downloaded 2.2 MB

trying URL 'https://cran.rstudio.com/bin/windows/contrib/3.4/RcppArmadillo_0.9.300.2.0.zip'
Content type 'application/zip' length 2241393 bytes (2.1 MB)
downloaded 2.1 MB

package ‘checkmate’ successfully unpacked and MD5 sums checked
package ‘cluster’ successfully unpacked and MD5 sums checked
package ‘nlme’ successfully unpacked and MD5 sums checked
package ‘RcppArmadillo’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in
    C:\Users\sejjzcr\AppData\Local\Temp\Rtmp8MmDrg\downloaded_packages

But then when I try and load the library it gives an error (which I can't seem to google my way around):

 library(S4Vectors)
Error: package or namespace load failed for ‘S4Vectors’:
 .onLoad failed in loadNamespace() for 'S4Vectors', details:
  call: .Call(.NAME, ..., PACKAGE = PACKAGE)
  error: "make_RAW_from_NA_LLINT" not available for .Call() for package "S4Vectors"

I get the same sort of error for GenomicRanges, BSgenome, Xvector, so all the good stuff...

Is this to do with the binary packages being in a different folder to the package downloads? I work on a university managed desktop but have had privileges to download into the folder where my packages (not the binary versions) are being downloaded, and I can see them in the R folder library there, so they do seem to download fine?

Any insight would be much appreciated, thanks all!

All the best, Zoe

s4vectors • 557 views
ADD COMMENT
0
Entering edit mode

Are there multiple versions of, e.g., S4Vectors installed? Investigate using .libPaths() and installed.packages(). If so, probably you are updating one installation, but then using another (older?) version. If your installation has a general-purpose entry in .libPaths(), you could try removing it (something like .libPaths(.libPaths()[-INDEX_OF_UNWANTED_PATH]).

ADD REPLY
0
Entering edit mode

Hi

Thanks for the input. Unfortunately however this is the only version installed according to installed.packages(), and the lib path is set correctly. We now think it seems likely to be due to the lack of admin privileges that the packages cannot load properly...

All the best, Zoe

ADD REPLY

Login before adding your answer.

Traffic: 521 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6