ChIPQC error: "names' attribute [9] must be the same length as the vector [7]"
0
2
Entering edit mode
analeigh.gui ▴ 20
@analeighgui-14556
Last seen 2.4 years ago

I saw a similar post using ChIPQC package for ATAC-Seq peaks quality check but not answer https://support.bioconductor.org/p/117577/#117670

As I have a different setting than the above post, so I want to detail my problems and ask for help.

I want to use ChIPQC package to check the quality of H3K4me3 and H3K27ac ChIP-seq quality.

library(tidyverse)
library(ChIPQC)

chipqc <- ChIPQC(experiment, 
                 annotation = "mm10", 
                 blacklist = "~/iris/genome/mouseGenomemm10/mm10.blacklist.bed",
                 chromosomes = "chr11")

ChIPQCreport(chipqc)

When I ran the function ChIPQC, I got the following error:

"Error in names(res) <- c("Reads", "Map%", "Filt%", "Dup%", "ReadL", "FragL", : 'names' attribute [9] must be the same length as the vector [7]"

I continued to run the ChIPQCreport, the same error popped up, though some quality plots did manage to generate.

The CoverageHistogramPlot showed all the samples have certain coverage. However, the PeakProfile plot, two of my samples show no signal at all, which is rather strange because the igv shows enrichment.

(in case you can't see the image, the link is next to it.)

ConverageHistogramPlot https://ibb.co/6XH67Rn

PeakProfile https://ibb.co/6XH67Rn

Random locus showing enrichment https://ibb.co/4Jv9G1X

Does anybody have some thoughts? Thanks in advance.

R version 3.6.0 (2019-04-26)
Platform: x86_64-apple-darwin15.6.0 (64-bit)
Running under: macOS Mojave 10.14.5

Matrix products: default
BLAS:   /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
LAPACK: /Library/Frameworks/R.framework/Versions/3.6/Resources/lib/libRlapack.dylib

locale:
[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats4    parallel  stats     graphics  grDevices utils     datasets  methods  
[9] base     

other attached packages:
 [1] ChIPQC_1.21.0                            DiffBind_2.13.0                         
 [3] forcats_0.4.0                            stringr_1.4.0                           
 [5] dplyr_0.8.1                              purrr_0.3.2                             
 [7] readr_1.3.1                              tidyr_0.8.3                             
 [9] tibble_2.1.3                             ggplot2_3.1.1                           
[11] tidyverse_1.2.1                          chipseq_1.35.0                          
[13] ShortRead_1.43.0                         GenomicAlignments_1.21.2                
[15] SummarizedExperiment_1.15.2              DelayedArray_0.11.0                     
[17] BiocParallel_1.19.0                      matrixStats_0.54.0                      
[19] TxDb.Mmusculus.UCSC.mm10.knownGene_3.4.7 GenomicFeatures_1.37.1                  
[21] AnnotationDbi_1.47.0                     Biobase_2.45.0                          
[23] GenomeInfoDbData_1.2.1                   Rsamtools_2.1.2                         
[25] Biostrings_2.53.0                        XVector_0.25.0                          
[27] GenomicRanges_1.37.11                    GenomeInfoDb_1.21.1                     
[29] IRanges_2.19.10                          S4Vectors_0.23.12                       
[31] BiocGenerics_0.31.4                     
ChIPQC • 1.4k views
ADD COMMENT
0
Entering edit mode

The problem is caused by single end data which would not return fragment length. I fixed it in my fork project. And I contacted the author and hope they will fix it in their next release.

https://github.com/shengqh/ChIPQC

ADD REPLY
0
Entering edit mode

Hi, I got the same problem. Thank you for the update and fixed it. I hope they will fix it in the new version.

ADD REPLY
0
Entering edit mode

Hi, there I update new version of this packages. But seems it didn't work I still got the same error.

Samples: 9 : V1_CTCF.Rep1 V1_CTCF.Rep2 ... Input_RM01_HIP Input_RM01_CBC Error in h(simpleError(msg, call)) : 在为't'函数选择方法时评估'x'参数出了错: 'names'属性的长度[9]必需和矢量的长度[7]一样

ADD REPLY
0
Entering edit mode
ChIPQCreport(chipobj,reportName = "CTCF ChIP-seq QC report",reportFolder = "ChIP QC report")
Error in h(simpleError(msg, call)) : 在为't'函数选择方法时评估'x'参数出了错: 'names'属性的长度[9]必需和矢量的长度[7]一样

It do generate some QC report pictures but the html files can't generate. Hope your reply! Many thanks!

ADD REPLY

Login before adding your answer.

Traffic: 340 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6