Question: Error in getBM
1
gravatar for erockkirk
3 months ago by
erockkirk10
erockkirk10 wrote:

There seems to be an error with the getBM function in biomaRt. The below code was working 3 days ago and now returns an error message. Any help would be appreciated. I'm working in R (version 3.6.0).

mart <- biomaRt::useMart(biomart = "ensembl", + dataset = "hsapiensgeneensembl", + host = 'http://www.ensembl.org')

ttg <- biomaRt::getBM( + attributes = c('mirbaseaccession', + 'mirbaseid', + 'mirbasetransname'), + mart = mart)

Error in biomaRt::getBM(attributes = c("mirbaseaccession", "mirbaseid", : The query to the BioMart webservice returned an invalid result: biomaRt expected a character string of length 1.

software error • 157 views
ADD COMMENTlink modified 12 weeks ago by YinCY10 • written 3 months ago by erockkirk10

The same problem happens to me right now, and it happened to me a couple of weeks ago too. . it's related to the web server of Ensembl, it's not working well. Hope there is a solution... Maybe it's a matter of time.

ADD REPLYlink written 3 months ago by rgeysels0

one solution I found was to use a different host, or alternate to whichever is working. host = 'http://useast.ensembl.org'

ADD REPLYlink written 12 weeks ago by erockkirk10
Answer: Error in getBM
1
gravatar for YinCY
12 weeks ago by
YinCY10
HangZhou, zhejaing
YinCY10 wrote:

Try use useEnsembl() function instead of useMart() which can choose different mirror, that you can choose the one that closest to you. useEnsembl(mirror = c("eastusa", "westusa", "asia"))

ADD COMMENTlink written 12 weeks ago by YinCY10
Answer: Error in getBM
0
gravatar for Puks
3 months ago by
Puks10
Estonia
Puks10 wrote:

A previous post on this might be helpful for you: https://support.bioconductor.org/p/121331/

ADD COMMENTlink written 3 months ago by Puks10
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 356 users visited in the last hour