Question: SummarizedExperiment no function found corresponding to methods exports from XVector for concatenateObjects
0
gravatar for zhang.jianhai
16 days ago by
zhang.jianhai0 wrote:

enter code hereHi,

I am using the package "SummarizedExperiment " as a dependency in my own R package. I got this warning "no function found corresponding to methods exports from ‘XVector’ for: ‘concatenateObjects" when library(SummarizedExperiment). This warning occurs in "R CMD check". How to resolve it?

sessionInfo()
R version 3.5.1 (2018-07-02)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 16.04.5 LTS

Matrix products: default
BLAS: /usr/lib/libblas/libblas.so.3.6.0
LAPACK: /usr/lib/lapack/liblapack.so.3.6.0

locale:
 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C              
 [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8    
 [5] LC_MONETARY=en_US.UTF-8    LC_MESSAGES=en_US.UTF-8   
 [7] LC_PAPER=en_US.UTF-8       LC_NAME=C                 
 [9] LC_ADDRESS=C               LC_TELEPHONE=C            
[11] LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C       

attached base packages:
[1] parallel  stats4    stats     graphics  grDevices utils     datasets 
[8] methods   base     

other attached packages:
 [1] SummarizedExperiment_1.10.1 DelayedArray_0.6.6         
 [3] BiocParallel_1.14.2         matrixStats_0.54.0         
 [5] Biobase_2.40.0              GenomicRanges_1.34.0       
 [7] GenomeInfoDb_1.16.0         IRanges_2.16.0             
 [9] S4Vectors_0.20.1            BiocGenerics_0.26.0        

loaded via a namespace (and not attached):
 [1] lattice_0.20-35        bitops_1.0-6           grid_3.5.1            
 [4] zlibbioc_1.26.0        XVector_0.20.0         Matrix_1.2-14         
 [7] tools_3.5.1            RCurl_1.95-4.11        compiler_3.5.1        
[10] GenomeInfoDbData_1.1.0

Thanks.

summarizedexperiment • 77 views
ADD COMMENTlink modified 15 days ago by Martin Morgan ♦♦ 24k • written 16 days ago by zhang.jianhai0
Answer: SummarizedExperiment no function found corresponding to methods exports from XVe
0
gravatar for Martin Morgan
15 days ago by
Martin Morgan ♦♦ 24k
United States
Martin Morgan ♦♦ 24k wrote:

These errors (unknown functions) often occur when your installation includes packages from different versions of Bioconductor. Make sure

BiocManager::version()

returns the version that you want to use. Then that

BiocManager::valid()

reports no problems.

ADD COMMENTlink modified 14 days ago • written 15 days ago by Martin Morgan ♦♦ 24k

Resolved. Thanks a lot!

ADD REPLYlink written 12 days ago by zhang.jianhai0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 148 users visited in the last hour