Rgraphviz installation failing
1
0
Entering edit mode
mascaretti • 0
@mascaretti-22851
Last seen 21 months ago

Installation of Rgraphviz fails

Installation of the Rgrapvhiz package fails.


Installation code

To install the package, I run the following:

if (!requireNamespace("BiocManager", quietly = TRUE))
  install.packages("BiocManager")
BiocManager::install("Rgraphviz")

Error

The installation process exits with non-zero status reporting the following:

Error: package or namespace load failed for ‘Rgraphviz’:
 .onLoad failed in loadNamespace() for 'Rgraphviz', details:
  call: value[[3L]](cond)
  error: unable to load shared object '/home/andrea/R/x86_64-pc-linux-gnu-library/3.6/00LOCK-Rgraphviz/00new/Rgraphviz/libs/Rgraphviz.so':
  /home/andrea/R/x86_64-pc-linux-gnu-library/3.6/00LOCK-Rgraphviz/00new/Rgraphviz/libs/Rgraphviz.so: undefined symbol: _ZGVdN4vv___pow_finite

  Rgraphviz is unable to be loaded.  This typically is a symptom of an
  installation problem.  From 2.x.x onwards, Graphviz ought to come
  bundled with Rgraphviz.

  If you are trying to use an external Graphviz, see additional
  instructions in the 'README' file of the Rgraphviz 'source'
  distribution, available at

  http://bioconductor.org/packages/release/bioc/html/Rgraphviz.html

  Ask further questions on the Bioconductor mailing list

  http://bioconductor.org/docs/mailList.html


  Rgraphviz is unable to be loaded.  This typically is a symptom of an
  installation problem.  From 2.x.x onwards, Graphviz ought to come
  bundled with Rgraphviz.

  If you are trying to use an external Graphviz, see additional
  instructions in the 'README' file of the Rgraphviz 'source'
  distribution, available at

  http://bioconductor.org/packages/release/bioc/html/Rgraphviz.html

  Ask further questions on the Bioconductor mailing list

  http://bioconductor.org/docs/mailList.html


Errore: loading failed
Esecuzione interrotta

Session Info

The output of sessionInfo() is the following:

R version 3.6.2 (2019-12-12)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Manjaro Linux

Matrix products: default
BLAS/LAPACK: /usr/lib/libopenblas_zenp-r0.3.7.so

locale:
 [1] LC_CTYPE=it_IT.UTF-8       LC_NUMERIC=C               LC_TIME=it_IT.UTF-8        LC_COLLATE=it_IT.UTF-8     LC_MONETARY=it_IT.UTF-8   
 [6] LC_MESSAGES=it_IT.UTF-8    LC_PAPER=it_IT.UTF-8       LC_NAME=C                  LC_ADDRESS=C               LC_TELEPHONE=C            
[11] LC_MEASUREMENT=it_IT.UTF-8 LC_IDENTIFICATION=C       

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
 [1] BiocManager_1.30.10 compiler_3.6.2      htmltools_0.4.0     tools_3.6.2         yaml_2.2.1          Rcpp_1.0.3          rmarkdown_2.1      
 [8] knitr_1.27          xfun_0.12           digest_0.6.23       rlang_0.4.4         evaluate_0.14   

GCC Version

I am running GCC 9.2.0

~ » gcc -v                                         andrea@andrea-pc
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/lto-wrapper
Target: x86_64-pc-linux-gnu
Configured with: /build/gcc/src/gcc/configure --prefix=/usr --libdir=/usr/lib --libexecdir=/usr/lib --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=https://bugs.archlinux.org/ --enable-languages=c,c++,ada,fortran,go,lto,objc,obj-c++,d --enable-shared --enable-threads=posix --with-system-zlib --with-isl --enable-__cxa_atexit --disable-libunwind-exceptions --enable-clocale=gnu --disable-libstdcxx-pch --disable-libssp --enable-gnu-unique-object --enable-linker-build-id --enable-lto --enable-plugin --enable-install-libiberty --with-linker-hash-style=gnu --enable-gnu-indirect-function --enable-multilib --disable-werror --enable-checking=release --enable-default-pie --enable-default-ssp --enable-cet=auto gdc_include_dir=/usr/include/dlang/gdc
Thread model: posix
gcc version 9.2.0 (GCC) 
software error Rgraphviz • 369 views
ADD COMMENT
2
Entering edit mode
Mike Smith ★ 5.2k
@mike-smith
Last seen 4 hours ago
EMBL Heidelberg / de.NBI

This looks like a pretty similar error message to the problem reported in https://support.bioconductor.org/p/115919/#116290

Do you use -O3 with gcc? It seems like Rgraphviz isn't able to cope with that level of compiler optimization. Maybe you can try lowering it to -O2?

ADD COMMENT
0
Entering edit mode

You were right. I should have included that I had a Makevars of the form:

CFLAGS=-O3 -Wall -pedantic -march=native -mtune=native -pipe
CXXFLAGS=-O3 -Wall -pedantic -march=native -mtune=native -pipe

By changing the optimisation options, everything works alright. Many thanks!

ADD REPLY

Login before adding your answer.

Traffic: 332 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6