Cannot properly finish biomaRt query
1
0
Entering edit mode
bas_work ▴ 10
@bas_work-22458
Last seen 9 weeks ago
Netherlands

Hi,

I am trying to get hence symbols using biomaRt, but it fails. I get the following warnings:

dfbiomarttmp <- getBM(attributes = c("ensemblgeneid", "hgncsymbol", "genebiotype", "chromosomename"), filter = "ensemblgeneid", values = dfbiomrttmp$ensemblgene_id, mart = ensembl) Cache found Warning messages: 1: select_() is deprecated as of dplyr 0.7.0. Please use select() instead. This warning is displayed once every 8 hours. Call lifecycle::last_warnings() to see where this warning was generated. 2: filter_() is deprecated as of dplyr 0.7.0. Please use filter() instead. See vignette('programming') for more help This warning is displayed once every 8 hours. Call lifecycle::last_warnings() to see where this warning was generated.

lifecycle::lastwarnings() [[1]] <deprecated> message: select_() is deprecated as of dplyr 0.7.0. Please use select() instead. This warning is displayed once every 8 hours. Call lifecycle::last_warnings() to see where this warning was generated. backtrace: 1. biomaRt::getBM(...) 2. biomaRt:::.checkCache(bfc, hash) 4. BiocFileCache::bfcquery(bfc, query = hash, field = "rname") 7. BiocFileCache:::.getallcolnames(x) 10. BiocFileCache:::.sqlgetresourcetable(bfc) 14. dplyr::select(., ~-id) 20. dplyr:::lazydeprec("select", hint = FALSE)

[[2]] <deprecated> message: filter_() is deprecated as of dplyr 0.7.0. Please use filter() instead. See vignette('programming') for more help This warning is displayed once every 8 hours. Call lifecycle::last_warnings() to see where this warning was generated. backtrace: 1. biomaRt::getBM(...) 2. biomaRt:::.checkCache(bfc, hash) 4. BiocFileCache::bfcquery(bfc, query = hash, field = "rname") 6. BiocFileCache::bfcinfo(x, rids) 7. BiocFileCache:::.sqlgetresourcetable(x, rids) 14. dplyr::filter(., ~rid == rids) 19. dplyr:::lazy_deprec("filter")

sessionInfo() R version 3.6.3 (2020-02-29) Platform: x86_64-apple-darwin15.6.0 (64-bit) Running under: macOS Catalina 10.15.5

Matrix products: default BLAS: /Library/Frameworks/R.framework/Versions/3.6/Resources/lib/libRblas.0.dylib LAPACK: /Library/Frameworks/R.framework/Versions/3.6/Resources/lib/libRlapack.dylib

locale: [1] C/UTF-8/C/C/C/C

attached base packages: [1] stats4 parallel stats graphics grDevices utils datasets [8] methods base

other attached packages: [1] biomaRt2.42.1 DESeq21.26.0
[3] SummarizedExperiment1.16.1 DelayedArray0.12.3
[5] BiocParallel1.20.1 matrixStats0.56.0
[7] GenomicRanges1.38.0 GenomeInfoDb1.22.1
[9] IRanges2.20.2 S4Vectors0.24.4
[11] Biobase2.46.0 BiocGenerics0.32.0

loaded via a namespace (and not attached): [1] httr1.4.1 bit640.9-7 splines3.6.3
[4] assertthat
0.2.1 Formula1.2-3 askpass1.1
[7] BiocFileCache1.10.2 latticeExtra0.6-29 blob1.2.1
[10] GenomeInfoDbData
1.2.2 progress1.2.2 pillar1.4.4
[13] RSQLite2.2.0 backports1.1.7 lattice0.20-41
[16] glue
1.4.1 digest0.6.25 RColorBrewer1.1-2
[19] XVector0.26.0 checkmate2.0.0 colorspace1.4-1
[22] htmltools
0.4.0 Matrix1.2-18 XML3.99-0.3
[25] pkgconfig2.0.3 genefilter1.68.0 zlibbioc1.32.0
[28] purrr
0.3.4 xtable1.8-4 scales1.1.1
[31] jpeg0.1-8.1 openssl1.4.1 htmlTable1.13.3
[34] tibble
3.0.1 annotate1.64.0 generics0.0.2
[37] ggplot23.3.1 ellipsis0.3.1 nnet7.3-14
[40] survival
3.1-12 magrittr1.5 crayon1.3.4
[43] memoise1.1.0 foreign0.8-76 prettyunits1.1.1
[46] tools
3.6.3 data.table1.12.8 hms0.5.3
[49] lifecycle0.2.0 stringr1.4.0 locfit1.5-9.4
[52] munsell
0.5.0 cluster2.1.0 AnnotationDbi1.48.0
[55] compiler3.6.3 rlang0.4.6 grid3.6.3
[58] RCurl
1.98-1.2 rstudioapi0.11 rappdirs0.3.1
[61] htmlwidgets1.5.1 bitops1.0-6 base64enc0.1-3
[64] gtable
0.3.0 curl4.3 DBI1.1.0
[67] R62.4.1 gridExtra2.3 knitr1.28
[70] dplyr
1.0.0 bit1.1-15.2 Hmisc4.4-0
[73] stringi1.4.6 Rcpp1.0.4.6 geneplotter1.64.0
[76] vctrs
0.3.0 rpart4.1-15 acepack1.4.1
[79] png0.1-7 dbplyr1.4.4 tidyselect1.1.0
[82] xfun
0.14

It used to work just fine. Many thanks for your help.

Kind regards, Bas

software error annotation biomart • 1.4k views
ADD COMMENT
0
Entering edit mode

To clarify: I also do not get the metadata back from Ensembl! It used to work just fine unit a few days ago.

Kind regards, Bas

ADD REPLY
0
Entering edit mode

I suspect the problem lies here: https://github.com/tidyverse/dplyr/issues/5294

A royal pain in the butt.

Kind regards, Bas

ADD REPLY
0
Entering edit mode
bas_work ▴ 10
@bas_work-22458
Last seen 9 weeks ago
Netherlands

Solved. I could trace it to a typo in my own script. My apologies!

Regards, Bas

ADD COMMENT
0
Entering edit mode

I am running into the same issue, can you elaborate on how you solved it?

ADD REPLY

Login before adding your answer.

Traffic: 252 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6