Rsamtools is not available for (for R version 4.0.2)
1
0
Entering edit mode
yusuke_suita ▴ 10
@yusuke_suita-23760
Last seen 2.4 years ago

When I try to read a Bamfiel and try to use "Rsamtools" function, then R returns the messagings below.

"Warning in install.packages : package ‘Rsamtools’ is not available (for R version 4.0.2)".

This R version is the latest version. Is there anything else we can do?

Thank you very much for the help!

Rsamtools • 2.0k views
ADD COMMENT
1
Entering edit mode

What command are you using to install Rsamtools? It's hard for people to give advice if you don't show what you've done to get to the error message.

ADD REPLY
1
Entering edit mode

Thank you very much for the answers! After using this (BiocManager::install("Rsamtools")), it worked!

Apology for not having provided the commands, it was my first time to use this forum. Now I got to know how to use it. Thank you very much for the insights!

ADD REPLY
2
Entering edit mode
ATpoint ★ 1.9k
@atpoint-13662
Last seen 2 hours ago
Germany

You seem to be using install.packages for installation. Rsamtools is a Bioconductor package, therefore use BiocManager::install("Rsamtools") after installing Bioconductor as described: https://bioconductor.org/install/

ADD COMMENT
0
Entering edit mode

I had the same problem (R 4.2.0) I used BiocManager::install("Rsamtools", force = TRUE)

And it is working fine

ADD REPLY

Login before adding your answer.

Traffic: 460 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6