DESeq2 installation failur in r version 4.0.2
1
0
Entering edit mode
@arminshahpari-24215
Last seen 11 months ago

Hello everyone,

I am trying to install DESeq2 package in r version 4.0.2 but it doesn't work. I have searched a lot on different pages but I couldn't find a solution. Could anyone help me, please?

Here are the codes that I am running and the errors that I have received:

codes:

    if (!requireNamespace("BiocManager", quietly = TRUE))
  install.packages("BiocManager")
BiocManager::install("DESeq2")

And the errors:

* installing *source* package ‘RCurl’ ...
** package ‘RCurl’ successfully unpacked and MD5 sums checked
** using staged installation
checking for curl-config... no
Cannot find curl-config
ERROR: configuration failed for package ‘RCurl’
* removing ‘/home/user-linux/R/x86_64-pc-linux-gnu-library/4.0/RCurl’
Warning in install.packages :
  installation of package ‘RCurl’ had non-zero exit status
ERROR: dependency ‘RCurl’ is not available for package ‘GenomeInfoDb’
* removing ‘/home/user-linux/R/x86_64-pc-linux-gnu-library/4.0/GenomeInfoDb’
Warning in install.packages :
  installation of package ‘GenomeInfoDb’ had non-zero exit status
ERROR: dependency ‘RCurl’ is not available for package ‘annotate’
* removing ‘/home/user-linux/R/x86_64-pc-linux-gnu-library/4.0/annotate’
Warning in install.packages :
  installation of package ‘annotate’ had non-zero exit status
ERROR: dependency ‘GenomeInfoDb’ is not available for package ‘GenomicRanges’
* removing ‘/home/user-linux/R/x86_64-pc-linux-gnu-library/4.0/GenomicRanges’
Warning in install.packages :
  installation of package ‘GenomicRanges’ had non-zero exit status
ERROR: dependency ‘annotate’ is not available for package ‘genefilter’
* removing ‘/home/user-linux/R/x86_64-pc-linux-gnu-library/4.0/genefilter’
Warning in install.packages :
  installation of package ‘genefilter’ had non-zero exit status
ERROR: dependency ‘annotate’ is not available for package ‘geneplotter’
* removing ‘/home/user-linux/R/x86_64-pc-linux-gnu-library/4.0/geneplotter’
Warning in install.packages :
  installation of package ‘geneplotter’ had non-zero exit status
ERROR: dependencies ‘GenomicRanges’, ‘GenomeInfoDb’ are not available for package ‘SummarizedExperiment’
* removing ‘/home/user-linux/R/x86_64-pc-linux-gnu-library/4.0/SummarizedExperiment’
Warning in install.packages :
  installation of package ‘SummarizedExperiment’ had non-zero exit status
ERROR: dependencies ‘GenomicRanges’, ‘SummarizedExperiment’, ‘genefilter’, ‘geneplotter’ are not available for package ‘DESeq2’
* removing ‘/home/user-linux/R/x86_64-pc-linux-gnu-library/4.0/DESeq2’
Warning in install.packages :
  installation of package ‘DESeq2’ had non-zero exit status

The downloaded source packages are in
    ‘/tmp/RtmpMiYAGn/downloaded_packages’
Error in library("DESeq2") : there is no package called ‘DESeq2’

Thank you

DESeq2 • 1.2k views
ADD COMMENT
0
Entering edit mode
@martin-morgan-1513
Last seen 9 weeks ago
United States

Unpack the error by starting with the first problem

** using staged installation
checking for curl-config... no
Cannot find curl-config
ERROR: configuration failed for package ‘RCurl’

You'll need to install the 'devel' version of the 'libcurl' system library (and probably also the devel version libxml2...). How to install depends on your operating system; something like sudo apt-get install libcurl4-openssl-dev would work on Ubuntu. Asking your system administrator for help might also be a good or necessary solution.

ADD COMMENT
0
Entering edit mode
ADD REPLY

Login before adding your answer.

Traffic: 270 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6