Search
Question: install new bioconductor packages R2.7.0 - affy
0
gravatar for Hoen, P.A.C. 't HKG
9.5 years ago by
Hoen, P.A.C. 't HKG30 wrote:
Dear list, We have updated to R2.7.0. I was using biocLite to also install the bioconductor 2.2 packages. Some of them were correctly installed, others not, amongst which affy 1.18.0 I paste sessionInfo and logs below. Any idea what the problem is? Thanks for your advice, Peter-Bram > sessionInfo() R version 2.7.0 (2008-04-22) x86_64-redhat-linux-gnu locale: LC_CTYPE=en_US.UTF-8;LC_NUMERIC=C;LC_TIME=en_US.UTF-8;LC_COLLATE=en_US .UTF-8;LC_MONETARY=C;LC_MESSAGES=en_US.UTF-8;LC_PAPER=en_US.UTF-8;LC_N AME=C;LC_ADDRESS=C;LC_TELEPHONE=C;LC_MEASUREMENT=en_US.UTF-8;LC_IDENTI FICATION=C attached base packages: [1] stats graphics grDevices utils datasets methods base loaded via a namespace (and not attached): [1] tools_2.7.0 > source("http://bioconductor.org/biocLite.R") > biocLite("affy") Running biocinstall version 2.2.9 with R version 2.7.0 Your version of R requires version 2.2 of BioConductor. trying URL 'http://bioconductor.org/packages/2.2/bioc/src/contrib/affy _1.18.0.tar.gz' Content type 'application/x-gzip' length 1375563 bytes (1.3 Mb) opened URL ================================================== downloaded 1.3 Mb * Installing *source* package 'affy' ... creating cache ./config.cache checking how to run the C preprocessor... cc -E checking for main in -lz... yes checking for zlib.h... yes checking if zlib version >= 1.1.3... yes updating cache ./config.cache creating ./config.status creating src/Makevars ** libs gcc -I/usr/lib64/R/include -DHAVE_ZLIB=1 -I/usr/local/include -I"/usr/lib64/R/library/preprocessCore/include" -fpic -O2 -g -std=gnu99 -c chipbackground.c -o chipbackground.o gcc -I/usr/lib64/R/include -DHAVE_ZLIB=1 -I/usr/local/include -I"/usr/lib64/R/library/preprocessCore/include" -fpic -O2 -g -std=gnu99 -c getall_locations.c -o getall_locations.o gcc -I/usr/lib64/R/include -DHAVE_ZLIB=1 -I/usr/local/include -I"/usr/lib64/R/library/preprocessCore/include" -fpic -O2 -g -std=gnu99 -c mas5calls.c -o mas5calls.o gcc -I/usr/lib64/R/include -DHAVE_ZLIB=1 -I/usr/local/include -I"/usr/lib64/R/library/preprocessCore/include" -fpic -O2 -g -std=gnu99 -c rma2.c -o rma2.o rma2.c:107:29: error: rma_background4.h: No such file or directory rma2.c:118:45: error: preprocessCore_background_stubs.c: No such file or directory rma2.c: In function ‘rma_c_complete’: rma2.c:348: warning: implicit declaration of function ‘rma_bg_correct’ make: *** [rma2.o] Error 1 chmod: cannot access `/usr/lib64/R/library/affy/libs/*': No such file or directory ERROR: compilation failed for package 'affy' ** Removing '/usr/lib64/R/library/affy' ** Restoring previous '/usr/lib64/R/library/affy' The downloaded packages are in /tmp/RtmpXSEp8l/downloaded_packages Updating HTML index of packages in '.Library' Warning message: In install.packages(pkgs = pkgs, repos = repos, dependencies = dependencies, : installation of package 'affy' had non-zero exit status [[alternative HTML version deleted]]
ADD COMMENTlink modified 9.5 years ago by Martin Morgan ♦♦ 20k • written 9.5 years ago by Hoen, P.A.C. 't HKG30
0
gravatar for Martin Morgan
9.5 years ago by
Martin Morgan ♦♦ 20k
United States
Martin Morgan ♦♦ 20k wrote:
Hi Peter-Bram -- I guess you are 'updating' an existing installation, in which case the best bet is to follow the instructions on http://bioconductor.org/download and do something like source("http://bioconductor.org/biocLite.R") update.packages(repos=biocinstallRepos(), ask=FALSE) (remove ask=FALSE if you want to be more selective about which packages are updated). The underlying problem is that affy depends on a pacakge called preprocessCore, and your version of preprocessCore is out of date. Martin <p.a.c._t_hoen at="" lumc.nl=""> writes: > Dear list, > We have updated to R2.7.0. > I was using biocLite to also install the bioconductor 2.2 packages. > Some of them were correctly installed, others not, amongst which affy 1.18.0 > I paste sessionInfo and logs below. Any idea what the problem is? > Thanks for your advice, > Peter-Bram > >> sessionInfo() > R version 2.7.0 (2008-04-22) > x86_64-redhat-linux-gnu > > locale: > LC_CTYPE=en_US.UTF-8;LC_NUMERIC=C;LC_TIME=en_US.UTF-8;LC_COLLATE=en_ US.UTF-8;LC_MONETARY=C;LC_MESSAGES=en_US.UTF-8;LC_PAPER=en_US.UTF-8;LC _NAME=C;LC_ADDRESS=C;LC_TELEPHONE=C;LC_MEASUREMENT=en_US.UTF-8;LC_IDEN TIFICATION=C > > attached base packages: > [1] stats graphics grDevices utils datasets methods base > > loaded via a namespace (and not attached): > [1] tools_2.7.0 > >> source("http://bioconductor.org/biocLite.R") >> biocLite("affy") > Running biocinstall version 2.2.9 with R version 2.7.0 > Your version of R requires version 2.2 of BioConductor. > trying URL 'http://bioconductor.org/packages/2.2/bioc/src/contrib/af fy_1.18.0.tar.gz' > Content type 'application/x-gzip' length 1375563 bytes (1.3 Mb) > opened URL > ================================================== > downloaded 1.3 Mb > > * Installing *source* package 'affy' ... > creating cache ./config.cache > checking how to run the C preprocessor... cc -E > checking for main in -lz... yes > checking for zlib.h... yes > checking if zlib version >= 1.1.3... yes > updating cache ./config.cache > creating ./config.status > creating src/Makevars > ** libs > gcc -I/usr/lib64/R/include -DHAVE_ZLIB=1 -I/usr/local/include -I"/usr/lib64/R/library/preprocessCore/include" -fpic -O2 -g -std=gnu99 -c chipbackground.c -o chipbackground.o > gcc -I/usr/lib64/R/include -DHAVE_ZLIB=1 -I/usr/local/include -I"/usr/lib64/R/library/preprocessCore/include" -fpic -O2 -g -std=gnu99 -c getall_locations.c -o getall_locations.o > gcc -I/usr/lib64/R/include -DHAVE_ZLIB=1 -I/usr/local/include -I"/usr/lib64/R/library/preprocessCore/include" -fpic -O2 -g -std=gnu99 -c mas5calls.c -o mas5calls.o > gcc -I/usr/lib64/R/include -DHAVE_ZLIB=1 -I/usr/local/include -I"/usr/lib64/R/library/preprocessCore/include" -fpic -O2 -g -std=gnu99 -c rma2.c -o rma2.o > rma2.c:107:29: error: rma_background4.h: No such file or directory > rma2.c:118:45: error: preprocessCore_background_stubs.c: No such file or directory > rma2.c: In function rma_c_complete: > rma2.c:348: warning: implicit declaration of function rma_bg_correct > make: *** [rma2.o] Error 1 > chmod: cannot access `/usr/lib64/R/library/affy/libs/*': No such file or directory > ERROR: compilation failed for package 'affy' > ** Removing '/usr/lib64/R/library/affy' > ** Restoring previous '/usr/lib64/R/library/affy' > > The downloaded packages are in > /tmp/RtmpXSEp8l/downloaded_packages > Updating HTML index of packages in '.Library' > Warning message: > In install.packages(pkgs = pkgs, repos = repos, dependencies = dependencies, : > installation of package 'affy' had non-zero exit status > > [[alternative HTML version deleted]] > > _______________________________________________ > Bioconductor mailing list > Bioconductor at stat.math.ethz.ch > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor -- Martin Morgan Computational Biology / Fred Hutchinson Cancer Research Center 1100 Fairview Ave. N. PO Box 19024 Seattle, WA 98109 Location: Arnold Building M2 B169 Phone: (206) 667-2793
ADD COMMENTlink written 9.5 years ago by Martin Morgan ♦♦ 20k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 195 users visited in the last hour