EBImage install problems
1
0
Entering edit mode
Crispin Miller ★ 1.1k
@crispin-miller-264
Last seen 7.7 years ago
Hi, We're trying to install EBImage (2.5.0) on a 64 bit RedHat (EL4) machine against R 2.8.0, in a development version of Bioconductor. To do this, we've installed ImageMagick 6.4.1 from source... EBImage appears to install OK and compile without errors or warnings. However when we load the library we get: > library(EBImage) Error in dyn.load(file, DLLpath = DLLpath, ...) : unable to load shared library ... It's looking for EBImage.so, which is present - i.e. R/library/EBImage/libs/EBImage.so exists. Looking into things a bit further, we can't locate the library libmagick9-dev, mentioned in the installation instructions. As we understand it, this should be created if ImageMagick is installed from source. Is this correct? - and can any one suggest what we need to do to make sure it's built? Any help much appreciated, Crispin -------------------------------------------------------- This email is confidential and intended solely for the u...{{dropped:12}}
EBImage EBImage • 653 views
ADD COMMENT
0
Entering edit mode
@wolfgang-huber-3550
Last seen 4 months ago
EMBL European Molecular Biology Laborat…
Hi Crispin, - The libmagick9-dev package contains header files (e.g. filename.h) for the libmagick9 library. AfaIk it does not contain executable code. It is necessary for compiling other programs that want to use functions or other symbols from libmagick9. From your description, it appears as if the header files are present, and found by R CMD INSTALL, on your system. - However, it seems that the loader does not find certain shared library files. Did you set LD_LIBRARY_PATH to include the location of where you installed the libmagick9 object files? Best wishes Wolfgang Crispin Miller wrote: > Hi, > We're trying to install EBImage (2.5.0) on a 64 bit RedHat (EL4) machine > against R 2.8.0, in a development version of Bioconductor. > > To do this, we've installed ImageMagick 6.4.1 from source... EBImage appears > to install OK and compile without errors or warnings. However when we load > the library we get: > > > > library(EBImage) > Error in dyn.load(file, DLLpath = DLLpath, ...) : > unable to load shared library > ... > > It's looking for EBImage.so, which is present - i.e. > R/library/EBImage/libs/EBImage.so exists. > > > Looking into things a bit further, we can't locate the library > libmagick9-dev, mentioned in the installation instructions. As we understand > it, this should be created if ImageMagick is installed from source. Is this > correct? - and can any one suggest what we need to do to make sure it's > built? > > Any help much appreciated, > > Crispin
ADD COMMENT
0
Entering edit mode
Hi Crispin, installing imagemagick from source you obviously executed the ./configure script first, did you path the --prefix argument? If yes, you need to set your LD_LIBRARY_PATH and maybe LIBDIR variable to point to the directory included in your --prefix added /lib. E.g. by default, the prefix is /usr and thus the libraries are installed into /usr/lib Search for libmagick.so on your file system and include the path to it into your LD_LIBRARY_PATH, on my system (default installation) it is: * /usr/lib: ls libmagic.so.1 libmagic.so.1 libmagic.so.1.0.0 Now the libmagick9-dev is the binary package that you would install on a system like Ubuntu or Debian installing from repositories. On RedHat it is different, but in any case you do not need it if you install imagemagick from source. Best, Oleg Wolfgang Huber wrote: > > Hi Crispin, > > - The libmagick9-dev package contains header files (e.g. filename.h) for > the libmagick9 library. AfaIk it does not contain executable code. It is > necessary for compiling other programs that want to use functions or > other symbols from libmagick9. From your description, it appears as if > the header files are present, and found by R CMD INSTALL, on your system. > > - However, it seems that the loader does not find certain shared library > files. Did you set LD_LIBRARY_PATH to include the location of where you > installed the libmagick9 object files? > > Best wishes > Wolfgang > > > Crispin Miller wrote: >> Hi, >> We're trying to install EBImage (2.5.0) on a 64 bit RedHat (EL4) machine >> against R 2.8.0, in a development version of Bioconductor. >> >> To do this, we've installed ImageMagick 6.4.1 from source... EBImage >> appears >> to install OK and compile without errors or warnings. However when we >> load >> the library we get: >> >> >> > library(EBImage) >> Error in dyn.load(file, DLLpath = DLLpath, ...) : >> unable to load shared library >> ... >> >> It's looking for EBImage.so, which is present - i.e. >> R/library/EBImage/libs/EBImage.so exists. >> >> >> Looking into things a bit further, we can't locate the library >> libmagick9-dev, mentioned in the installation instructions. As we >> understand >> it, this should be created if ImageMagick is installed from source. Is >> this >> correct? - and can any one suggest what we need to do to make sure it's >> built? >> Any help much appreciated, >> >> Crispin > > _______________________________________________ > Bioconductor mailing list > Bioconductor at stat.math.ethz.ch > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: > http://news.gmane.org/gmane.science.biology.informatics.conductor -- Dr Oleg Sklyar * EBI-EMBL, Cambridge CB10 1SD, UK * +44-1223-494466
ADD REPLY

Login before adding your answer.

Traffic: 760 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6