Cannot receive data tracks back rtracklayer session
1
0
Entering edit mode
@tholzmanfhcrcorg-3269
Last seen 7.9 years ago
Hi, This is Ted Holzman. I am new bioconductor user, and I have a Problem. I am using the rtracklayer package within Bioconductor. I am trying to receive a track back from a session. The view generated by the session looks fine in the browser. But I get no data back in the track. > conservation <- trackSet(session,"Conservation") > conservation ucscTrackSet (storageMode: lockedEnvironment) assayData: 377 features, 1 samples element names: dataVals phenoData sampleNames: score varLabels and varMetadata description: none featureData featureNames: ., ..1, ..., ..376 (377 total) fvarLabels and fvarMetadata description: chrom: Chromosome ID start: Start position on chromosome ...: ... strand: DNA strand, sense (+) or antisense (-) (5 total) experimentData: use 'experimentData(object)' Annotation: genome: hg18 trackLine: track name=multiz30way description=multiz30way visibility=1 All this looks fine except the genome is incorrect. It should be "mm9". > cons <- trackData(conservation) > head(cons) chrom start end name strand featMid score . chr12 85105663 85105741 . NA 85105702 0 ..1 chr12 85105742 85105813 . NA 85105778 0 ..2 chr12 85105814 85106306 . NA 85106060 0 ..3 chr12 85106307 85106426 . NA 85106366 0 ..4 chr12 85106427 85106780 . NA 85106604 0 ..5 chr12 85106781 85106808 . NA 85106794 0 All the scores are 0! Can anybody help? Thanks, -Ted **** > sessionInfo() R version 2.8.1 (2008-12-22) x86_64-unknown-linux-gnu locale: LC_CTYPE=en_US.UTF-8;LC_NUMERIC=C;LC_TIME=en_US.UTF-8;LC_COLLATE=en_US .UTF-8;LC_MONETARY=C;LC_MESSAGES=en_US.UTF-8;LC_PAPER=en_US.UTF-8;LC_N AME=C;LC_ADDRESS=C;LC_TELEPHONE=C;LC_MEASUREMENT=en_US.UTF-8;LC_IDENTI FICATION=C attached base packages: [1] grid tools stats graphics grDevices utils datasets methods base other attached packages: [1] GenomeGraphs_1.3.4 biomaRt_1.99.2 rtracklayer_1.2.2 RCurl_0.94-0 Biobase_2.2.1 loaded via a namespace (and not attached): [1] Biostrings_2.10.15 IRanges_1.0.9 lattice_0.17-20 Matrix_0.999375-17 rJava_0.6-2 XML_1.99-0
rtracklayer rtracklayer • 679 views
ADD COMMENT
0
Entering edit mode
@michael-lawrence-2759
Last seen 7.9 years ago
On Thu, Feb 5, 2009 at 5:02 PM, tholzman@fhcrc.org <tholzman@fhcrc.org>wrote: > Hi, > > This is Ted Holzman. I am new bioconductor user, and I have a Problem. > > I am using the rtracklayer package within Bioconductor. I am trying to > receive > a track back from a session. The view generated by the session looks fine > in the browser. But I get no data back in the track. > > > conservation <- trackSet(session,"Conservation") > > conservation > ucscTrackSet (storageMode: lockedEnvironment) > assayData: 377 features, 1 samples > element names: dataVals > phenoData > sampleNames: score > varLabels and varMetadata description: none > featureData > featureNames: ., ..1, ..., ..376 (377 total) > fvarLabels and fvarMetadata description: > chrom: Chromosome ID > start: Start position on chromosome > ...: ... > strand: DNA strand, sense (+) or antisense (-) > (5 total) > experimentData: use 'experimentData(object)' > Annotation: > genome: hg18 > trackLine: track name=multiz30way description=multiz30way visibility=1 > > All this looks fine except the genome is incorrect. It should be "mm9". > This would be the problem. In hg18, the scores really are zero in that region. This part of rtracklayer has been majorly fixed up in the development branch, but as you're a new user, you probably want to avoid that for now. Try calling "genomeSegment(session)" and check that the genome is mm9. Unfortunately, I can't reproduce this, because you didn't give me all of your code. Thanks, Michael > > > cons <- trackData(conservation) > > head(cons) > > chrom start end name strand featMid score > . chr12 85105663 85105741 . NA 85105702 0 > ..1 chr12 85105742 85105813 . NA 85105778 0 > ..2 chr12 85105814 85106306 . NA 85106060 0 > ..3 chr12 85106307 85106426 . NA 85106366 0 > ..4 chr12 85106427 85106780 . NA 85106604 0 > ..5 chr12 85106781 85106808 . NA 85106794 0 > > > All the scores are 0! > > Can anybody help? > > Thanks, > -Ted > > **** > > > sessionInfo() > R version 2.8.1 (2008-12-22) > x86_64-unknown-linux-gnu > > locale: > > LC_CTYPE=en_US.UTF-8;LC_NUMERIC=C;LC_TIME=en_US.UTF-8;LC_COLLATE=en_ US.UTF-8;LC_MONETARY=C;LC_MESSAGES=en_US.UTF-8;LC_PAPER=en_US.UTF-8;LC _NAME=C;LC_ADDRESS=C;LC_TELEPHONE=C;LC_MEASUREMENT=en_US.UTF-8;LC_IDEN TIFICATION=C > > attached base packages: > [1] grid tools stats graphics grDevices utils > datasets methods base > > other attached packages: > [1] GenomeGraphs_1.3.4 biomaRt_1.99.2 rtracklayer_1.2.2 > RCurl_0.94-0 Biobase_2.2.1 > > loaded via a namespace (and not attached): > [1] Biostrings_2.10.15 IRanges_1.0.9 lattice_0.17-20 > Matrix_0.999375-17 rJava_0.6-2 XML_1.99-0 > > _______________________________________________ > Bioconductor mailing list > Bioconductor@stat.math.ethz.ch > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: > http://news.gmane.org/gmane.science.biology.informatics.conductor > [[alternative HTML version deleted]]
ADD COMMENT

Login before adding your answer.

Traffic: 345 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6