[Bioc-devel] Install EBImage
1
0
Entering edit mode
Gregoire Pau ▴ 310
@gregoire-pau-3274
Last seen 7.7 years ago
Hi Sharon, Xu, EBImage works well on Windows with R-2.8.1. However, it needs recent and -developer- versions of GTK+ and ImageMagick. Don't forget to check the 'install development tools' boxes during install. The following installers work well: http://ftp.gnome.org/pub/gnome/binaries/win32/gtk+/2.14/gtk+-bundle_2. 14.7-20090119_win32.zip http://www.imagemagick.org/download/binaries/ImageMagick-6.4.9-2-Q16 -windows-dll.exe The next release of EBImage will considerably simplify these installation issues using Michael Lawrence's RGtk2 or Simon Anders's SystemRequirements:gtkmm-2.4. Best regards, Greg Xu Zhang wrote: > Hi - > > I have a problem when installing EBImage 2.6.0 under R-2.8.1 > on my win XP. I installed "ImageMagick-6.4.8-10-Q16-windows- > dll.exe" and "gtk-2.12.9-win32-2", also set the system Path > as the HOWTO pdf suggested. > > When I loaded the library, there is an error like this: > > Runtime Error! > Program:C:\Program Files\R\R-2.8.1/bin\Rgui.exe > R6034 > An application has made an attempt to load the C runtime > library incorrectly. > > Thanks in advance for any suggestion! > Xu > ------- > Xu Zhang > Ecology and Evolution > University of Chicago > 773-834-4055 > > _______________________________________________ > Bioc-devel at stat.math.ethz.ch mailing list > https://stat.ethz.ch/mailman/listinfo/bioc-devel
EBImage EBImage • 780 views
ADD COMMENT
0
Entering edit mode
Xu Zhang ▴ 10
@xu-zhang-3290
Last seen 7.7 years ago
Hi Greg- Thanks for the information. I would like to install EBImage on linux for larger memory. Do you know which version of Imagemagick and GTK I need to install for R-2.8.1? Many thanks! Xu ---- Original message ---- >Date: Tue, 10 Feb 2009 14:55:42 +0100 >From: Gregoire Pau <gregoire.pau at="" embl.de=""> >Subject: Re: [Bioc-devel] Install EBImage >To: bioconductor at stat.math.ethz.ch >Cc: Xu Zhang <xuzhang at="" uchicago.edu="">, sharonanandhi at gmail.com > >Hi Sharon, Xu, > >EBImage works well on Windows with R-2.8.1. However, it needs recent and > -developer- versions of GTK+ and ImageMagick. Don't forget to check >the 'install development tools' boxes during install. > >The following installers work well: >http://ftp.gnome.org/pub/gnome/binaries/win32/gtk+/2.14/gtk+ -bundle_2.14.7-20090119_win32.zip >http://www.imagemagick.org/download/binaries/ImageMagick- 6.4.9-2-Q16-windows-dll.exe > >The next release of EBImage will considerably simplify these >installation issues using Michael Lawrence's RGtk2 or Simon Anders's >SystemRequirements:gtkmm-2.4. > >Best regards, > >Greg > >Xu Zhang wrote: >> Hi - >> >> I have a problem when installing EBImage 2.6.0 under R- 2.8.1 >> on my win XP. I installed "ImageMagick-6.4.8-10-Q16- windows- >> dll.exe" and "gtk-2.12.9-win32-2", also set the system Path >> as the HOWTO pdf suggested. >> >> When I loaded the library, there is an error like this: >> >> Runtime Error! >> Program:C:\Program Files\R\R-2.8.1/bin\Rgui.exe >> R6034 >> An application has made an attempt to load the C runtime >> library incorrectly. >> >> Thanks in advance for any suggestion! >> Xu >> ------- >> Xu Zhang >> Ecology and Evolution >> University of Chicago >> 773-834-4055 >> >> _______________________________________________ >> Bioc-devel at stat.math.ethz.ch mailing list >> https://stat.ethz.ch/mailman/listinfo/bioc-devel ------- Xu Zhang Ecology and Evolution University of Chicago 773-834-4055
ADD COMMENT
0
Entering edit mode
Hi Xu, In the DESCRIPTION file of the package, the SystemRequirements states that "ImageMagick (>= 6.2.4), GTK+ (> 2.6)". EBImage is easy to install on Linux boxes since ImageMagick and GTK+ are most often already present (and if not, they are easy to install). Best regards, Greg Xu Zhang wrote: > Hi Greg- > > Thanks for the information. I would like to install EBImage > on linux for larger memory. Do you know which version of > Imagemagick and GTK I need to install for R-2.8.1? > Many thanks! > > Xu > > > > ---- Original message ---- >> Date: Tue, 10 Feb 2009 14:55:42 +0100 >> From: Gregoire Pau <gregoire.pau at="" embl.de=""> >> Subject: Re: [Bioc-devel] Install EBImage >> To: bioconductor at stat.math.ethz.ch >> Cc: Xu Zhang <xuzhang at="" uchicago.edu="">, sharonanandhi at gmail.com >> >> Hi Sharon, Xu, >> >> EBImage works well on Windows with R-2.8.1. However, it > needs recent and >> -developer- versions of GTK+ and ImageMagick. Don't > forget to check >> the 'install development tools' boxes during install. >> >> The following installers work well: >> http://ftp.gnome.org/pub/gnome/binaries/win32/gtk+/2.14/gtk+ > -bundle_2.14.7-20090119_win32.zip >> http://www.imagemagick.org/download/binaries/ImageMagick- > 6.4.9-2-Q16-windows-dll.exe >> The next release of EBImage will considerably simplify > these >> installation issues using Michael Lawrence's RGtk2 or Simon > Anders's >> SystemRequirements:gtkmm-2.4. >> >> Best regards, >> >> Greg >> >> Xu Zhang wrote: >>> Hi - >>> >>> I have a problem when installing EBImage 2.6.0 under R- > 2.8.1 >>> on my win XP. I installed "ImageMagick-6.4.8-10-Q16- > windows- >>> dll.exe" and "gtk-2.12.9-win32-2", also set the system > Path >>> as the HOWTO pdf suggested. >>> >>> When I loaded the library, there is an error like this: >>> >>> Runtime Error! >>> Program:C:\Program Files\R\R-2.8.1/bin\Rgui.exe >>> R6034 >>> An application has made an attempt to load the C runtime >>> library incorrectly. >>> >>> Thanks in advance for any suggestion! >>> Xu >>> ------- >>> Xu Zhang >>> Ecology and Evolution >>> University of Chicago >>> 773-834-4055 >>> >>> _______________________________________________ >>> Bioc-devel at stat.math.ethz.ch mailing list >>> https://stat.ethz.ch/mailman/listinfo/bioc-devel > ------- > Xu Zhang > Ecology and Evolution > University of Chicago > 773-834-4055
ADD REPLY

Login before adding your answer.

Traffic: 220 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6