Question: RdbiPgSQL problem: SET_VECTOR_ELT() can only be applied to a 'list', not a 'character'
0
gravatar for Philip Lijnzaad
10.5 years ago by
European Union
Philip Lijnzaad160 wrote:
Dear all, I'm having difficulty using RdbiPgSQL. This is using R 2.9.1, RdbiPgSQL 1.18.0, both R client and server at 8.3. If I do conn=dbConnect(PgSQL(), host=db.host, dbname=db.name, user=db.user, password=db.password) I keep getting this: SET_VECTOR_ELT() can only be applied to a 'list', not a 'character' Calls: dbConnect ... dbConnectionInfo -> dbConnectionInfo.PgSQL.conn -> .Call This used to work fine under R 2.7 I see that the RdbiPgSQL compiles properly, but is the actual connectivity against a real database really checked? In an ideal world this would be the case, as the current version is unusuable. This is very unfortunate, since we really rely on this code. Any suggestions are welcome. Philip -- Philip Lijnzaad, PhD Holstege Genomics Laboratory Dept. of Biomedical Genetics University Medical Center (UMC), Utrecht Stratenum room 2.211 (on Mondays and Thursdays not in after 15.00) MSN chat (*NOT* email): philip_lijnzaad at hotmail.com P.O. Box 85060, 3508 AB Utrecht (Universiteitsweg 100, 3584 CG Utrecht) The Netherlands tel: +31 (0)8875 68464 fax: +31 (0)8875 68479
rdbipgsql • 696 views
ADD COMMENTlink modified 10.5 years ago by Kasper Daniel Hansen6.4k • written 10.5 years ago by Philip Lijnzaad160
Answer: RdbiPgSQL problem: SET_VECTOR_ELT() can only be applied to a 'list', not a 'char
0
gravatar for Kasper Daniel Hansen
10.5 years ago by
United States
Kasper Daniel Hansen6.4k wrote:
This is most likely a bug in RdbiPgSQL, related to more stringent check of SET_VECTOR_ELT (C code) in R. It is probably easy to fix, but I don't have access to a PostGres database, so I would be unable to check. Contact the maintainer and complain :) Kasper On Apr 25, 2009, at 2:26 , Philip Lijnzaad wrote: > Dear all, > > I'm having difficulty using RdbiPgSQL. This is using R 2.9.1, > RdbiPgSQL > 1.18.0, both R client and server at 8.3. > > If I do > > conn=dbConnect(PgSQL(), > host=db.host, > dbname=db.name, > user=db.user, > password=db.password) > > > I keep getting this: > > SET_VECTOR_ELT() can only be applied to a 'list', not a 'character' > Calls: dbConnect ... dbConnectionInfo -> > dbConnectionInfo.PgSQL.conn -> .Call > > This used to work fine under R 2.7 > > I see that the RdbiPgSQL compiles properly, but is the actual > connectivity > against a real database really checked? In an ideal world this would > be the > case, as the current version is unusuable. > > This is very unfortunate, since we really rely on this code. > > Any suggestions are welcome. > Philip > > -- > Philip Lijnzaad, PhD > Holstege Genomics Laboratory > Dept. of Biomedical Genetics > University Medical Center (UMC), Utrecht > Stratenum room 2.211 (on Mondays and Thursdays not in after 15.00) > MSN chat (*NOT* email): philip_lijnzaad at hotmail.com > P.O. Box 85060, 3508 AB Utrecht > (Universiteitsweg 100, 3584 CG Utrecht) > The Netherlands > tel: +31 (0)8875 68464 > fax: +31 (0)8875 68479 > > _______________________________________________ > Bioconductor mailing list > Bioconductor at stat.math.ethz.ch > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor
ADD COMMENTlink written 10.5 years ago by Kasper Daniel Hansen6.4k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 397 users visited in the last hour