Question: problem with reading agilent microarray data into agi4x44preprocess
0
gravatar for Jarek Bryk
10.5 years ago by
Jarek Bryk110
Jarek Bryk110 wrote:
Hello, I am trying to read my Agilent single color whole mouse genome microarray data into Agi4x44PreProcess, as described in the vignette. However, I get the error: > Error in readGenericHeader(fullname, columns = columns, sep = sep) : Specified column headings not found in file Following the advice from Martin Morgan (using options(error=recover) etc., see https://stat.ethz.ch/pipermail/bioconductor/2007-October/019577.html) I figured out that the error is caused by the lack of the BGUsed column in my raw data text file. And I don't know how to fix it. Is there a way of telling the read.maimages/read.AgilentFE to skip this column (I can't find this solution in the read.maimages help), or to modify the raw data files so that the function doesn't complain (simply pasting the column header does not work, I tried...)? > sessionInfo() R version 2.9.0 (2009-04-17) i386-apple-darwin8.11.1 locale: C attached base packages: [1] stats graphics grDevices utils datasets methods base other attached packages: [1] mgug4122a.db_2.2.11 RSQLite_0.7-1 DBI_0.2-4 Agi4x44PreProcess_1.4.0 genefilter_1.24.0 annotate_1.22.0 AnnotationDbi_1.6.0 limma_2.18.0 [9] Biobase_2.4.1 loaded via a namespace (and not attached): [1] splines_2.9.0 survival_2.35-4 tools_2.9.0 xtable_1.5-5 I would be very grateful for help, cheers jarek -- Jarek Bryk Max Planck Institute for Evolutionary Biology August Thienemann Str. 2 | 24306 Pl?n, Germany tel. +49 4522 763 287 | bryk at evolbio.mpg.de
ADD COMMENTlink written 10.5 years ago by Jarek Bryk110
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 466 users visited in the last hour