EBImage installation problem on Linux
1
0
Entering edit mode
quantrum75 ▴ 30
@quantrum75-3581
Last seen 7.7 years ago
Hi Group, I am trying to install the EBImage package on my linux box. I have the latest version of Ubuntu, GTK2.0 and Image magick. The error which I get is as follows...Could anyone give me an idea what I am doing wrong? Thanks in advance. Rama > source("http://bioconductor.org/biocLite.R") > biocLite("EBImage") Running biocinstall version 2.3.13 with R version 2.8.1 Your version of R requires version 2.3 of Bioconductor. Warning in install.packages(pkgs = pkgs, repos = repos, dependencies = dependencies,  :   argument 'lib' is missing: using '/home/rama/R/i486-pc-linux-gnu- library/2.8' trying URL 'http://bioconductor.org/packages/2.3/bioc/src/contrib/EBIm age_2.6.0.tar.gz' Content type 'application/x-gzip' length 1425422 bytes (1.4 Mb) opened URL ================================================== downloaded 1.4 Mb * Installing *source* package 'EBImage' ... checking for Magick-config... yes * found ImageMagick version 6.5.4 Q16 * found ImageMagick includes in -I/usr/local/include/ImageMagick checking for pkg-config... yes * compiling with GTK+ support ----------------------------------------------------- configure: creating ./config.status config.status: creating src/Makevars ** libs gcc -std=gnu99 -I/usr/share/R/include     -DUSE_GTK -DGLIB_GETTEXT -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -Wall -I/usr/local/include/ImageMagick -fopenmp -I/usr/local/include/ImageMagick  -fpic  -g -O2 -c colors.c -o colors.o In file included from colors.c:1: colors.h:6:32: error: magick/ImageMagick.h: No such file or directory In file included from colors.c:1: colors.h:13: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token colors.h:14: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token colors.h:15: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token colors.h:16: error: expected ‘)’ before ‘*’ token colors.h:17: error: expected ‘)’ before ‘*’ token colors.h:18: error: expected ‘)’ before ‘*’ token colors.h:19: error: expected ‘)’ before ‘*’ token colors.h:20: error: expected ‘)’ before ‘*’ token colors.c:24: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token colors.c:25: error: expected ‘)’ before ‘*’ token colors.c:26: error: expected ‘)’ before ‘*’ token colors.c:27: error: expected ‘)’ before ‘*’ token colors.c: In function ‘lib_channel’: colors.c:33: error: ‘Image’ undeclared (first use in this function) colors.c:33: error: (Each undeclared identifier is reported only once colors.c:33: error: for each function it appears in.) colors.c:33: error: ‘image’ undeclared (first use in this function) colors.c:35: warning: implicit declaration of function ‘vector2image1D’ colors.c:40: warning: implicit declaration of function ‘image1D2INTEGER’ colors.c:40: warning: assignment makes pointer from integer without a cast colors.c:43: warning: implicit declaration of function ‘image1D2REAL’ colors.c:43: warning: assignment makes pointer from integer without a cast colors.c:46: warning: assignment makes pointer from integer without a cast colors.c:49: warning: assignment makes pointer from integer without a cast colors.c:52: warning: assignment makes pointer from integer without a cast colors.c:55: warning: assignment makes pointer from integer without a cast colors.c:58: warning: assignment makes pointer from integer without a cast colors.c:61: warning: assignment makes pointer from integer without a cast colors.c:64: warning: implicit declaration of function ‘image1D2CHAR’ colors.c:64: warning: assignment makes pointer from integer without a cast colors.c:67: warning: implicit declaration of function ‘DestroyImage’ colors.c: At top level: colors.c:75: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token colors.c:118: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token colors.c:133: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token colors.c:150: error: expected ‘)’ before ‘*’ token colors.c:187: error: expected ‘)’ before ‘*’ token colors.c:199: error: expected ‘)’ before ‘*’ token colors.c:236: error: expected ‘)’ before ‘*’ token colors.c:248: error: expected ‘)’ before ‘*’ token make: *** [colors.o] Error 1 chmod: cannot access `/home/rama/R/i486-pc-linux-gnu- library/2.8/EBImage/libs/*': No such file or directory ERROR: compilation failed for package 'EBImage' ** Removing '/home/rama/R/i486-pc-linux-gnu-library/2.8/EBImage' The downloaded packages are in     /tmp/Rtmpp8W5xS/downloaded_packages Warning message: In install.packages(pkgs = pkgs, repos = repos, dependencies = dependencies,  :   installation of package 'EBImage' had non-zero exit status [[alternative HTML version deleted]]
EBImage EBImage • 1.8k views
ADD COMMENT
0
Entering edit mode
@wolfgang-huber-3550
Last seen 4 months ago
EMBL European Molecular Biology Laborat…
Dear Rama please use the current release of R and Bioconductor. You are using an outdated version (R2.8, Bioc 2.3). Installation of R is described here: http://www.bioconductor.org/docs/install/ Best wishes Wolfgang quantrum75 wrote: > Hi Group, > I am trying to install the EBImage package on my linux box. I have the latest version of Ubuntu, GTK2.0 and Image magick. The error which I get is as follows...Could anyone give me an idea what I am doing wrong? > Thanks in advance. > Rama > >> source("http://bioconductor.org/biocLite.R") >> biocLite("EBImage") > Running biocinstall version 2.3.13 with R version 2.8.1 > Your version of R requires version 2.3 of Bioconductor. > Warning in install.packages(pkgs = pkgs, repos = repos, dependencies = dependencies,? : > ? argument 'lib' is missing: using '/home/rama/R/i486-pc-linux-gnu- library/2.8' > trying URL 'http://bioconductor.org/packages/2.3/bioc/src/contrib/EB Image_2.6.0.tar.gz' > Content type 'application/x-gzip' length 1425422 bytes (1.4 Mb) > opened URL > ================================================== > downloaded 1.4 Mb > > * Installing *source* package 'EBImage' ... > checking for Magick-config... yes > * found ImageMagick version 6.5.4 Q16 > * found ImageMagick includes in -I/usr/local/include/ImageMagick > checking for pkg-config... yes > * compiling with GTK+ support > ----------------------------------------------------- > configure: creating ./config.status > config.status: creating src/Makevars > ** libs > gcc -std=gnu99 -I/usr/share/R/include? ? ? ? -DUSE_GTK -DGLIB_GETTEXT -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include? ? -Wall -I/usr/local/include/ImageMagick -fopenmp -I/usr/local/include/ImageMagick? -fpic? -g -O2 -c colors.c -o colors.o > In file included from colors.c:1: > colors.h:6:32: error: magick/ImageMagick.h: No such file or directory > In file included from colors.c:1: > colors.h:13: error: expected ???=???, ???,???, ???;???, ???asm??? or ???__attribute__??? before ???*??? token > colors.h:14: error: expected ???=???, ???,???, ???;???, ???asm??? or ???__attribute__??? before ???*??? token > colors.h:15: error: expected ???=???, ???,???, ???;???, ???asm??? or ???__attribute__??? before ???*??? token > colors.h:16: error: expected ???)??? before ???*??? token > colors.h:17: error: expected ???)??? before ???*??? token > colors.h:18: error: expected ???)??? before ???*??? token > colors.h:19: error: expected ???)??? before ???*??? token > colors.h:20: error: expected ???)??? before ???*??? token > colors.c:24: error: expected ???=???, ???,???, ???;???, ???asm??? or ???__attribute__??? before ???*??? token > colors.c:25: error: expected ???)??? before ???*??? token > colors.c:26: error: expected ???)??? before ???*??? token > colors.c:27: error: expected ???)??? before ???*??? token > colors.c: In function ???lib_channel???: > colors.c:33: error: ???Image??? undeclared (first use in this function) > colors.c:33: error: (Each undeclared identifier is reported only once > colors.c:33: error: for each function it appears in.) > colors.c:33: error: ???image??? undeclared (first use in this function) > colors.c:35: warning: implicit declaration of function ???vector2image1D??? > colors.c:40: warning: implicit declaration of function ???image1D2INTEGER??? > colors.c:40: warning: assignment makes pointer from integer without a cast > colors.c:43: warning: implicit declaration of function ???image1D2REAL??? > colors.c:43: warning: assignment makes pointer from integer without a cast > colors.c:46: warning: assignment makes pointer from integer without a cast > colors.c:49: warning: assignment makes pointer from integer without a cast > colors.c:52: warning: assignment makes pointer from integer without a cast > colors.c:55: warning: assignment makes pointer from integer without a cast > colors.c:58: warning: assignment makes pointer from integer without a cast > colors.c:61: warning: assignment makes pointer from integer without a cast > colors.c:64: warning: implicit declaration of function ???image1D2CHAR??? > colors.c:64: warning: assignment makes pointer from integer without a cast > colors.c:67: warning: implicit declaration of function ???DestroyImage??? > colors.c: At top level: > colors.c:75: error: expected ???=???, ???,???, ???;???, ???asm??? or ???__attribute__??? before ???*??? token > colors.c:118: error: expected ???=???, ???,???, ???;???, ???asm??? or ???__attribute__??? before ???*??? token > colors.c:133: error: expected ???=???, ???,???, ???;???, ???asm??? or ???__attribute__??? before ???*??? token > colors.c:150: error: expected ???)??? before ???*??? token > colors.c:187: error: expected ???)??? before ???*??? token > colors.c:199: error: expected ???)??? before ???*??? token > colors.c:236: error: expected ???)??? before ???*??? token > colors.c:248: error: expected ???)??? before ???*??? token > make: *** [colors.o] Error 1 > chmod: cannot access `/home/rama/R/i486-pc-linux-gnu- library/2.8/EBImage/libs/*': No such file or directory > ERROR: compilation failed for package 'EBImage' > ** Removing '/home/rama/R/i486-pc-linux-gnu-library/2.8/EBImage' > > The downloaded packages are in > ? ? ? /tmp/Rtmpp8W5xS/downloaded_packages > Warning message: > In install.packages(pkgs = pkgs, repos = repos, dependencies = dependencies,? : > ? installation of package 'EBImage' had non-zero exit status > > > > > > [[alternative HTML version deleted]] > > > > -------------------------------------------------------------------- ---- > > _______________________________________________ > Bioconductor mailing list > Bioconductor at stat.math.ethz.ch > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor
ADD COMMENT
0
Entering edit mode
Dear Wolfgang, Thank you for your reply. As per your advice, I reinstalled the software and tried to install EBImage with biocLite. However, I still get the same error. I also tried to locate the file in the location and directory (see details below) and the file was indeed there. So I am not sure EBImage is giving the error that Imagemagick.h is not there. I shall look forward to any guidance on the subject. Thanks Rama INSTALLATION - Running biocinstall version 2.4.11 with R version 2.9.1 Your version of R requires version 2.4 of Bioconductor. Warning in install.packages(pkgs = pkgs, repos = repos, dependencies = dependencies,  :   argument 'lib' is missing: using '/home/rama/R/i486-pc-linux-gnu- library/2.9' trying URL 'http://bioconductor.org/packages/2.4/bioc/src/contrib/EBIm age_3.0.3.tar.gz' Content type 'application/x-gzip' length 10222583 bytes (9.7 Mb) opened URL ================================================== downloaded 9.7 Mb * Installing *source* package ‘EBImage’ ... checking for Magick-config... yes * found ImageMagick version 6.5.4 Q16 * found ImageMagick includes in -I/usr/local/include/ImageMagick checking for pkg-config... yes * compiling with GTK+ support ----------------------------------------------------- configure: creating ./config.status config.status: creating src/Makevars ** libs gcc -std=gnu99 -I/usr/share/R/include     -DUSE_GTK -DGLIB_GETTEXT -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -Wall -I/usr/local/include/ImageMagick -fopenmp -I/usr/local/include/ImageMagick  -fpic  -g -O2 -c EBImage.c -o EBImage.o In file included from EBImage.c:8: conversions.h:6:32: error: magick/ImageMagick.h: No such file or directory In file included from EBImage.c:8: conversions.h:12: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token conversions.h:13: error: expected ‘)’ before ‘*’ token EBImage.c:40:30: error: wand/magick-wand.h: No such file or directory EBImage.c: In function ‘R_init_EBImage’: EBImage.c:158: warning: implicit declaration of function ‘MagickWandGenesis’ EBImage.c: In function ‘R_unload_EBImage’: EBImage.c:166: warning: implicit declaration of function ‘MagickWandTerminus’ make: *** [EBImage.o] Error 1 ERROR: compilation failed for package ‘EBImage’ * Removing ‘/home/rama/R/i486-pc-linux-gnu-library/2.9/EBImage’ The downloaded packages are in     ‘/tmp/RtmpdB9twt/downloaded_packages’ Warning message: In install.packages(pkgs = pkgs, repos = repos, dependencies = dependencies,  :   installation of package 'EBImage' had non-zero exit status LOCATION OF IMAGEMAGICK.H rama@Durga:/usr/include/ImageMagick/magick$ ls animate.h     coder.h       delegate.h   gem.h          log.h            mime.h        profile.h   segment.h     timer.h annotate.h    color.h       deprecate.h  geometry.h    magic.h          module.h      property.h  semaphore.h   token.h api.h         colorspace.h  display.h    hashmap.h      magick-config.h  monitor.h     quantize.h   shear.h       transform.h artifact.h    compare.h     distort.h    identify.h    MagickCore.h     montage.h     quantum.h    signature.h  type.h blob.h        composite.h   draw.h       image.h        magick.h         option.h      random_.h   splay-tree.h  utility.h cache.h       compress.h    effect.h     ImageMagick.h magick-type.h    paint.h       registry.h   statistic.h  version.h cache-view.h  configure.h   enhance.h    layer.h       matrix.h         pixel.h       resample.h   stream.h      widget.h cipher.h      constitute.h  exception.h  list.h        memory_.h        prepress.h    resize.h     string_.h     xml-tree.h client.h      decorate.h    fx.h         locale_.h      methods.h        PreRvIcccm.h  resource_.h threshold.h   xwindow.h --- On Sat, 7/18/09, Wolfgang Huber <huber@ebi.ac.uk> wrote: From: Wolfgang Huber <huber@ebi.ac.uk> Subject: Re: [BioC] EBImage installation problem on Linux Cc: bioconductor@stat.math.ethz.ch Date: Saturday, July 18, 2009, 4:18 PM Dear Rama please use the current release of R and Bioconductor. You are using an outdated version (R2.8, Bioc 2.3). Installation of R is described here: http://www.bioconductor.org/docs/install/     Best wishes     Wolfgang quantrum75 wrote: > Hi Group, > I am trying to install the EBImage package on my linux box. I have the latest version of Ubuntu, GTK2.0 and Image magick. The error which I get is as follows...Could anyone give me an idea what I am doing wrong? > Thanks in advance. > Rama > >> source("http://bioconductor.org/biocLite.R") >> biocLite("EBImage") > Running biocinstall version 2.3.13 with R version 2.8.1 Your version of R requires version 2.3 of Bioconductor. > Warning in install.packages(pkgs = pkgs, repos = repos, dependencies = dependencies,  : >   argument 'lib' is missing: using '/home/rama/R/i486-pc-linux- gnu-library/2.8' > trying URL 'http://bioconductor.org/packages/2.3/bioc/src/contrib/EB Image_2.6.0.tar.gz' > Content type 'application/x-gzip' length 1425422 bytes (1.4 Mb) > opened URL > ================================================== > downloaded 1.4 Mb > > * Installing *source* package 'EBImage' ... > checking for Magick-config... yes > * found ImageMagick version 6.5.4 Q16 * found ImageMagick includes in -I/usr/local/include/ImageMagick > checking for pkg-config... yes > * compiling with GTK+ support > ----------------------------------------------------- > configure: creating ./config.status > config.status: creating src/Makevars > ** libs > gcc -std=gnu99 -I/usr/share/R/include     -DUSE_GTK -DGLIB_GETTEXT -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -Wall -I/usr/local/include/ImageMagick -fopenmp -I/usr/local/include/ImageMagick  -fpic  -g -O2 -c colors.c -o colors.o > In file included from colors.c:1: > colors.h:6:32: error: magick/ImageMagick.h: No such file or directory > In file included from colors.c:1: > colors.h:13: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token > colors.h:14: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token > colors.h:15: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token > colors.h:16: error: expected ‘)’ before ‘*’ token > colors.h:17: error: expected ‘)’ before ‘*’ token > colors.h:18: error: expected ‘)’ before ‘*’ token > colors.h:19: error: expected ‘)’ before ‘*’ token > colors.h:20: error: expected ‘)’ before ‘*’ token > colors.c:24: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token > colors.c:25: error: expected ‘)’ before ‘*’ token > colors.c:26: error: expected ‘)’ before ‘*’ token > colors.c:27: error: expected ‘)’ before ‘*’ token > colors.c: In function ‘lib_channel’: > colors.c:33: error: ‘Image’ undeclared (first use in this function) > colors.c:33: error: (Each undeclared identifier is reported only once > colors.c:33: error: for each function it appears in.) > colors.c:33: error: ‘image’ undeclared (first use in this function) > colors.c:35: warning: implicit declaration of function ‘vector2image1D’ > colors.c:40: warning: implicit declaration of function ‘image1D2INTEGER’ > colors.c:40: warning: assignment makes pointer from integer without a cast > colors.c:43: warning: implicit declaration of function ‘image1D2REAL’ > colors.c:43: warning: assignment makes pointer from integer without a cast > colors.c:46: warning: assignment makes pointer from integer without a cast > colors.c:49: warning: assignment makes pointer from integer without a cast > colors.c:52: warning: assignment makes pointer from integer without a cast > colors.c:55: warning: assignment makes pointer from integer without a cast > colors.c:58: warning: assignment makes pointer from integer without a cast > colors.c:61: warning: assignment makes pointer from integer without a cast > colors.c:64: warning: implicit declaration of function ‘image1D2CHAR’ > colors.c:64: warning: assignment makes pointer from integer without a cast > colors.c:67: warning: implicit declaration of function ‘DestroyImage’ > colors.c: At top level: > colors.c:75: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token > colors.c:118: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token > colors.c:133: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token > colors.c:150: error: expected ‘)’ before ‘*’ token > colors.c:187: error: expected ‘)’ before ‘*’ token > colors.c:199: error: expected ‘)’ before ‘*’ token > colors.c:236: error: expected ‘)’ before ‘*’ token > colors.c:248: error: expected ‘)’ before ‘*’ token > make: *** [colors.o] Error 1 > chmod: cannot access `/home/rama/R/i486-pc-linux-gnu- library/2.8/EBImage/libs/*': No such file or directory > ERROR: compilation failed for package 'EBImage' > ** Removing '/home/rama/R/i486-pc-linux-gnu-library/2.8/EBImage' > > The downloaded packages are in >     /tmp/Rtmpp8W5xS/downloaded_packages > Warning message: > In install.packages(pkgs = pkgs, repos = repos, dependencies = dependencies,  : >   installation of package 'EBImage' had non-zero exit status > > > > >           [[alternative HTML version deleted]] > > > > -------------------------------------------------------------------- ---- > > _______________________________________________ > Bioconductor mailing list > Bioconductor@stat.math.ethz.ch > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor [[alternative HTML version deleted]]
ADD REPLY
0
Entering edit mode
Dear Rama, It looks like your ImageMagick (IM) installation is messed up. First, please make sure that both the Ubuntu IM main package (ImageMagick) and the Ubuntu IM development package (sometimes referred as ImageMagick-devel) are installed, as mentioned in the 'How to install EBImage' file. EBImage uses the command 'Magick-config --cppflags' to localize IM components and according to your output, it seems that the IM headers are in '/usr/local/include/ImageMagick' But your 'ls' command shows that the IM headers are in '/usr/include/ImageMagick/magick', contradicting the results given before. It seems that you have two IM installations in parallel on your system: an Ubuntu packaged one (without the development component) and a non-packaged, manually installed version. Or maybe did you rename some directories by mistake ? I would suggest you to (re)install both the Ubuntu ImageMagick main and development packages. If you have installed ImageMagick manually, then you could uninstall the Ubuntu ImageMagick package to avoid a version clash. After these steps, please check that the header files are present in the directory returned by the command 'Magick-config --cppflags'. Best, Greg --- Gregoire Pau EMBL Research officer http://www.ebi.ac.uk/~gpau/ quantrum75 wrote: > Dear Wolfgang, > Thank you for your reply. As per your advice, I reinstalled the software and tried to install EBImage with biocLite. However, I still get the same error. I also tried to locate the file in the location and directory (see details below) and the file was indeed there. So I am not sure EBImage is giving the error that Imagemagick.h is not there. > I shall look forward to any guidance on the subject. > Thanks > Rama > > INSTALLATION - > Running biocinstall version 2.4.11 with R version 2.9.1 > Your version of R requires version 2.4 of Bioconductor. > Warning in install.packages(pkgs = pkgs, repos = repos, dependencies = dependencies,? : > ? argument 'lib' is missing: using '/home/rama/R/i486-pc-linux-gnu- library/2.9' > trying URL 'http://bioconductor.org/packages/2.4/bioc/src/contrib/EB Image_3.0.3.tar.gz' > Content type 'application/x-gzip' length 10222583 bytes (9.7 Mb) > opened URL > ================================================== > downloaded 9.7 Mb > > * Installing *source* package ???EBImage??? ... > checking for Magick-config... yes > * found ImageMagick version 6.5.4 Q16 > * found ImageMagick includes in -I/usr/local/include/ImageMagick > checking for pkg-config... yes > * compiling with GTK+ support > ----------------------------------------------------- > configure: creating ./config.status > config.status: creating src/Makevars > ** libs > gcc -std=gnu99 -I/usr/share/R/include? ? ? ? -DUSE_GTK -DGLIB_GETTEXT -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include? ? -Wall -I/usr/local/include/ImageMagick -fopenmp -I/usr/local/include/ImageMagick? -fpic? -g -O2 -c EBImage.c -o EBImage.o > In file included from EBImage.c:8: > conversions.h:6:32: error: magick/ImageMagick.h: No such file or directory > In file included from EBImage.c:8: > conversions.h:12: error: expected ???=???, ???,???, ???;???, ???asm??? or ???__attribute__??? before ???*??? token > conversions.h:13: error: expected ???)??? before ???*??? token > EBImage.c:40:30: error: wand/magick-wand.h: No such file or directory > EBImage.c: In function ???R_init_EBImage???: > EBImage.c:158: warning: implicit declaration of function ???MagickWandGenesis??? > EBImage.c: In function ???R_unload_EBImage???: > EBImage.c:166: warning: implicit declaration of function ???MagickWandTerminus??? > make: *** [EBImage.o] Error 1 > ERROR: compilation failed for package ???EBImage??? > * Removing ???/home/rama/R/i486-pc-linux-gnu-library/2.9/EBImage??? > > The downloaded packages are in > ? ? ? ???/tmp/RtmpdB9twt/downloaded_packages??? > Warning message: > In install.packages(pkgs = pkgs, repos = repos, dependencies = dependencies,? : > ? installation of package 'EBImage' had non-zero exit status > > LOCATION OF IMAGEMAGICK.H > > rama at Durga:/usr/include/ImageMagick/magick$ ls > animate.h? ? ? ? coder.h? ? ? ? ? ? delegate.h? ? gem.h? ? ? ? ? ? ? ? ? log.h? ? ? ? ? ? ? ? ? ? ? mime.h? ? ? ? ? ? ? profile.h? ? ? segment.h? ? ? ? timer.h > annotate.h? ? ? color.h? ? ? ? ? ? deprecate.h? geometry.h? ? ? ? magic.h? ? ? ? ? ? ? ? ? module.h? ? ? ? ? property.h? ? semaphore.h? ? token.h > api.h? ? ? ? ? ? ? ? colorspace.h? display.h? ? ? hashmap.h? ? ? ? ? magick-config.h? monitor.h? ? ? ? quantize.h? ? shear.h? ? ? ? ? ? transform.h > artifact.h? ? ? compare.h? ? ? ? distort.h? ? ? identify.h? ? ? ? MagickCore.h? ? ? ? montage.h? ? ? ? quantum.h? ? ? signature.h? ? type.h > blob.h? ? ? ? ? ? ? composite.h? ? draw.h? ? ? ? ? ? image.h? ? ? ? ? ? ? magick.h? ? ? ? ? ? ? ? option.h? ? ? ? ? random_.h? ? ? splay-tree.h? utility.h > cache.h? ? ? ? ? ? compress.h? ? ? effect.h? ? ? ? ImageMagick.h? magick-type.h? ? ? paint.h? ? ? ? ? ? registry.h? ? statistic.h? ? version.h > cache-view.h? configure.h? ? enhance.h? ? ? layer.h? ? ? ? ? ? ? matrix.h? ? ? ? ? ? ? ? pixel.h? ? ? ? ? ? resample.h? ? stream.h? ? ? ? ? widget.h > cipher.h? ? ? ? ? constitute.h? exception.h? list.h? ? ? ? ? ? ? ? memory_.h? ? ? ? ? ? ? prepress.h? ? ? resize.h? ? ? ? string_.h? ? ? ? xml-tree.h > client.h? ? ? ? ? decorate.h? ? ? fx.h? ? ? ? ? ? ? ? locale_.h? ? ? ? ? methods.h? ? ? ? ? ? ? PreRvIcccm.h? resource_.h? threshold.h? ? xwindow.h > > > > --- On Sat, 7/18/09, Wolfgang Huber <huber at="" ebi.ac.uk=""> wrote: > > From: Wolfgang Huber <huber at="" ebi.ac.uk=""> > Subject: Re: [BioC] EBImage installation problem on Linux > > Cc: bioconductor at stat.math.ethz.ch > Date: Saturday, July 18, 2009, 4:18 PM > > Dear Rama > > please use the current release of R and Bioconductor. You are using an outdated version (R2.8, Bioc 2.3). > > Installation of R is described here: > http://www.bioconductor.org/docs/install/ > > ? ? ? Best wishes > ? ? ? Wolfgang > > > quantrum75 wrote: >> Hi Group, >> I am trying to install the EBImage package on my linux box. I have the latest version of Ubuntu, GTK2.0 and Image magick. The error which I get is as follows...Could anyone give me an idea what I am doing wrong? >> Thanks in advance. >> Rama >> >>> source("http://bioconductor.org/biocLite.R") >>> biocLite("EBImage") >> Running biocinstall version 2.3.13 with R version 2.8.1 Your version of R requires version 2.3 of Bioconductor. >> Warning in install.packages(pkgs = pkgs, repos = repos, dependencies = dependencies,??? : >> ??? argument 'lib' is missing: using '/home/rama/R/i486-pc-linux- gnu-library/2.8' >> trying URL 'http://bioconductor.org/packages/2.3/bioc/src/contrib/E BImage_2.6.0.tar.gz' >> Content type 'application/x-gzip' length 1425422 bytes (1.4 Mb) >> opened URL >> ================================================== >> downloaded 1.4 Mb >> >> * Installing *source* package 'EBImage' ... >> checking for Magick-config... yes >> * found ImageMagick version 6.5.4 Q16 * found ImageMagick includes in -I/usr/local/include/ImageMagick >> checking for pkg-config... yes >> * compiling with GTK+ support >> ----------------------------------------------------- >> configure: creating ./config.status >> config.status: creating src/Makevars >> ** libs >> gcc -std=gnu99 -I/usr/share/R/include?? ?? ?? ??? -DUSE_GTK -DGLIB_GETTEXT -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include?? ??? -Wall -I/usr/local/include/ImageMagick -fopenmp -I/usr/local/include/ImageMagick??? -fpic??? -g -O2 -c colors.c -o colors.o >> In file included from colors.c:1: >> colors.h:6:32: error: magick/ImageMagick.h: No such file or directory >> In file included from colors.c:1: >> colors.h:13: error: expected ???????=????????, ???????,????????, ???????;????????, ???????asm???????? or ???????__attribute__???????? before ???????*???????? token >> colors.h:14: error: expected ???????=????????, ???????,????????, ???????;????????, ???????asm???????? or ???????__attribute__???????? before ???????*???????? token >> colors.h:15: error: expected ???????=????????, ???????,????????, ???????;????????, ???????asm???????? or ???????__attribute__???????? before ???????*???????? token >> colors.h:16: error: expected ???????)???????? before ???????*???????? token >> colors.h:17: error: expected ???????)???????? before ???????*???????? token >> colors.h:18: error: expected ???????)???????? before ???????*???????? token >> colors.h:19: error: expected ???????)???????? before ???????*???????? token >> colors.h:20: error: expected ???????)???????? before ???????*???????? token >> colors.c:24: error: expected ???????=????????, ???????,????????, ???????;????????, ???????asm???????? or ???????__attribute__???????? before ???????*???????? token >> colors.c:25: error: expected ???????)???????? before ???????*???????? token >> colors.c:26: error: expected ???????)???????? before ???????*???????? token >> colors.c:27: error: expected ???????)???????? before ???????*???????? token >> colors.c: In function ???????lib_channel????????: >> colors.c:33: error: ???????Image???????? undeclared (first use in this function) >> colors.c:33: error: (Each undeclared identifier is reported only once >> colors.c:33: error: for each function it appears in.) >> colors.c:33: error: ???????image???????? undeclared (first use in this function) >> colors.c:35: warning: implicit declaration of function ???????vector2image1D???????? >> colors.c:40: warning: implicit declaration of function ???????image1D2INTEGER???????? >> colors.c:40: warning: assignment makes pointer from integer without a cast >> colors.c:43: warning: implicit declaration of function ???????image1D2REAL???????? >> colors.c:43: warning: assignment makes pointer from integer without a cast >> colors.c:46: warning: assignment makes pointer from integer without a cast >> colors.c:49: warning: assignment makes pointer from integer without a cast >> colors.c:52: warning: assignment makes pointer from integer without a cast >> colors.c:55: warning: assignment makes pointer from integer without a cast >> colors.c:58: warning: assignment makes pointer from integer without a cast >> colors.c:61: warning: assignment makes pointer from integer without a cast >> colors.c:64: warning: implicit declaration of function ???????image1D2CHAR???????? >> colors.c:64: warning: assignment makes pointer from integer without a cast >> colors.c:67: warning: implicit declaration of function ???????DestroyImage???????? >> colors.c: At top level: >> colors.c:75: error: expected ???????=????????, ???????,????????, ???????;????????, ???????asm???????? or ???????__attribute__???????? before ???????*???????? token >> colors.c:118: error: expected ???????=????????, ???????,????????, ???????;????????, ???????asm???????? or ???????__attribute__???????? before ???????*???????? token >> colors.c:133: error: expected ???????=????????, ???????,????????, ???????;????????, ???????asm???????? or ???????__attribute__???????? before ???????*???????? token >> colors.c:150: error: expected ???????)???????? before ???????*???????? token >> colors.c:187: error: expected ???????)???????? before ???????*???????? token >> colors.c:199: error: expected ???????)???????? before ???????*???????? token >> colors.c:236: error: expected ???????)???????? before ???????*???????? token >> colors.c:248: error: expected ???????)???????? before ???????*???????? token >> make: *** [colors.o] Error 1 >> chmod: cannot access `/home/rama/R/i486-pc-linux-gnu- library/2.8/EBImage/libs/*': No such file or directory >> ERROR: compilation failed for package 'EBImage' >> ** Removing '/home/rama/R/i486-pc-linux-gnu-library/2.8/EBImage' >> >> The downloaded packages are in >> ?? ?? ??? /tmp/Rtmpp8W5xS/downloaded_packages >> Warning message: >> In install.packages(pkgs = pkgs, repos = repos, dependencies = dependencies,??? : >> ??? installation of package 'EBImage' had non-zero exit status >> >> >> >> >> ? ? ? ? ? ? ? ? [[alternative HTML version deleted]] >> >> >> >> ------------------------------------------------------------------- ----- >> >> _______________________________________________ >> Bioconductor mailing list >> Bioconductor at stat.math.ethz.ch >> https://stat.ethz.ch/mailman/listinfo/bioconductor >> Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor > > > > > > [[alternative HTML version deleted]] > > > > -------------------------------------------------------------------- ---- > > _______________________________________________ > Bioconductor mailing list > Bioconductor at stat.math.ethz.ch > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor
ADD REPLY

Login before adding your answer.

Traffic: 261 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6