Error with EBImage package loading
2
0
Entering edit mode
@kishor-tappita-2563
Last seen 8.1 years ago
An embedded and charset-unspecified text was scrubbed... Name: not available URL: <https: stat.ethz.ch="" pipermail="" bioconductor="" attachments="" 20090806="" 6182c0e9="" attachment.ksh="">
• 757 views
ADD COMMENT
0
Entering edit mode
Gregoire Pau ▴ 310
@gregoire-pau-3274
Last seen 8.1 years ago
Dear Kishor, Do you have the libraries GTK+ and ImageMagick installed ? Did you follow the instructions to install EBImage ? http://www.bioconductor.org/packages/release/bioc/html/EBImage.html Best regards, Greg --- Gregoire Pau EMBL Research officer http://www.ebi.ac.uk/~gpau/ Kishor Tappita wrote: > Dear All, > > I was able to install EBImage but when I am trying to load the package I get > the following error > > R6034 > - C runtime library incorrectly... > > Below is my session information. > >> sessionInfo() > R version 2.9.1 (2009-06-26) > i386-pc-mingw32 > > locale: > LC_COLLATE=English_United States.1252;LC_CTYPE=English_United > States.1252;LC_MONETARY=English_United > States.1252;LC_NUMERIC=C;LC_TIME=English_United States.1252 > > attached base packages: > [1] stats graphics grDevices utils datasets methods base > > other attached packages: > [1] EBImage_3.0.3 abind_1.1-0 > > loaded via a namespace (and not attached): > [1] tools_2.9.1 > > Thanks, > Kishor > > [[alternative HTML version deleted]] > > _______________________________________________ > Bioconductor mailing list > Bioconductor at stat.math.ethz.ch > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor
ADD COMMENT
0
Entering edit mode
@kishor-tappita-2563
Last seen 8.1 years ago
Dear Greg, I have installed GTK+ (C:\opt\gtk) and ImageMagick and have also followed the instruction of EBImage intallation. I am having the same issue on two computers (my personal and work). Thanks, Kishor On Thu, Aug 6, 2009 at 1:24 PM, Gregoire Pau <gregoire.pau@embl.de> wrote: > Dear Kishor, > > Do you have the libraries GTK+ and ImageMagick installed ? > Did you follow the instructions to install EBImage ? > http://www.bioconductor.org/packages/release/bioc/html/EBImage.html > > Best regards, > > Greg > --- > Gregoire Pau > EMBL Research officer > http://www.ebi.ac.uk/~gpau/ <http: www.ebi.ac.uk="" %7egpau=""/> > > > Kishor Tappita wrote: > >> Dear All, >> >> I was able to install EBImage but when I am trying to load the package I >> get >> the following error >> >> R6034 >> - C runtime library incorrectly... >> >> Below is my session information. >> >> sessionInfo() >>> >> R version 2.9.1 (2009-06-26) >> i386-pc-mingw32 >> >> locale: >> LC_COLLATE=English_United States.1252;LC_CTYPE=English_United >> States.1252;LC_MONETARY=English_United >> States.1252;LC_NUMERIC=C;LC_TIME=English_United States.1252 >> >> attached base packages: >> [1] stats graphics grDevices utils datasets methods base >> >> other attached packages: >> [1] EBImage_3.0.3 abind_1.1-0 >> >> loaded via a namespace (and not attached): >> [1] tools_2.9.1 >> >> Thanks, >> Kishor >> >> [[alternative HTML version deleted]] >> >> _______________________________________________ >> Bioconductor mailing list >> Bioconductor@stat.math.ethz.ch >> https://stat.ethz.ch/mailman/listinfo/bioconductor >> Search the archives: >> http://news.gmane.org/gmane.science.biology.informatics.conductor >> > [[alternative HTML version deleted]]
ADD COMMENT
0
Entering edit mode
Dear Kishor, > I have installed GTK+ (C:\opt\gtk) and ImageMagick and have also > followed the instruction of EBImage intallation. As mentioned in the installation guide, did you install the Microsoft C runtime library patch in case of 'C runtime error exception' ? Did you set the PATH system environment to point to 'c:\opt\gtk\bin' ? During ImageMagick installation, did you check the box to install development headers and libraries ? Are GTK+ and ImageMagick working ? Did you try the command 'gtk-demo' in the Windows command line ? What is the result of 'convert' (coming from ImageMagick) in the command line ? EBImage works fine on Windows systems. Most of the installation issues come from the installation of ImageMagick. Regards, Greg --- Gregoire Pau EMBL Research Officer http://www.ebi.ac.uk/~gpau/ Kishor Tappita wrote: > Dear Greg, > > I have installed GTK+ (C:\opt\gtk) and ImageMagick and have also > followed the instruction of EBImage intallation. > > I am having the same issue on two computers (my personal and work). > > Thanks, > Kishor > > On Thu, Aug 6, 2009 at 1:24 PM, Gregoire Pau <gregoire.pau at="" embl.de=""> <mailto:gregoire.pau at="" embl.de="">> wrote: > > Dear Kishor, > > Do you have the libraries GTK+ and ImageMagick installed ? > Did you follow the instructions to install EBImage ? > http://www.bioconductor.org/packages/release/bioc/html/EBImage.html > > Best regards, > > Greg > --- > Gregoire Pau > EMBL Research officer > http://www.ebi.ac.uk/~gpau/ <http: www.ebi.ac.uk="" %7egpau=""/> > > > Kishor Tappita wrote: > > Dear All, > > I was able to install EBImage but when I am trying to load the > package I get > the following error > > R6034 > - C runtime library incorrectly... > > Below is my session information. > > sessionInfo() > > R version 2.9.1 (2009-06-26) > i386-pc-mingw32 > > locale: > LC_COLLATE=English_United States.1252;LC_CTYPE=English_United > States.1252;LC_MONETARY=English_United > States.1252;LC_NUMERIC=C;LC_TIME=English_United States.1252 > > attached base packages: > [1] stats graphics grDevices utils datasets methods base > > other attached packages: > [1] EBImage_3.0.3 abind_1.1-0 > > loaded via a namespace (and not attached): > [1] tools_2.9.1 > > Thanks, > Kishor > > [[alternative HTML version deleted]] > > _______________________________________________ > Bioconductor mailing list > Bioconductor at stat.math.ethz.ch > <mailto:bioconductor at="" stat.math.ethz.ch=""> > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: > http://news.gmane.org/gmane.science.biology.informatics.conductor > >
ADD REPLY
0
Entering edit mode
Dear Greg, I have not installed Microsoft C runtime library patch. Can you please help me in installing that. gtk-demo works fine and I have set the path to 'c:\opt\gtk\bin' . But while installing ImageMagick I used the default installation and am not sure whether I checked the box for hearders and libraries. Thanks again for your help. Regards, Kishor On Thu, Aug 6, 2009 at 2:18 PM, Gregoire Pau<gregoire.pau at="" embl.de=""> wrote: > Dear Kishor, > >> I have installed GTK+ (C:\opt\gtk) and ImageMagick and have also >> followed the instruction of EBImage intallation. > > As mentioned in the installation guide, did you install the Microsoft C > runtime library patch in case of 'C runtime error exception' ? Did you set > the PATH system environment to point to 'c:\opt\gtk\bin' ? During > ImageMagick installation, did you check the box to install development > headers and libraries ? > > Are GTK+ and ImageMagick working ? Did you try the command 'gtk- demo' in the > Windows command line ? What is the result of 'convert' (coming from > ImageMagick) in the command line ? > > EBImage works fine on Windows systems. Most of the installation issues come > from the installation of ImageMagick. > > Regards, > > Greg > --- > Gregoire Pau > EMBL Research Officer > http://www.ebi.ac.uk/~gpau/ > > > Kishor Tappita wrote: >> >> Dear Greg, >> >> I have installed GTK+ (C:\opt\gtk) and ImageMagick and have also followed >> the instruction of EBImage intallation. >> >> I am having the same issue on two computers (my personal and work). >> >> Thanks, >> Kishor >> >> On Thu, Aug 6, 2009 at 1:24 PM, Gregoire Pau <gregoire.pau at="" embl.de="">> <mailto:gregoire.pau at="" embl.de="">> wrote: >> >> ? ?Dear Kishor, >> >> ? ?Do you have the libraries GTK+ and ImageMagick installed ? >> ? ?Did you follow the instructions to install EBImage ? >> ? ?http://www.bioconductor.org/packages/release/bioc/html/EBImage.html >> >> ? ?Best regards, >> >> ? ?Greg >> ? ?--- >> ? ?Gregoire Pau >> ? ?EMBL Research officer >> ? ?http://www.ebi.ac.uk/~gpau/ <http: www.ebi.ac.uk="" %7egpau=""/> >> >> >> ? ?Kishor Tappita wrote: >> >> ? ? ? ?Dear All, >> >> ? ? ? ?I was able to install EBImage but when I am trying to load the >> ? ? ? ?package I get >> ? ? ? ?the following error >> >> ? ? ? ?R6034 >> ? ? ? ? - C runtime library incorrectly... >> >> ? ? ? ?Below is my session information. >> >> ? ? ? ? ? ?sessionInfo() >> >> ? ? ? ?R version 2.9.1 (2009-06-26) >> ? ? ? ?i386-pc-mingw32 >> >> ? ? ? ?locale: >> ? ? ? ?LC_COLLATE=English_United States.1252;LC_CTYPE=English_United >> ? ? ? ?States.1252;LC_MONETARY=English_United >> ? ? ? ?States.1252;LC_NUMERIC=C;LC_TIME=English_United States.1252 >> >> ? ? ? ?attached base packages: >> ? ? ? ?[1] stats ? ? graphics ?grDevices utils ? ? datasets ?methods >> base >> >> ? ? ? ?other attached packages: >> ? ? ? ?[1] EBImage_3.0.3 abind_1.1-0 >> >> ? ? ? ?loaded via a namespace (and not attached): >> ? ? ? ?[1] tools_2.9.1 >> >> ? ? ? ?Thanks, >> ? ? ? ?Kishor >> >> ? ? ? ? ? ? ? [[alternative HTML version deleted]] >> >> ? ? ? ?_______________________________________________ >> ? ? ? ?Bioconductor mailing list >> ? ? ? ?Bioconductor at stat.math.ethz.ch >> ? ? ? ?<mailto:bioconductor at="" stat.math.ethz.ch=""> >> ? ? ? ?https://stat.ethz.ch/mailman/listinfo/bioconductor >> ? ? ? ?Search the archives: >> ? ? ? ?http://news.gmane.org/gmane.science.biology.informatics.conductor >> >> >
ADD REPLY
0
Entering edit mode
Dear Kishor, > I have not installed Microsoft C runtime library patch. Can you please > help me in installing that. Everything is in the installation guide: http://www.bioconductor.org/packages/release/bioc/vignettes/EBImage/in st/doc/EBImage-installation.pdf Please install this patch and reinstall ImageMagick with the box checked for headers and libraries. This should solve all your issues. Best regards, Greg --- Gregoire Pau EMBL Research Officer http://www.ebi.ac.uk/~gpau/ Kishor Tappita wrote: > Dear Greg, > > I have not installed Microsoft C runtime library patch. Can you please > help me in > installing that. > > gtk-demo works fine and I have set the path to 'c:\opt\gtk\bin' . But > while installing > ImageMagick I used the default installation and am not sure whether I > checked the box for > hearders and libraries. > > > Thanks again for your help. > > > Regards, > Kishor > On Thu, Aug 6, 2009 at 2:18 PM, Gregoire Pau<gregoire.pau at="" embl.de=""> wrote: >> Dear Kishor, >> >>> I have installed GTK+ (C:\opt\gtk) and ImageMagick and have also >>> followed the instruction of EBImage intallation. >> As mentioned in the installation guide, did you install the Microsoft C >> runtime library patch in case of 'C runtime error exception' ? Did you set >> the PATH system environment to point to 'c:\opt\gtk\bin' ? During >> ImageMagick installation, did you check the box to install development >> headers and libraries ? >> >> Are GTK+ and ImageMagick working ? Did you try the command 'gtk- demo' in the >> Windows command line ? What is the result of 'convert' (coming from >> ImageMagick) in the command line ? >> >> EBImage works fine on Windows systems. Most of the installation issues come >> from the installation of ImageMagick. >> >> Regards, >> >> Greg >> --- >> Gregoire Pau >> EMBL Research Officer >> http://www.ebi.ac.uk/~gpau/ >> >> >> Kishor Tappita wrote: >>> Dear Greg, >>> >>> I have installed GTK+ (C:\opt\gtk) and ImageMagick and have also followed >>> the instruction of EBImage intallation. >>> >>> I am having the same issue on two computers (my personal and work). >>> >>> Thanks, >>> Kishor >>> >>> On Thu, Aug 6, 2009 at 1:24 PM, Gregoire Pau <gregoire.pau at="" embl.de="">>> <mailto:gregoire.pau at="" embl.de="">> wrote: >>> >>> Dear Kishor, >>> >>> Do you have the libraries GTK+ and ImageMagick installed ? >>> Did you follow the instructions to install EBImage ? >>> http://www.bioconductor.org/packages/release/bioc/html/EBImage.html >>> >>> Best regards, >>> >>> Greg >>> --- >>> Gregoire Pau >>> EMBL Research officer >>> http://www.ebi.ac.uk/~gpau/ <http: www.ebi.ac.uk="" %7egpau=""/> >>> >>> >>> Kishor Tappita wrote: >>> >>> Dear All, >>> >>> I was able to install EBImage but when I am trying to load the >>> package I get >>> the following error >>> >>> R6034 >>> - C runtime library incorrectly... >>> >>> Below is my session information. >>> >>> sessionInfo() >>> >>> R version 2.9.1 (2009-06-26) >>> i386-pc-mingw32 >>> >>> locale: >>> LC_COLLATE=English_United States.1252;LC_CTYPE=English_United >>> States.1252;LC_MONETARY=English_United >>> States.1252;LC_NUMERIC=C;LC_TIME=English_United States.1252 >>> >>> attached base packages: >>> [1] stats graphics grDevices utils datasets methods >>> base >>> >>> other attached packages: >>> [1] EBImage_3.0.3 abind_1.1-0 >>> >>> loaded via a namespace (and not attached): >>> [1] tools_2.9.1 >>> >>> Thanks, >>> Kishor >>> >>> [[alternative HTML version deleted]] >>> >>> _______________________________________________ >>> Bioconductor mailing list >>> Bioconductor at stat.math.ethz.ch >>> <mailto:bioconductor at="" stat.math.ethz.ch=""> >>> https://stat.ethz.ch/mailman/listinfo/bioconductor >>> Search the archives: >>> http://news.gmane.org/gmane.science.biology.informatics.conductor >>> >>>
ADD REPLY
0
Entering edit mode
Dear Greg, Sorry foe the delayed response. I installed the patch and that fixed evrything. Thank you so much for your help. Regards, Kishor On Thu, Aug 6, 2009 at 2:35 PM, Gregoire Pau<gregoire.pau at="" embl.de=""> wrote: > Dear Kishor, > >> I have not installed Microsoft C runtime library patch. Can you please >> help me in installing that. > > Everything is in the installation guide: > http://www.bioconductor.org/packages/release/bioc/vignettes/EBImage/ inst/doc/EBImage-installation.pdf > > Please install this patch and reinstall ImageMagick with the box checked for > headers and libraries. This should solve all your issues. > > Best regards, > > Greg > --- > Gregoire Pau > EMBL Research Officer > http://www.ebi.ac.uk/~gpau/ > > > Kishor Tappita wrote: >> >> Dear Greg, >> >> I have not installed Microsoft C runtime library patch. Can you please >> help me in >> installing that. >> >> gtk-demo works fine and I have set the path to 'c:\opt\gtk\bin' . But >> while installing >> ?ImageMagick I used the default installation and am not sure whether I >> checked the box for >> hearders and libraries. >> >> >> Thanks again for your help. >> >> >> Regards, >> Kishor >> On Thu, Aug 6, 2009 at 2:18 PM, Gregoire Pau<gregoire.pau at="" embl.de=""> wrote: >>> >>> Dear Kishor, >>> >>>> I have installed GTK+ (C:\opt\gtk) and ImageMagick and have also >>>> followed the instruction of EBImage intallation. >>> >>> As mentioned in the installation guide, did you install the Microsoft C >>> runtime library patch in case of 'C runtime error exception' ? Did you >>> set >>> the PATH system environment to point to 'c:\opt\gtk\bin' ? During >>> ImageMagick installation, did you check the box to install development >>> headers and libraries ? >>> >>> Are GTK+ and ImageMagick working ? Did you try the command 'gtk- demo' in >>> the >>> Windows command line ? What is the result of 'convert' (coming from >>> ImageMagick) in the command line ? >>> >>> EBImage works fine on Windows systems. Most of the installation issues >>> come >>> from the installation of ImageMagick. >>> >>> Regards, >>> >>> Greg >>> --- >>> Gregoire Pau >>> EMBL Research Officer >>> http://www.ebi.ac.uk/~gpau/ >>> >>> >>> Kishor Tappita wrote: >>>> >>>> Dear Greg, >>>> >>>> I have installed GTK+ (C:\opt\gtk) and ImageMagick and have also >>>> followed >>>> the instruction of EBImage intallation. >>>> >>>> I am having the same issue on two computers (my personal and work). >>>> >>>> Thanks, >>>> Kishor >>>> >>>> On Thu, Aug 6, 2009 at 1:24 PM, Gregoire Pau <gregoire.pau at="" embl.de="">>>> <mailto:gregoire.pau at="" embl.de="">> wrote: >>>> >>>> ? Dear Kishor, >>>> >>>> ? Do you have the libraries GTK+ and ImageMagick installed ? >>>> ? Did you follow the instructions to install EBImage ? >>>> ? http://www.bioconductor.org/packages/release/bioc/html/EBImage.html >>>> >>>> ? Best regards, >>>> >>>> ? Greg >>>> ? --- >>>> ? Gregoire Pau >>>> ? EMBL Research officer >>>> ? http://www.ebi.ac.uk/~gpau/ <http: www.ebi.ac.uk="" %7egpau=""/> >>>> >>>> >>>> ? Kishor Tappita wrote: >>>> >>>> ? ? ? Dear All, >>>> >>>> ? ? ? I was able to install EBImage but when I am trying to load the >>>> ? ? ? package I get >>>> ? ? ? the following error >>>> >>>> ? ? ? R6034 >>>> ? ? ? ?- C runtime library incorrectly... >>>> >>>> ? ? ? Below is my session information. >>>> >>>> ? ? ? ? ? sessionInfo() >>>> >>>> ? ? ? R version 2.9.1 (2009-06-26) >>>> ? ? ? i386-pc-mingw32 >>>> >>>> ? ? ? locale: >>>> ? ? ? LC_COLLATE=English_United States.1252;LC_CTYPE=English_United >>>> ? ? ? States.1252;LC_MONETARY=English_United >>>> ? ? ? States.1252;LC_NUMERIC=C;LC_TIME=English_United States.1252 >>>> >>>> ? ? ? attached base packages: >>>> ? ? ? [1] stats ? ? graphics ?grDevices utils ? ? datasets ?methods >>>> base >>>> >>>> ? ? ? other attached packages: >>>> ? ? ? [1] EBImage_3.0.3 abind_1.1-0 >>>> >>>> ? ? ? loaded via a namespace (and not attached): >>>> ? ? ? [1] tools_2.9.1 >>>> >>>> ? ? ? Thanks, >>>> ? ? ? Kishor >>>> >>>> ? ? ? ? ? ? ?[[alternative HTML version deleted]] >>>> >>>> ? ? ? _______________________________________________ >>>> ? ? ? Bioconductor mailing list >>>> ? ? ? Bioconductor at stat.math.ethz.ch >>>> ? ? ? <mailto:bioconductor at="" stat.math.ethz.ch=""> >>>> ? ? ? https://stat.ethz.ch/mailman/listinfo/bioconductor >>>> ? ? ? Search the archives: >>>> ? ? ? http://news.gmane.org/gmane.science.biology.informatics.conductor >>>> >>>> >
ADD REPLY
0
Entering edit mode
---------- Forwarded message ---------- From: Kishor Tappita <kishor.tappita@gmail.com> Date: Thu, Aug 6, 2009 at 1:29 PM Subject: Re: [BioC] Error with EBImage package loading To: Gregoire Pau <gregoire.pau at="" embl.de=""> Cc: bioconductor at stat.math.ethz.ch Dear Greg, I have installed GTK+ (C:\opt\gtk) and ImageMagick and have also followed the instruction of EBImage intallation. I am having the same issue on two computers (my personal and work). Thanks, Kishor On Thu, Aug 6, 2009 at 1:24 PM, Gregoire Pau <gregoire.pau at="" embl.de=""> wrote: > > Dear Kishor, > > Do you have the libraries GTK+ and ImageMagick installed ? > Did you follow the instructions to install EBImage ? http://www.bioconductor.org/packages/release/bioc/html/EBImage.html > > Best regards, > > Greg > --- > Gregoire Pau > EMBL Research officer > http://www.ebi.ac.uk/~gpau/ > > > Kishor Tappita wrote: >> >> Dear All, >> >> I was able to install EBImage but when I am trying to load the package I get >> the following error >> >> R6034 >> ?- C runtime library incorrectly... >> >> Below is my session information. >> >>> sessionInfo() >> >> R version 2.9.1 (2009-06-26) >> i386-pc-mingw32 >> >> locale: >> LC_COLLATE=English_United States.1252;LC_CTYPE=English_United >> States.1252;LC_MONETARY=English_United >> States.1252;LC_NUMERIC=C;LC_TIME=English_United States.1252 >> >> attached base packages: >> [1] stats ? ? graphics ?grDevices utils ? ? datasets ?methods ? base >> >> other attached packages: >> [1] EBImage_3.0.3 abind_1.1-0 >> >> loaded via a namespace (and not attached): >> [1] tools_2.9.1 >> >> Thanks, >> Kishor >> >> ? ? ? ?[[alternative HTML version deleted]] >> >> _______________________________________________ >> Bioconductor mailing list >> Bioconductor at stat.math.ethz.ch >> https://stat.ethz.ch/mailman/listinfo/bioconductor >> Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor
ADD REPLY

Login before adding your answer.

Traffic: 221 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6