Help Understand flowViz Error
2
0
Entering edit mode
Aric Gregson ▴ 50
@aric-gregson-3687
Last seen 7.2 years ago
Hello, I would like to figure out why attempting to apply a gate is failing with the error: Error adding item 'action': length of 'dimnames' [2] not equal to array extent I have created a flowSet 'fs': A flowSet with 60 experiments. An object of class "AnnotatedDataFrame" rowNames: TregPanel_376.fcs, TregPanel_396.fcs, ..., TregPanel_328.fcs (60 total) varLabels and varMetadata description: name: name Filename: Filename ...: ... Infection: NA (10 total) column names: FSC.A FSC.H FSC.W SSC.A SSC.H SSC.W FITC.A PE.A PE.Texas.Red.A PerCP.Cy5.5.A PE.Cy7.A Pacific.Blue.A AmCyan.A Qdot.605.A Qdot.655.A Indo.1..Violet..A AlexaFluor.647.A Alexa.Fluor.700.A APC.H7.A Time And am attempting to apply this (and other similar gates) to the flowSet: ccr7filter Rectangular gate 'CCR7' with dimensions: PE.Cy7.A: (5.6,Inf) There are some tubes within the flowSet that do not have any cells within the sub-population to which I am attempting to apply this gate (Treg). Application of this (and the other gates) to the lymphocyte population works without the error. I seem to remember having trouble at some point in the past attempting to apply gates like this to a flowSet when some tubes did not have enough of the sub-population to apply the gate to, but it had been fixed (or so I thought?). Is it possible that this is causing the seen error? The flowSets were read in with ncdf and combined using the rbind2 function. sessionInfo() R version 2.9.2 (2009-08-24) i386-pc-solaris2.11 locale: C attached base packages: [1] grid splines stats graphics grDevices utils datasets [8] methods base other attached packages: [1] ncdf_1.6 flowViz_1.9.8 flowCore_1.11.17 [4] rrcov_0.5-02 pcaPP_1.71 mvtnorm_0.9-7 [7] robustbase_0.4-5 Hmisc_3.7-0 survival_2.35-4 [10] colorspace_1.0-1 geneplotter_1.22.0 lattice_0.17-25 [13] annotate_1.22.0 AnnotationDbi_1.6.1 Biobase_2.4.1 [16] fortunes_1.3-6 loaded via a namespace (and not attached): [1] DBI_0.2-4 KernSmooth_2.23-2 MASS_7.2-48 RColorBrewer_1.0-2 [5] RSQLite_0.7-2 cluster_1.12.0 feature_1.2.4 graph_1.22.2 [9] ks_1.6.6 latticeExtra_0.6-1 stats4_2.9.2 tools_2.9.2 [13] xtable_1.5-5 Thanks in advance, Aric
cdf cdf • 806 views
ADD COMMENT
0
Entering edit mode
@nishant-gopalakrishnan-3253
Last seen 7.2 years ago
Hi Aric, I am unable to reproduce the error you get after trying out a gate that does not have any sub populations that fall into the rectangular gate using the GvHD dataset. I can look into the issue if you are able to submit a reproducible example. Nishant -----Original Message----- From: bioconductor-bounces@stat.math.ethz.ch [mailto:bioconductor-bounces at stat.math.ethz.ch] On Behalf Of Aric Gregson Sent: Wednesday, October 07, 2009 5:01 PM To: bioconductor at stat.math.ethz.ch Subject: [BioC] Help Understand flowViz Error Hello, I would like to figure out why attempting to apply a gate is failing with the error: Error adding item 'action': length of 'dimnames' [2] not equal to array extent I have created a flowSet 'fs': A flowSet with 60 experiments. An object of class "AnnotatedDataFrame" rowNames: TregPanel_376.fcs, TregPanel_396.fcs, ..., TregPanel_328.fcs (60 total) varLabels and varMetadata description: name: name Filename: Filename ...: ... Infection: NA (10 total) column names: FSC.A FSC.H FSC.W SSC.A SSC.H SSC.W FITC.A PE.A PE.Texas.Red.A PerCP.Cy5.5.A PE.Cy7.A Pacific.Blue.A AmCyan.A Qdot.605.A Qdot.655.A Indo.1..Violet..A AlexaFluor.647.A Alexa.Fluor.700.A APC.H7.A Time And am attempting to apply this (and other similar gates) to the flowSet: ccr7filter Rectangular gate 'CCR7' with dimensions: PE.Cy7.A: (5.6,Inf) There are some tubes within the flowSet that do not have any cells within the sub-population to which I am attempting to apply this gate (Treg). Application of this (and the other gates) to the lymphocyte population works without the error. I seem to remember having trouble at some point in the past attempting to apply gates like this to a flowSet when some tubes did not have enough of the sub-population to apply the gate to, but it had been fixed (or so I thought?). Is it possible that this is causing the seen error? The flowSets were read in with ncdf and combined using the rbind2 function. sessionInfo() R version 2.9.2 (2009-08-24) i386-pc-solaris2.11 locale: C attached base packages: [1] grid splines stats graphics grDevices utils datasets [8] methods base other attached packages: [1] ncdf_1.6 flowViz_1.9.8 flowCore_1.11.17 [4] rrcov_0.5-02 pcaPP_1.71 mvtnorm_0.9-7 [7] robustbase_0.4-5 Hmisc_3.7-0 survival_2.35-4 [10] colorspace_1.0-1 geneplotter_1.22.0 lattice_0.17-25 [13] annotate_1.22.0 AnnotationDbi_1.6.1 Biobase_2.4.1 [16] fortunes_1.3-6 loaded via a namespace (and not attached): [1] DBI_0.2-4 KernSmooth_2.23-2 MASS_7.2-48 RColorBrewer_1.0-2 [5] RSQLite_0.7-2 cluster_1.12.0 feature_1.2.4 graph_1.22.2 [9] ks_1.6.6 latticeExtra_0.6-1 stats4_2.9.2 tools_2.9.2 [13] xtable_1.5-5 Thanks in advance, Aric _______________________________________________ Bioconductor mailing list Bioconductor at stat.math.ethz.ch https://stat.ethz.ch/mailman/listinfo/bioconductor Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor
ADD COMMENT
0
Entering edit mode
Chao-Jen Wong ▴ 580
@chao-jen-wong-3603
Last seen 6.9 years ago
USA/Seattle/Fred Hutchinson Cancer Reseā€¦
Hi, Josef, The first error message that you got is quite common when using the flowStats' warping function. I post your question on the mailing list so that other people can benefit from it. The first issue is due to a floating point problem in the fda package that we use for wrapping the data. Spancer Graves (fda's maintainer) has fixed it in version 2.1.3 which will appear in the newly-released R. 2.10 in the end of this month. Unfortunately, I was not able to find the binary file of fad_2.1.3.tar.gz on line. What I can do now is that I can wrap the fda package that I modified and email to you. What do you think? As for the second issue, it seems to me that the data object might be empty. Anyhow, I will take a look at your data and will get back to you soon. cheers, Chao-Jen > > Hi guys, > I am experiencing some weird behavior when running the warpSet function > (flowStats 1.3.19) > > The flowSet that I am using is attached. > > Issue 1, error: > > warpSet(original, "FSC-H")$flowset > Estimating landmarks for channel FSC-H ... > Registering curves for parameter FSC-H ... > Error in seq.default(rangeval[1] + del/2, rangeval[2] - del/2, del) : > wrong sign in 'by' argument > > > > Issue 2, no error but returns NULL: > > warpSet(original, "FL1-H")$flowset > Estimating landmarks for channel FL1-H ... > Registering curves for parameter FL1-H ... > NULL > > > > This is my configuration: > > sessionInfo() > R version 2.10.0 alpha (2009-10-06 r49961) x86_64-unknown-linux-gnu > > locale: > [1] LC_CTYPE=en_CA.UTF-8 LC_NUMERIC=C > [3] LC_TIME=en_CA.UTF-8 LC_COLLATE=en_CA.UTF-8 > [5] LC_MONETARY=C LC_MESSAGES=en_CA.UTF-8 > [7] LC_PAPER=en_CA.UTF-8 LC_NAME=C > [9] LC_ADDRESS=C LC_TELEPHONE=C > [11] LC_MEASUREMENT=en_CA.UTF-8 LC_IDENTIFICATION=C > > attached base packages: > [1] splines stats graphics grDevices utils datasets methods > [8] base > > other attached packages: > [1] flowViz_1.9.9 lattice_0.17-26 flowStats_1.3.19 mvoutlier_1.4 > [5] fda_2.1.2 zoo_1.5-8 flowCore_1.11.22 rrcov_0.5-02 > [9] pcaPP_1.7 mvtnorm_0.9-7 robustbase_0.4-5 Biobase_2.5.8 > > loaded via a namespace (and not attached): > [1] feature_1.2.4 graph_1.23.7 grid_2.10.0 > KernSmooth_2.23-3 > [5] ks_1.6.7 latticeExtra_0.6-1 MASS_7.3-2 > RColorBrewer_1.0-2 > [9] stats4_2.10.0 tools_2.10.0 > > > > Am I just applying it in a stupid way or is there a bug? > > Thanks, > Josef > > -- > Josef Spidlen, Ph.D. > Terry Fox Laboratory, BC Cancer Agency > 675 West 10th Avenue, V5Z 1L3 Vancouver, BC, Canada > > Tel: +1 (604) 675-8000 x 7755 > http://www.terryfoxlab.ca/people/rbrinkman/josef.aspx > > > > -- Chao-Jen Wong Program in Computational Biology Division of Public Health Sciences Fred Hutchinson Cancer Research Center 1100 Fairview Avenue N., M2-B876 PO Box 19024 Seattle, WA 98109 206.667.4485 cwon2 at fhcrc.org
ADD COMMENT
0
Entering edit mode
Hi Chao-Jen, > What I can do now is that I can > wrap the fda package that I modified and email to you. What do you think? That would be great, thanks. Josef Chao-Jen Wong wrote: > Hi, Josef, > > The first error message that you got is quite common when using the > flowStats' warping function. I post your question on the mailing list so > that other people can benefit from it. > > The first issue is due to a floating point problem in the fda package > that we use for wrapping the data. Spancer Graves (fda's maintainer) has > fixed it in version 2.1.3 which will appear in the newly-released R. > 2.10 in the end of this month. Unfortunately, I was not able to find the > binary file of fad_2.1.3.tar.gz on line. What I can do now is that I can > wrap the fda package that I modified and email to you. What do you think? > > As for the second issue, it seems to me that the data object might be > empty. Anyhow, I will take a look at your data and will get back to you > soon. > > cheers, > Chao-Jen > >> Hi guys, >> I am experiencing some weird behavior when running the warpSet function >> (flowStats 1.3.19) >> >> The flowSet that I am using is attached. >> >> Issue 1, error: >> > warpSet(original, "FSC-H")$flowset >> Estimating landmarks for channel FSC-H ... >> Registering curves for parameter FSC-H ... >> Error in seq.default(rangeval[1] + del/2, rangeval[2] - del/2, del) : >> wrong sign in 'by' argument >> > >> >> Issue 2, no error but returns NULL: >> > warpSet(original, "FL1-H")$flowset >> Estimating landmarks for channel FL1-H ... >> Registering curves for parameter FL1-H ... >> NULL >> > >> >> This is my configuration: >> > sessionInfo() >> R version 2.10.0 alpha (2009-10-06 r49961) x86_64-unknown-linux-gnu >> >> locale: >> [1] LC_CTYPE=en_CA.UTF-8 LC_NUMERIC=C >> [3] LC_TIME=en_CA.UTF-8 LC_COLLATE=en_CA.UTF-8 >> [5] LC_MONETARY=C LC_MESSAGES=en_CA.UTF-8 >> [7] LC_PAPER=en_CA.UTF-8 LC_NAME=C >> [9] LC_ADDRESS=C LC_TELEPHONE=C >> [11] LC_MEASUREMENT=en_CA.UTF-8 LC_IDENTIFICATION=C >> >> attached base packages: >> [1] splines stats graphics grDevices utils datasets methods >> [8] base >> >> other attached packages: >> [1] flowViz_1.9.9 lattice_0.17-26 flowStats_1.3.19 mvoutlier_1.4 >> [5] fda_2.1.2 zoo_1.5-8 flowCore_1.11.22 rrcov_0.5-02 >> [9] pcaPP_1.7 mvtnorm_0.9-7 robustbase_0.4-5 Biobase_2.5.8 >> >> loaded via a namespace (and not attached): >> [1] feature_1.2.4 graph_1.23.7 grid_2.10.0 >> KernSmooth_2.23-3 >> [5] ks_1.6.7 latticeExtra_0.6-1 MASS_7.3-2 >> RColorBrewer_1.0-2 >> [9] stats4_2.10.0 tools_2.10.0 >> > >> >> Am I just applying it in a stupid way or is there a bug? >> >> Thanks, >> Josef >> >> -- >> Josef Spidlen, Ph.D. >> Terry Fox Laboratory, BC Cancer Agency >> 675 West 10th Avenue, V5Z 1L3 Vancouver, BC, Canada >> >> Tel: +1 (604) 675-8000 x 7755 >> http://www.terryfoxlab.ca/people/rbrinkman/josef.aspx >> >> >> >> >> > > -- Josef Spidlen, Ph.D. Terry Fox Laboratory, BC Cancer Agency 675 West 10th Avenue, V5Z 1L3 Vancouver, BC, Canada Tel: +1 (604) 675-8000 x 7755 http://www.terryfoxlab.ca/people/rbrinkman/josef.aspx
ADD REPLY
0
Entering edit mode
HI, Josef, It terms out fda_2.1.3 is available on R-Forge. Quoting from Spencer: "The current version of fda on R-Forge is 2.1.3 and is available via install.packages("fda", repos="http://R-Forge.R-project.org")." I will have submit some examples for testing the modification that accounts for the floating point problems before they can release the new version. Hopefully it will be done before BioC 2.5's release day. Thanks for your patient. Cheers, Chao-Jen Quoting Chao-Jen Wong <cwon2 at="" fhcrc.org="">: > Hi, Josef, > > The first error message that you got is quite common when using the > flowStats' warping function. I post your question on the mailing list so > that other people can benefit from it. > > The first issue is due to a floating point problem in the fda package > that we use for wrapping the data. Spancer Graves (fda's maintainer) has > fixed it in version 2.1.3 which will appear in the newly-released R. > 2.10 in the end of this month. Unfortunately, I was not able to find the > binary file of fad_2.1.3.tar.gz on line. What I can do now is that I can > wrap the fda package that I modified and email to you. What do you think? > > As for the second issue, it seems to me that the data object might be > empty. Anyhow, I will take a look at your data and will get back to you > soon. > > cheers, > Chao-Jen >> >> Hi guys, >> I am experiencing some weird behavior when running the warpSet function >> (flowStats 1.3.19) >> >> The flowSet that I am using is attached. >> >> Issue 1, error: >> > warpSet(original, "FSC-H")$flowset >> Estimating landmarks for channel FSC-H ... >> Registering curves for parameter FSC-H ... >> Error in seq.default(rangeval[1] + del/2, rangeval[2] - del/2, del) : >> wrong sign in 'by' argument >> > >> >> Issue 2, no error but returns NULL: >> > warpSet(original, "FL1-H")$flowset >> Estimating landmarks for channel FL1-H ... >> Registering curves for parameter FL1-H ... >> NULL >> > >> >> This is my configuration: >> > sessionInfo() >> R version 2.10.0 alpha (2009-10-06 r49961) x86_64-unknown-linux-gnu >> >> locale: >> [1] LC_CTYPE=en_CA.UTF-8 LC_NUMERIC=C >> [3] LC_TIME=en_CA.UTF-8 LC_COLLATE=en_CA.UTF-8 >> [5] LC_MONETARY=C LC_MESSAGES=en_CA.UTF-8 >> [7] LC_PAPER=en_CA.UTF-8 LC_NAME=C >> [9] LC_ADDRESS=C LC_TELEPHONE=C >> [11] LC_MEASUREMENT=en_CA.UTF-8 LC_IDENTIFICATION=C >> >> attached base packages: >> [1] splines stats graphics grDevices utils datasets methods >> [8] base >> >> other attached packages: >> [1] flowViz_1.9.9 lattice_0.17-26 flowStats_1.3.19 mvoutlier_1.4 >> [5] fda_2.1.2 zoo_1.5-8 flowCore_1.11.22 rrcov_0.5-02 >> [9] pcaPP_1.7 mvtnorm_0.9-7 robustbase_0.4-5 Biobase_2.5.8 >> >> loaded via a namespace (and not attached): >> [1] feature_1.2.4 graph_1.23.7 grid_2.10.0 >> KernSmooth_2.23-3 >> [5] ks_1.6.7 latticeExtra_0.6-1 MASS_7.3-2 >> RColorBrewer_1.0-2 >> [9] stats4_2.10.0 tools_2.10.0 >> > >> >> Am I just applying it in a stupid way or is there a bug? >> >> Thanks, >> Josef >> >> -- >> Josef Spidlen, Ph.D. >> Terry Fox Laboratory, BC Cancer Agency >> 675 West 10th Avenue, V5Z 1L3 Vancouver, BC, Canada >> >> Tel: +1 (604) 675-8000 x 7755 >> http://www.terryfoxlab.ca/people/rbrinkman/josef.aspx >> >> >> >> > > -- > Chao-Jen Wong > Program in Computational Biology > Division of Public Health Sciences > Fred Hutchinson Cancer Research Center > 1100 Fairview Avenue N., M2-B876 > PO Box 19024 > Seattle, WA 98109 > 206.667.4485 > cwon2 at fhcrc.org > > _______________________________________________ > Bioconductor mailing list > Bioconductor at stat.math.ethz.ch > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: > http://news.gmane.org/gmane.science.biology.informatics.conductor >
ADD REPLY
0
Entering edit mode
Hi, Josef, As for the second issue that you mentioned (below), since warpSet itself returns a flowSet object, it makes sense warpSet(original, "FL1-H")$flowset would return NULL (see the value section in warpSet's man page). The correct way is to get the resulting flowSet object is: obj <- warpSet(original, "FL1-H") str(obj) To view the result, do densityplot(~`FL1-H`, original) Sorry for the delay of my response. Cheers, Chao-Jen >>> >>> >>> Issue 2, no error but returns NULL: >>> > warpSet(original, "FL1-H")$flowset >>> Estimating landmarks for channel FL1-H ... >>> Registering curves for parameter FL1-H ... >>> NULL >>> > -- Chao-Jen Wong Program in Computational Biology Division of Public Health Sciences Fred Hutchinson Cancer Research Center 1100 Fairview Avenue N., M2-B876 PO Box 19024 Seattle, WA 98109 206.667.4485 cwon2 at fhcrc.org
ADD REPLY
0
Entering edit mode
Sorry, forget to attach my sessionInfo. Please notice that I use fda_2.1.3 instead of fda2.1.2 > sessionInfo() R version 2.10.0 Under development (unstable) (2009-09-11 r49665) x86_64-unknown-linux-gnu locale: [1] C attached base packages: [1] splines stats graphics grDevices utils datasets methods [8] base other attached packages: [1] flowViz_1.9.9 lattice_0.17-25 flowStats_1.3.6 fda_2.1.3 [5] zoo_1.5-6 flowCore_1.11.19 rrcov_0.5-01 pcaPP_1.6 [9] mvtnorm_0.9-7 robustbase_0.4-5 Biobase_2.5.8 loaded via a namespace (and not attached): [1] KernSmooth_2.23-3 MASS_7.3-2 RColorBrewer_1.0-2 feature_1.2.3 [5] graph_1.23.2 grid_2.10.0 ks_1.6.5 latticeExtra_0.6-1 [9] stats4_2.10.0 tools_2.10.0 Chao-Jen Wong wrote: > Hi, Josef, > > As for the second issue that you mentioned (below), since warpSet itself > returns a flowSet object, it makes sense warpSet(original, > "FL1-H")$flowset would return NULL (see the value section in warpSet's > man page). The correct way is to get the resulting flowSet object is: > obj <- warpSet(original, "FL1-H") > str(obj) > > To view the result, do > densityplot(~`FL1-H`, original) > > Sorry for the delay of my response. > > Cheers, > Chao-Jen > >>>> Issue 2, no error but returns NULL: >>>> > warpSet(original, "FL1-H")$flowset >>>> Estimating landmarks for channel FL1-H ... >>>> Registering curves for parameter FL1-H ... >>>> NULL >>>> > >>>> > > -- Chao-Jen Wong Program in Computational Biology Division of Public Health Sciences Fred Hutchinson Cancer Research Center 1100 Fairview Avenue N., M2-B876 PO Box 19024 Seattle, WA 98109 206.667.4485 cwon2 at fhcrc.org
ADD REPLY

Login before adding your answer.

Traffic: 536 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6