Installing affy package
2
0
Entering edit mode
dorothyc ▴ 140
@dorothyc-3150
Last seen 8.2 years ago
Hi, I've been experiencing problems installing the affy package (please see output below). I've installed the latest versions of Biobase and affyio already. Thanks very much!! Regards, Dorothy ############# ~/% R CMD INSTALL affy_1.24.2.tar.gz * Installing to library '/home/dorothyc/R/x86_64-unknown-linux-gnu- library/2.8' * Installing *source* package 'affy' ... creating cache ./config.cache checking how to run the C preprocessor... cc -E checking for main in -lz... yes checking for zlib.h... yes checking if zlib version >= 1.1.3... yes updating cache ./config.cache creating ./config.status creating src/Makevars ** libs gcc -std=gnu99 -I/projects/tab/linux/x86_64/lib64/R/include - DHAVE_ZLIB=1 -I/usr/local/include -I"/home/dorothyc/R/x86_64-unknown- linux-gnu-library/2.8/pr eprocessCore/include" -fpic -g -O2 -c chipbackground.c -o chipbackground.o gcc -std=gnu99 -I/projects/tab/linux/x86_64/lib64/R/include - DHAVE_ZLIB=1 -I/usr/local/include -I"/home/dorothyc/R/x86_64-unknown- linux-gnu-library/2.8/pr eprocessCore/include" -fpic -g -O2 -c getall_locations.c -o getall_locations.o gcc -std=gnu99 -I/projects/tab/linux/x86_64/lib64/R/include - DHAVE_ZLIB=1 -I/usr/local/include -I"/home/dorothyc/R/x86_64-unknown- linux-gnu-library/2.8/pr eprocessCore/include" -fpic -g -O2 -c mas5calls.c -o mas5calls.o gcc -std=gnu99 -I/projects/tab/linux/x86_64/lib64/R/include - DHAVE_ZLIB=1 -I/usr/local/include -I"/home/dorothyc/R/x86_64-unknown- linux-gnu-library/2.8/pr eprocessCore/include" -fpic -g -O2 -c rma2.c -o rma2.o gcc -std=gnu99 -I/projects/tab/linux/x86_64/lib64/R/include - DHAVE_ZLIB=1 -I/usr/local/include -I"/home/dorothyc/R/x86_64-unknown- linux-gnu-library/2.8/pr eprocessCore/include" -fpic -g -O2 -c rma_common.c -o rma_common.o gcc -std=gnu99 -shared -L/usr/local/lib64 -o affy.so chipbackground.o getall_locations.o mas5calls.o rma2.o rma_common.o -lz ** R ** data ** demo ** inst ** preparing package for lazy loading Loading required package: Biobase Welcome to Bioconductor Vignettes contain introductory material. To view, type 'openVignette()'. To cite Bioconductor, see 'citation("Biobase")' and for packages 'citation(pkgname)'. Error in importIntoEnv(impenv, impnames, ns, impvars) : object ''smoothScatter'' is not exported by 'namespace:graphics' Calls: <anonymous> ... loadNamespace -> namespaceImportFrom -> importIntoEnv Execution halted ERROR: lazy loading failed for package 'affy' ** Removing '/home/dorothyc/R/x86_64-unknown-linux-gnu- library/2.8/affy' ** Restoring previous '/home/dorothyc/R/x86_64-unknown-linux-gnu- library/2.8/affy' [[alternative HTML version deleted]]
Biobase affy Biobase affy • 1.6k views
ADD COMMENT
0
Entering edit mode
Seth Falcon ★ 7.4k
@seth-falcon-992
Last seen 8.2 years ago
Hi Dorothy, On 11/24/09 4:43 PM, dorothyc wrote: > I've been experiencing problems installing the affy package (please > see output below). I've installed the latest versions of Biobase and > affyio already. > > ############# > ~/% R CMD INSTALL affy_1.24.2.tar.gz Is there a reason you are not using the biocLite helper script? Can you please try from a clean R session: source("http://bioconductor.org/biocLite.R") biocLite("affy") If that fails, let us know and include the error message and the output of sessionInfo(). Thanks, + seth -- Seth Falcon Program in Computational Biology | Fred Hutchinson Cancer Research Center
ADD COMMENT
0
Entering edit mode
@keith-satterley-1452
Last seen 8.1 years ago
Australia
Hi Dorothy, I'm not sure about the smootScatter error. Sometimes these sort of things are sorted out by having compatible versions. Have you tried using biocLite? Do the following: source("http://bioconductor.org/biocLite.R") biocLite("affy",dependencies=TRUE) This will ensure you get the correct version of affy for your version of R. If you provide the output from the sessionInfo() function, people can tell what versions of software you have and whether they match or not. If possible install the latest R, (currently version 2.10.0) and use biocLite, as described above and also at the bioconductor website: http://www.bioconductor.org/docs/install/ hope that helps, Keith. dorothyc wrote: > Hi, > > I've been experiencing problems installing the affy package (please > see output below). I've installed the latest versions of Biobase and > affyio already. > > Thanks very much!! > > Regards, > Dorothy > > ############# > ~/% R CMD INSTALL affy_1.24.2.tar.gz > * Installing to library '/home/dorothyc/R/x86_64-unknown-linux-gnu- > library/2.8' > * Installing *source* package 'affy' ... > creating cache ./config.cache > checking how to run the C preprocessor... cc -E > checking for main in -lz... yes > checking for zlib.h... yes > checking if zlib version >= 1.1.3... yes > updating cache ./config.cache > creating ./config.status > creating src/Makevars > ** libs > gcc -std=gnu99 -I/projects/tab/linux/x86_64/lib64/R/include - > DHAVE_ZLIB=1 -I/usr/local/include -I"/home/dorothyc/R/x86_64-unknown- > linux-gnu-library/2.8/pr > eprocessCore/include" -fpic -g -O2 -c chipbackground.c -o > chipbackground.o > gcc -std=gnu99 -I/projects/tab/linux/x86_64/lib64/R/include - > DHAVE_ZLIB=1 -I/usr/local/include -I"/home/dorothyc/R/x86_64-unknown- > linux-gnu-library/2.8/pr > eprocessCore/include" -fpic -g -O2 -c getall_locations.c -o > getall_locations.o > gcc -std=gnu99 -I/projects/tab/linux/x86_64/lib64/R/include - > DHAVE_ZLIB=1 -I/usr/local/include -I"/home/dorothyc/R/x86_64-unknown- > linux-gnu-library/2.8/pr > eprocessCore/include" -fpic -g -O2 -c mas5calls.c -o mas5calls.o > gcc -std=gnu99 -I/projects/tab/linux/x86_64/lib64/R/include - > DHAVE_ZLIB=1 -I/usr/local/include -I"/home/dorothyc/R/x86_64-unknown- > linux-gnu-library/2.8/pr > eprocessCore/include" -fpic -g -O2 -c rma2.c -o rma2.o > gcc -std=gnu99 -I/projects/tab/linux/x86_64/lib64/R/include - > DHAVE_ZLIB=1 -I/usr/local/include -I"/home/dorothyc/R/x86_64-unknown- > linux-gnu-library/2.8/pr > eprocessCore/include" -fpic -g -O2 -c rma_common.c -o rma_common.o > gcc -std=gnu99 -shared -L/usr/local/lib64 -o affy.so chipbackground.o > getall_locations.o mas5calls.o rma2.o rma_common.o -lz > ** R > ** data > ** demo > ** inst > ** preparing package for lazy loading > > Loading required package: Biobase > > Welcome to Bioconductor > > Vignettes contain introductory material. To view, type > 'openVignette()'. To cite Bioconductor, see > 'citation("Biobase")' and for packages 'citation(pkgname)'. > > Error in importIntoEnv(impenv, impnames, ns, impvars) : > object ''smoothScatter'' is not exported by 'namespace:graphics' > Calls: <anonymous> ... loadNamespace -> namespaceImportFrom -> > importIntoEnv > Execution halted > ERROR: lazy loading failed for package 'affy' > ** Removing '/home/dorothyc/R/x86_64-unknown-linux-gnu- library/2.8/affy' > ** Restoring previous '/home/dorothyc/R/x86_64-unknown-linux-gnu- > library/2.8/affy' > [[alternative HTML version deleted]] > > _______________________________________________ > Bioconductor mailing list > Bioconductor at stat.math.ethz.ch > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor >
ADD COMMENT
0
Entering edit mode
On 11/24/09 5:20 PM, Keith Satterley wrote: > Hi Dorothy, > > I'm not sure about the smootScatter error. Sometimes these sort of > things are sorted out by having compatible versions. Have you tried > using biocLite? Do the following: > > source("http://bioconductor.org/biocLite.R") > biocLite("affy",dependencies=TRUE) > > This will ensure you get the correct version of affy for your version of R. By default, biocLite should install all dependencies. Setting dependencies=TRUE will install many packages that you don't need because it includes all packages in the "Suggests" category and does so recursively. + seth
ADD REPLY
0
Entering edit mode
Hi Seth and Keith, It works now. Thanks very much for your help. Regards, Dorothy On Nov 24, 2009, at 8:59 PM, Seth Falcon wrote: > On 11/24/09 5:20 PM, Keith Satterley wrote: >> Hi Dorothy, >> >> I'm not sure about the smootScatter error. Sometimes these sort of >> things are sorted out by having compatible versions. Have you tried >> using biocLite? Do the following: >> >> source("http://bioconductor.org/biocLite.R") >> biocLite("affy",dependencies=TRUE) >> >> This will ensure you get the correct version of affy for your >> version of R. > > By default, biocLite should install all dependencies. Setting > dependencies=TRUE will install many packages that you don't need > because > it includes all packages in the "Suggests" category and does so > recursively. > > + seth
ADD REPLY

Login before adding your answer.

Traffic: 474 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6