EBImage installation on Mac OS X 10.6
2
0
Entering edit mode
Milan Esner ▴ 10
@milan-esner-3891
Last seen 7.7 years ago
Hi, I have some difficulties with installing EBImage package to my R running on Mac OS X 10.6. I am currently running R sessionInfo() R version 2.10.1 (2009-12-14) i386-apple-darwin9.8.0 locale: [1] en_US.UTF-8/en_US.UTF-8/C/C/en_US.UTF-8/en_US.UTF-8 attached base packages: [1] stats graphics grDevices utils datasets methods base other attached packages: [1] abind_1.1-0 loaded via a namespace (and not attached): [1] tools_2.10.1 on Mac OS X 10.6.1. I followed all the installation, I installed MacPort, GTK2+ and Imagemagick. On the command line Image magick works, but if I want to load EBIimage in R I have this error message: library(EBImage) Error in dyn.load(file, DLLpath = DLLpath, ...) : unable to load shared library '/Users/esner/Library/R/2.10/library/EBImage/libs/i386/EBImage.so': dlopen(/Users/esner/Library/R/2.10/library/EBImage/libs/i386/EBImage .so, 6): Library not loaded: /usr/local/lib/libMagick.10.dylib Referenced from: /Users/esner/Library/R/2.10/library/EBImage/libs/i386/EBImage.so Reason: image not found Error: package/namespace load failed for 'EBImage' Could someone help. Thanks a lot. Milan
EBImage EBImage • 1.0k views
ADD COMMENT
0
Entering edit mode
@kasper-daniel-hansen-2979
Last seen 10 months ago
United States
Install EBImage using pkgType = "source" and make sure it picks up your MacPorts version of Imagemagick (which may require some fiddling). You probably used pkgType = "mac.binary" which assumes you are using another version of Imagemagick, residing in /usr/local. You might also consider using Simon Urbaneks's gtk2/Imagemagick distribution, which he just updated for 64 bit (which I have not tried). However, that is right now in a state for intermediate- advanced users (see recent r-sig-mac posting). Kasper On Jan 13, 2010, at 9:46 AM, Milan Esner wrote: > Hi, > I have some difficulties with installing EBImage package to my R running on Mac OS X 10.6. > > I am currently running R > > sessionInfo() > R version 2.10.1 (2009-12-14) > i386-apple-darwin9.8.0 > > locale: > [1] en_US.UTF-8/en_US.UTF-8/C/C/en_US.UTF-8/en_US.UTF-8 > > attached base packages: > [1] stats graphics grDevices utils datasets methods base > > other attached packages: > [1] abind_1.1-0 > > loaded via a namespace (and not attached): > [1] tools_2.10.1 > > on Mac OS X 10.6.1. > > I followed all the installation, I installed MacPort, GTK2+ and Imagemagick. On the command line Image magick works, but if I want to load EBIimage in R I have this error message: > > library(EBImage) > Error in dyn.load(file, DLLpath = DLLpath, ...) : > unable to load shared library '/Users/esner/Library/R/2.10/library/EBImage/libs/i386/EBImage.so': > dlopen(/Users/esner/Library/R/2.10/library/EBImage/libs/i386/EBImag e.so, 6): Library not loaded: /usr/local/lib/libMagick.10.dylib > Referenced from: /Users/esner/Library/R/2.10/library/EBImage/libs/i386/EBImage.so > Reason: image not found > Error: package/namespace load failed for 'EBImage' > > > Could someone help. Thanks a lot. > > Milan > > _______________________________________________ > Bioconductor mailing list > Bioconductor at stat.math.ethz.ch > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor
ADD COMMENT
0
Entering edit mode
Gregoire Pau ▴ 310
@gregoire-pau-3274
Last seen 7.7 years ago
Hello Milan, > Library not loaded: /usr/local/lib/libMagick.10.dylib If you used MacPorts to install ImageMagick then libMagick is located in /opt/local/ ... and not in /usr/local/lib. It looks like you are using the binary EBImage Mac package. Please download and compile the *source* package (.tar.gz) instead, from: http://www.bioconductor.org/packages/release/bioc/html/EBImage.html We are currently working on a new version of EBImage based on Qt, which will be much easier to install. Best regards, Greg --- Gregoire Pau EMBL Research officer http://www.ebi.ac.uk/~gpau/ Milan Esner wrote: > Hi, > I have some difficulties with installing EBImage package to my R running on Mac OS X 10.6. > > I am currently running R > > sessionInfo() > R version 2.10.1 (2009-12-14) > i386-apple-darwin9.8.0 > > locale: > [1] en_US.UTF-8/en_US.UTF-8/C/C/en_US.UTF-8/en_US.UTF-8 > > attached base packages: > [1] stats graphics grDevices utils datasets methods base > > other attached packages: > [1] abind_1.1-0 > > loaded via a namespace (and not attached): > [1] tools_2.10.1 > > on Mac OS X 10.6.1. > > I followed all the installation, I installed MacPort, GTK2+ and Imagemagick. On the command line Image magick works, but if I want to load EBIimage in R I have this error message: > > library(EBImage) > Error in dyn.load(file, DLLpath = DLLpath, ...) : > unable to load shared library '/Users/esner/Library/R/2.10/library/EBImage/libs/i386/EBImage.so': > dlopen(/Users/esner/Library/R/2.10/library/EBImage/libs/i386/EBIma ge.so, 6): Library not loaded: /usr/local/lib/libMagick.10.dylib > Referenced from: /Users/esner/Library/R/2.10/library/EBImage/libs/i386/EBImage.so > Reason: image not found > Error: package/namespace load failed for 'EBImage' > > > Could someone help. Thanks a lot. > > Milan > > _______________________________________________ > Bioconductor mailing list > Bioconductor at stat.math.ethz.ch > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor
ADD COMMENT

Login before adding your answer.

Traffic: 258 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6