question on SPIA pavkage application
2
0
Entering edit mode
Jing Huang ▴ 380
@jing-huang-4737
Last seen 7.2 years ago
Thank You so much for all of you. I tried and it works on previous problem. Now I am having another problem. I am so sorry for not being able to solve problems myself. Can somebody advise me? Here is the R to follow SPIA package: >x=topTable(fit,coef=WThypo,n==1003) >library(mgu74av2.db) >y=mgu74av2ENTREZID >x$ENTREZ=toTable(mgu74av2ENTREZID)[match(x$ID,toTable(mgu74av2ENTREZI D)[, 1]), 2] >x=x[!is.na(x$ENTREZ),] >x=x[!duplicated(x$ENTREZ),] >tg1=x[x$adj.P.Val<0.1,] >WThypo=tg1$logFC >head(WThypo) [1] 4.80 3.27 2.65 2.63 3.03 -3.41 At this step: I should received a outcome like this: 11535 20525 11839 15277 11910 18639 [1] 4.80 3.27 2.65 2.63 3.03 -3.41 >WThypo1=x$ENTREZ >head(WThypo) [1] "11535" "20525" "11839" "15277" "11910" "18639" >res=spia(de=WThypo,all=HWThypo1,organism="mmu",nB=2000,plots=F,beta=N ULL,combine="fisher",verbose=F) Error in spia(de = WThypo, all = WThypo1, organism = "mmu", nB = 2000, : de must be a vector of log2 fold changes. The names of de should be included in the refference array! I am not sure what I did wrong. I didn't have issue with this procedure before. Many Many Thanks [[alternative HTML version deleted]]
Organism SPIA Organism SPIA • 876 views
ADD COMMENT
0
Entering edit mode
@freudenberg-johannes-nihniehs-e-4789
Last seen 7.2 years ago
Hi Jing, I'm not sure how you got from here: >>head(WThypo) >[1] 4.80 3.27 2.65 2.63 3.03 -3.41 which look like log2 fold changes to me, to here, a character vector: >>WThypo1=x$ENTREZ >>head(WThypo) >[1] "11535" "20525" "11839" "15277" "11910" "18639" However, that seems to be the problem. In the error message is clearly says that you need "a vector of log2 fold changes", not a character vector. Best, --Johannes -----Original Message----- From: Jing Huang [mailto:huangji@ohsu.edu] Sent: Wednesday, August 24, 2011 1:22 PM To: 'bioconductor at r-project.org' Subject: [BioC] question on SPIA pavkage application Thank You so much for all of you. I tried and it works on previous problem. Now I am having another problem. I am so sorry for not being able to solve problems myself. Can somebody advise me? Here is the R to follow SPIA package: >x=topTable(fit,coef=WThypo,n==1003) >library(mgu74av2.db) >y=mgu74av2ENTREZID >x$ENTREZ=toTable(mgu74av2ENTREZID)[match(x$ID,toTable(mgu74av2ENTREZI D)[, 1]), 2] >x=x[!is.na(x$ENTREZ),] >x=x[!duplicated(x$ENTREZ),] >tg1=x[x$adj.P.Val<0.1,] >WThypo=tg1$logFC >head(WThypo) [1] 4.80 3.27 2.65 2.63 3.03 -3.41 At this step: I should received a outcome like this: 11535 20525 11839 15277 11910 18639 [1] 4.80 3.27 2.65 2.63 3.03 -3.41 >WThypo1=x$ENTREZ >head(WThypo) [1] "11535" "20525" "11839" "15277" "11910" "18639" >res=spia(de=WThypo,all=HWThypo1,organism="mmu",nB=2000,plots=F,beta=N ULL,combine="fisher",verbose=F) Error in spia(de = WThypo, all = WThypo1, organism = "mmu", nB = 2000, : de must be a vector of log2 fold changes. The names of de should be included in the refference array! I am not sure what I did wrong. I didn't have issue with this procedure before. Many Many Thanks [[alternative HTML version deleted]] _______________________________________________ Bioconductor mailing list Bioconductor at r-project.org https://stat.ethz.ch/mailman/listinfo/bioconductor Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor
0
Entering edit mode
@alex-gutteridge-2935
Last seen 7.2 years ago
United States
On Wed, 24 Aug 2011 10:22:10 -0700, Jing Huang wrote: > Thank You so much for all of you. > > I tried and it works on previous problem. > > Now I am having another problem. I am so sorry for not being able to > solve problems myself. Can somebody advise me? > > Here is the R to follow SPIA package: > >>x=topTable(fit,coef=WThypo,n==1003) >>library(mgu74av2.db) >>y=mgu74av2ENTREZID >>x$ENTREZ=toTable(mgu74av2ENTREZID)[match(x$ID,toTable(mgu74av2ENTREZ ID)[, >> 1]), 2] >>x=x[!is.na(x$ENTREZ),] >>x=x[!duplicated(x$ENTREZ),] >>tg1=x[x$adj.P.Val<0.1,] >>WThypo=tg1$logFC >>head(WThypo) > > [1] 4.80 3.27 2.65 2.63 3.03 -3.41 > > At this step: I should received a outcome like this: > > 11535 20525 11839 15277 11910 18639 > > [1] 4.80 3.27 2.65 2.63 3.03 -3.41 > >>WThypo1=x$ENTREZ >>head(WThypo) > > [1] "11535" "20525" "11839" "15277" "11910" "18639" > >>res=spia(de=WThypo,all=HWThypo1,organism="mmu",nB=2000,plots=F,beta= NULL,combine="fisher",verbose=F) > > Error in spia(de = WThypo, all = WThypo1, organism = "mmu", nB = > 2000, : > > de must be a vector of log2 fold changes. The names of de should be > included in the refference array! > > I am not sure what I did wrong. I didn't have issue with this > procedure before. Last time you correctly set the names of the DE gene vector to be the Entrez IDs. So you need: names(WThypo) = tg1$ENTREZ before running spia. -- Alex Gutteridge
ADD COMMENT

Login before adding your answer.

Traffic: 657 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6