Question: TopTable function in affylmGUI does not have Gene names
0
gravatar for Guest User
7.9 years ago by
Guest User12k
Guest User12k wrote:
Dear All, I would be grateful if you could provide assistance with a problem I am experiencing using Bioconductor to analyse Affymetrics microarray data. I am using the package affylmGUI and have managed to reproduce volcano plots from both experimental and other test data which have probe set IDs. This is after normalisation and linear model fitting. However when I try to apply gene names the error below occurs. Error in text.default(fit$coef[topGenes],fit$lods[topGenes], labels=substring(genelist[topGenes, : zero length 'labels' The volcano plot is produced but with no labels. Also the TopTable does not contain gene names or functions. This occurs with data files from two different chips. I have just started analysing data using R and bioconductor and so have tried to work this problem but have unfortunately been unable to resolve the situation. I am using MacOSX Snow Leopard and would be grateful for any help. With kindest regards, Dr Jagtar Singh Nijjar Clinical Lecturer in Rheumatology University of Glasgow -- output of sessionInfo(): R version 2.14.0 (2011-10-31) Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit) locale: [1] en_GB.UTF-8/en_GB.UTF-8/en_GB.UTF-8/C/en_GB.UTF-8/en_GB.UTF-8 attached base packages: [1] tcltk stats graphics grDevices utils [6] datasets methods base other attached packages: [1] mogene10stv1cdf_2.9.1 AnnotationDbi_1.16.10 [3] affylmGUI_1.28.0 affyio_1.22.0 [5] affy_1.32.0 Biobase_2.14.0 [7] limma_3.10.0 loaded via a namespace (and not attached): [1] BiocInstaller_1.2.1 DBI_0.2-5 [3] IRanges_1.12.5 preprocessCore_1.16.0 [5] RSQLite_0.11.1 tools_2.14.0 [7] zlibbioc_1.0.0 Warning messages: 1: The biocReposList() function is deprecated. Please use biocLite() to install packages: source("http://bioconductor.org/biocLite.R") biocLite("<pkgname>") If you really need to get the list of Bioconductor package repositories (like biocReposList() does), then do: source("http://bioconductor.org/biocLite.R") biocinstallRepos() 2: In getDependencies(pkgs, dependencies, available, lib) : Do not know which element of 'lib' to install dependencies into skipping dependencies 3: In getDependencies(pkgs, dependencies, available, lib) : package ???mogene10stv1??? is not available (for R version 2.14.0) -- Sent via the guest posting facility at bioconductor.org.
affylmgui • 655 views
ADD COMMENTlink written 7.9 years ago by Guest User12k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 224 users visited in the last hour