LumiT VST error
1
0
Entering edit mode
@paolo-kunderfranco-5158
Last seen 5.3 years ago
Hello, i am having problems with VST with my Illumina data, My values are all positive using lumiB "forcePositive" and my QC plots looks fine, Can anyone help me? Thanks, Paolo > library("lumi") > fileName<-"ANG.txt" > x.lumi<-lumiR.batch(fileName) Inputting the data ... Annotation columns are not available in the data. Duplicated IDs found and were merged! Adding nuID to the data ... Please provide Illumina ID Mapping library! Perform Quality Control assessment of the LumiBatch object ... Warning message: In as.vector(data) : si ? prodotto un NA per coercizione > lumi.T<-lumiT(x.lumi) Perform vst transformation ... 2012-03-13 15:33:15 , processing array 1 Errore in if (any(std < 0)) { : valore mancante dove ? richiesto TRUE/FALSE > sessionInfo() R version 2.12.1 (2010-12-16) Platform: i386-pc-mingw32/i386 (32-bit) locale: [1] LC_COLLATE=Italian_Italy.1252 LC_CTYPE=Italian_Italy.1252 LC_MONETARY=Italian_Italy.1252 LC_NUMERIC=C [5] LC_TIME=Italian_Italy.1252 attached base packages: [1] stats graphics grDevices utils datasets methods base other attached packages: [1] limma_3.6.9 lumi_2.2.1 Biobase_2.10.0 loaded via a namespace (and not attached): [1] affy_1.28.1 affyio_1.18.0 annotate_1.28.1 AnnotationDbi_1.12.1 DBI_0.2-5 grid_2.12.1 [7] hdrcde_2.15 KernSmooth_2.23-4 lattice_0.19-13 MASS_7.3-9 Matrix_0.999375-46 methylumi_1.6.1 [13] mgcv_1.7-2 nlme_3.1-97 preprocessCore_1.12.0 RSQLite_0.10.0 tools_2.12.1 xtable_1.6-0
lumi lumi • 710 views
ADD COMMENT
0
Entering edit mode
Pan Du ▴ 440
@pan-du-4636
Last seen 8.1 years ago
Hi Paolo Please update your R and lumi package. I remember this was fixed a while ago. Pan > Date: Tue, 13 Mar 2012 15:39:43 +0100 > From: Paolo Kunderfranco <paolo.kunderfranco at="" gmail.com=""> > To: bioconductor at r-project.org > Subject: [BioC] LumiT VST error > Message-ID: > ? ? ? ?<cagxwfc9ixxhjcdvdctakuchjzgcosxg_t7ncoozbf=ef_cubmq at="" mail.gmail.com=""> > Content-Type: text/plain; charset=ISO-8859-1 > > Hello, i am having problems with VST with my Illumina data, > My values are all positive using lumiB "forcePositive" and my QC plots > looks fine, > Can anyone help me? > Thanks, > Paolo > > >> library("lumi") >> fileName<-"ANG.txt" >> x.lumi<-lumiR.batch(fileName) > Inputting the data ... > Annotation columns are not available in the data. > Duplicated IDs found and were merged! > > Adding nuID to the data ... > Please provide Illumina ID Mapping library! > Perform Quality Control assessment of the LumiBatch object ... > Warning message: > In as.vector(data) : si ? prodotto un NA per coercizione >> lumi.T<-lumiT(x.lumi) > Perform vst transformation ... > 2012-03-13 15:33:15 , processing array ?1 > Errore in if (any(std < 0)) { : > ?valore mancante dove ? richiesto TRUE/FALSE >> sessionInfo() > R version 2.12.1 (2010-12-16) > Platform: i386-pc-mingw32/i386 (32-bit) > > locale: > [1] LC_COLLATE=Italian_Italy.1252 ?LC_CTYPE=Italian_Italy.1252 > LC_MONETARY=Italian_Italy.1252 LC_NUMERIC=C > [5] LC_TIME=Italian_Italy.1252 > > attached base packages: > [1] stats ? ? graphics ?grDevices utils ? ? datasets ?methods ? base > > other attached packages: > [1] limma_3.6.9 ? ?lumi_2.2.1 ? ? Biobase_2.10.0 > > loaded via a namespace (and not attached): > ?[1] affy_1.28.1 ? ? ? ? ? affyio_1.18.0 ? ? ? ? annotate_1.28.1 > AnnotationDbi_1.12.1 ?DBI_0.2-5 ? ? ? ? ? ? grid_2.12.1 > ?[7] hdrcde_2.15 ? ? ? ? ? KernSmooth_2.23-4 ? ? lattice_0.19-13 > MASS_7.3-9 ? ? ? ? ? ?Matrix_0.999375-46 ? ?methylumi_1.6.1 > [13] mgcv_1.7-2 ? ? ? ? ? ?nlme_3.1-97 ? ? ? ? ? preprocessCore_1.12.0 > RSQLite_0.10.0 ? ? ? ?tools_2.12.1 ? ? ? ? ?xtable_1.6-0 > >
ADD COMMENT

Login before adding your answer.

Traffic: 181 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6