Search
Question: Problems installing Genominator and GenomeGraphs
0
gravatar for Guest User
6.7 years ago by
Guest User12k
Guest User12k wrote:
I already used source("http://bioconductor.org/biocLite.R") biocLite("Genominator") Warning messages: 1: In install.packages(pkgs = pkgs, repos = repos, ...) : installation of package 'RCurl' had non-zero exit status 2: In install.packages(pkgs = pkgs, repos = repos, ...) : installation of package 'biomaRt' had non-zero exit status 3: In install.packages(pkgs = pkgs, repos = repos, ...) : installation of package 'GenomeGraphs' had non-zero exit status 4: In install.packages(pkgs = pkgs, repos = repos, ...) : installation of package 'Genominator' had non-zero exit status I already tried with others packages and had no problem. Apparently is the biomaRt package, when tried to install it directly, I had the same problem. What do I need to do? Thank you. -- output of sessionInfo(): R version 2.12.1 (2010-12-16) Platform: i686-pc-linux-gnu (32-bit) locale: [1] LC_CTYPE=en_GB.UTF-8 LC_NUMERIC=C [3] LC_TIME=en_GB.UTF-8 LC_COLLATE=en_GB.UTF-8 [5] LC_MONETARY=C LC_MESSAGES=en_GB.UTF-8 [7] LC_PAPER=en_GB.UTF-8 LC_NAME=C [9] LC_ADDRESS=C LC_TELEPHONE=C [11] LC_MEASUREMENT=en_GB.UTF-8 LC_IDENTIFICATION=C attached base packages: [1] stats graphics grDevices utils datasets methods base loaded via a namespace (and not attached): [1] tools_2.12.1 -- Sent via the guest posting facility at bioconductor.org.
ADD COMMENTlink modified 6.7 years ago by Dan Tenenbaum ♦♦ 8.2k • written 6.7 years ago by Guest User12k
0
gravatar for Dan Tenenbaum
6.7 years ago by
Dan Tenenbaum ♦♦ 8.2k
United States
Dan Tenenbaum ♦♦ 8.2k wrote:
Hello Jose, On Tue, Apr 3, 2012 at 12:21 PM, Jose Lopez [guest] <guest at="" bioconductor.org=""> wrote: > > I already used > > source("http://bioconductor.org/biocLite.R") > biocLite("Genominator") > Warning messages: > 1: In install.packages(pkgs = pkgs, repos = repos, ...) : > ?installation of package 'RCurl' had non-zero exit status > 2: In install.packages(pkgs = pkgs, repos = repos, ...) : > ?installation of package 'biomaRt' had non-zero exit status > 3: In install.packages(pkgs = pkgs, repos = repos, ...) : > ?installation of package 'GenomeGraphs' had non-zero exit status > 4: In install.packages(pkgs = pkgs, repos = repos, ...) : > ?installation of package 'Genominator' had non-zero exit status > > I already tried with others packages and had no problem. > > Apparently is the biomaRt package, when tried to install it directly, I had the same problem. What do I need to do? What makes you say that biomaRt is the problem? It looks like RCurl is the problem. But...what are your CRAN and Bioconductor mirrors set to? What happens if you start R as follows: R --vanilla Try that and let us know if it works. Also, as always, we recommend working with the latest release version of R (2.15) if possible. Thanks, Dan > > Thank you. > > ?-- output of sessionInfo(): > > R version 2.12.1 (2010-12-16) > Platform: i686-pc-linux-gnu (32-bit) > > locale: > ?[1] LC_CTYPE=en_GB.UTF-8 ? ? ? LC_NUMERIC=C > ?[3] LC_TIME=en_GB.UTF-8 ? ? ? ?LC_COLLATE=en_GB.UTF-8 > ?[5] LC_MONETARY=C ? ? ? ? ? ? ?LC_MESSAGES=en_GB.UTF-8 > ?[7] LC_PAPER=en_GB.UTF-8 ? ? ? LC_NAME=C > ?[9] LC_ADDRESS=C ? ? ? ? ? ? ? LC_TELEPHONE=C > [11] LC_MEASUREMENT=en_GB.UTF-8 LC_IDENTIFICATION=C > > attached base packages: > [1] stats ? ? graphics ?grDevices utils ? ? datasets ?methods ? base > > loaded via a namespace (and not attached): > [1] tools_2.12.1 > > -- > Sent via the guest posting facility at bioconductor.org. > > _______________________________________________ > Bioconductor mailing list > Bioconductor at r-project.org > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor
ADD COMMENTlink written 6.7 years ago by Dan Tenenbaum ♦♦ 8.2k
Thank you Dan. I've been searching that package. I found this page<http: www.omegahat.org="" rcurl="" faq.html=""> . As you mentioned, the problem is RCurl. Now It works correctly, I installed RCurl by terminal (R CMD INSTALL RCurl.....tar.gz). Then run R and installed with biocLite("Genominator"). When it was in installation, there were no errors, and installed every dependencies. Thank you Dan. Best regards. José 2012/4/3 Dan Tenenbaum <dtenenba@fhcrc.org> > Hello Jose, > > On Tue, Apr 3, 2012 at 12:21 PM, Jose Lopez [guest] > <guest@bioconductor.org> wrote: > > > > I already used > > > > source("http://bioconductor.org/biocLite.R") > > biocLite("Genominator") > > Warning messages: > > 1: In install.packages(pkgs = pkgs, repos = repos, ...) : > > installation of package 'RCurl' had non-zero exit status > > 2: In install.packages(pkgs = pkgs, repos = repos, ...) : > > installation of package 'biomaRt' had non-zero exit status > > 3: In install.packages(pkgs = pkgs, repos = repos, ...) : > > installation of package 'GenomeGraphs' had non-zero exit status > > 4: In install.packages(pkgs = pkgs, repos = repos, ...) : > > installation of package 'Genominator' had non-zero exit status > > > > I already tried with others packages and had no problem. > > > > Apparently is the biomaRt package, when tried to install it directly, I > had the same problem. What do I need to do? > > What makes you say that biomaRt is the problem? It looks like RCurl is > the problem. > > But...what are your CRAN and Bioconductor mirrors set to? What happens > if you start R as follows: > > R --vanilla > > Try that and let us know if it works. > > > Also, as always, we recommend working with the latest release version > of R (2.15) if possible. > > Thanks, > Dan > > > > > > Thank you. > > > > -- output of sessionInfo(): > > > > R version 2.12.1 (2010-12-16) > > Platform: i686-pc-linux-gnu (32-bit) > > > > locale: > > [1] LC_CTYPE=en_GB.UTF-8 LC_NUMERIC=C > > [3] LC_TIME=en_GB.UTF-8 LC_COLLATE=en_GB.UTF-8 > > [5] LC_MONETARY=C LC_MESSAGES=en_GB.UTF-8 > > [7] LC_PAPER=en_GB.UTF-8 LC_NAME=C > > [9] LC_ADDRESS=C LC_TELEPHONE=C > > [11] LC_MEASUREMENT=en_GB.UTF-8 LC_IDENTIFICATION=C > > > > attached base packages: > > [1] stats graphics grDevices utils datasets methods base > > > > loaded via a namespace (and not attached): > > [1] tools_2.12.1 > > > > -- > > Sent via the guest posting facility at bioconductor.org. > > > > _______________________________________________ > > Bioconductor mailing list > > Bioconductor@r-project.org > > https://stat.ethz.ch/mailman/listinfo/bioconductor > > Search the archives: > http://news.gmane.org/gmane.science.biology.informatics.conductor > [[alternative HTML version deleted]]
ADD REPLYlink written 6.7 years ago by José Fabricio López Hernández10
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 365 users visited in the last hour