Question: missing probe_id in ath1121501.db
0
gravatar for Guest User
7.1 years ago by
Guest User12k
Guest User12k wrote:
Already in reference to the post in biocondcutor mailing list (https:/ /stat.ethz.ch/pipermail/bioconductor/2012-February/043741.html) , Iam facing the same issues: universe<-mget(c("244901_at", "244902_at", "244903_at", "244904_at", "244905_at", + "244906_at", "244907_at", "244908_at", "244909_at", "244910_s_at", + "244911_at", "244912_at", "244913_at", "244914_at", "244915_s_at", + "244916_at", "244917_at", "244918_at", "244919_at", "244920_s_at", + "244921_s_at", "244922_s_at", "244923_s_at", "244924_at", "244925_at", + "244926_s_at", "244927_at", "244928_s_at", "244929_at", "244930_at", + "244931_at", "244932_at", "244933_at", "244934_at", "244935_at", + "244936_at", "244937_at", "244938_at", "244939_at", "244940_at", + "244941_at", "244942_at", "244943_at", "244944_s_at", "244945_at", + "244946_at", "244947_at", "244948_at", "244949_at", "244950_at", + "244951_s_at", "244952_at", "244953_s_at", "244954_s_at", "244955_at", + "244956_s_at", "244957_at", "244958_at", "244959_s_at", "244960_at", + "244961_at", "244962_at", "244963_at", "244964_at", "244965_at", + "244966_at", "244967_at", "244968_at", "244969_at", "244970_at", + "244971_at", "244972_at", "244973_at", "244974_at", "244975_at", + "244976_at", "244977_at", "244978_at", "244979_at", "244980_at", + "244981_at", "244982_at", "244983_at", "244984_at", "244985_at", + "244986_at", "244987_s_at", "244988_s_at", "244989_s_at", "244990_s_at", + "244991_s_at", "244992_s_at", "244993_s_at", "244994_at", "244995_at") selected<-mget(c("244901_at", "244910_s_at", "245000_at", "245001_at", "245002_at", + "245003_at", "245004_at", "245005_at", "245006_at", "245007_at", + "245008_at", "245009_at", "244911_at", "245010_at", "245011_at") params <- new("GOHyperGParams", geneIds = selected, universeGeneIds = universe, annotation="ath1121501", + ontology = "MF", pvalueCutoff = 0.5, conditional = FALSE, testDirection = "over") hgOver <- hyperGTest(params) head(summary(hgOver), n = 1) GOMFID Pvalue OddsRatio ExpCount Count Size Term 1 GO:0005488 0.006822516 2.87234 20.08571 27 38 binding The above works but when I intend to use it for the whole data as follows it fails: universe <- unlist(mget(myd, ath1121501ACCNUM)) Error in .checkKeys(value, Lkeys(x), x at ifnotfound) : value for "245651_s_at" not found length(as.list(toggleProbes(ath1121501ACCNUM,"all"))) [1] 22809 # whereas there should be 22810 as in the chip. -- output of sessionInfo(): R version 2.15.2 (2012-10-26) Platform: i686-redhat-linux-gnu (32-bit) locale: [1] LC_CTYPE=en_US.UTF-8 LC_NUMERIC=C LC_TIME=en_US.UTF-8 [4] LC_COLLATE=en_US.UTF-8 LC_MONETARY=en_US.UTF-8 LC_MESSAGES=en_US.UTF-8 [7] LC_PAPER=C LC_NAME=C LC_ADDRESS=C [10] LC_TELEPHONE=C LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C attached base packages: [1] stats graphics grDevices utils datasets methods base other attached packages: [1] annaffy_1.28.0 KEGG.db_2.7.1 GO.db_2.7.1 GOstats_2.22.0 graph_1.34.0 [6] Category_2.22.0 ath1121501.db_2.7.1 org.At.tair.db_2.7.1 RSQLite_0.10.0 DBI_0.2-5 [11] AnnotationDbi_1.18.4 BiocInstaller_1.4.9 limma_3.12.3 affy_1.34.0 Biobase_2.16.0 [16] BiocGenerics_0.2.0 loaded via a namespace (and not attached): [1] affyio_1.22.0 annotate_1.34.1 genefilter_1.38.0 GSEABase_1.18.0 [5] IRanges_1.14.4 preprocessCore_1.18.0 RBGL_1.32.1 splines_2.15.2 [9] stats4_2.15.2 survival_2.36-14 tools_2.15.2 XML_3.9-4 [13] xtable_1.6-0 zlibbioc_1.2.0 -- Sent via the guest posting facility at bioconductor.org.
go ath1121501 • 430 views
ADD COMMENTlink written 7.1 years ago by Guest User12k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 168 users visited in the last hour