Question: EBcoexpress error - initializeHP() error
0
gravatar for Guest User
7.0 years ago by
Guest User12k
Guest User12k wrote:
hi all i'm using the EBcoexpress package to analyze a series of 29 Tumor vs 29 Normal cancer microarray data. following the directions in the pdf file i can create the first coexpression matrix with no errors, however, when i run the initializeHP() function (as decscribed in the package file) i get the following error: Error in mvnX(data = data, prior = prior): NA/NaN/Inf in foreign function call (arg 1) i removed all the zeroes (i had 8) in the input matrix but still i get the same error. -- output of sessionInfo(): R version 2.15.1 (2012-06-22) Platform: x86_64-pc-mingw32/x64 (64-bit) locale: [1] LC_COLLATE=English_United States.1252 LC_CTYPE=English_United States.1252 LC_MONETARY=English_United States.1252 LC_NUMERIC=C [5] LC_TIME=English_United States.1252 attached base packages: [1] splines stats graphics grDevices utils datasets methods base other attached packages: [1] DCGL_1.02 igraph_0.6-3 Hmisc_3.10-1 survival_2.36-14 EBcoexpress_1.0.0 minqa_1.2.1 Rcpp_0.10.1 mclust_4.0 EBarrays_2.20.0 [10] lattice_0.20-10 Biobase_2.16.0 BiocGenerics_0.2.0 BiocInstaller_1.4.9 loaded via a namespace (and not attached): [1] cluster_1.14.3 grid_2.15.1 tools_2.15.1 -- Sent via the guest posting facility at bioconductor.org.
microarray cancer ebcoexpress • 848 views
ADD COMMENTlink modified 7.0 years ago by Dan Tenenbaum8.2k • written 7.0 years ago by Guest User12k
Answer: EBcoexpress error - initializeHP() error
0
gravatar for Dan Tenenbaum
7.0 years ago by
Dan Tenenbaum8.2k
United States
Dan Tenenbaum8.2k wrote:
Hi Sebastiano, On Thu, Nov 29, 2012 at 2:34 PM, Sebastiano [guest] <guest at="" bioconductor.org=""> wrote: > > hi all > > i'm using the EBcoexpress package to analyze a series of 29 Tumor vs 29 Normal cancer microarray data. > > following the directions in the pdf file i can create the first coexpression matrix with no errors, however, when i run the initializeHP() function (as decscribed in the package file) i get the following error: > > Error in mvnX(data = data, prior = prior): > NA/NaN/Inf in foreign function call (arg 1) > > i removed all the zeroes (i had 8) in the input matrix but still i get the same error. > Can you attach or post your input data and send the code that produced the errror? > -- output of sessionInfo(): > > R version 2.15.1 (2012-06-22) > Platform: x86_64-pc-mingw32/x64 (64-bit) > > locale: > [1] LC_COLLATE=English_United States.1252 LC_CTYPE=English_United States.1252 LC_MONETARY=English_United States.1252 LC_NUMERIC=C > [5] LC_TIME=English_United States.1252 > > attached base packages: > [1] splines stats graphics grDevices utils datasets methods base > > other attached packages: > [1] DCGL_1.02 igraph_0.6-3 Hmisc_3.10-1 survival_2.36-14 EBcoexpress_1.0.0 minqa_1.2.1 Rcpp_0.10.1 mclust_4.0 EBarrays_2.20.0 > [10] lattice_0.20-10 Biobase_2.16.0 BiocGenerics_0.2.0 BiocInstaller_1.4.9 > Looks like you are still running BioC 2.10. You might want to upgrade to BioC 2.11 as described here: http://bioconductor.org/install/#bioc-version Dan > loaded via a namespace (and not attached): > [1] cluster_1.14.3 grid_2.15.1 tools_2.15.1 > > -- > Sent via the guest posting facility at bioconductor.org. > > _______________________________________________ > Bioconductor mailing list > Bioconductor at r-project.org > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor
ADD COMMENTlink written 7.0 years ago by Dan Tenenbaum8.2k
Answer: EBcoexpress error - initializeHP() error
0
gravatar for Dan Tenenbaum
7.0 years ago by
Dan Tenenbaum8.2k
United States
Dan Tenenbaum8.2k wrote:
On Thu, Nov 29, 2012 at 3:08 PM, Seb <seba.bat at="" gmail.com=""> wrote: > sure, the file is attached (it's 1.9mb 2796 rows per 58cols) > > the code that generated the error is: > > myHP <- initializeHP(D, cond) > > - D is the output matrix from > D <- makeMyD (myData, cond) > > - cond is the conditions file, containing the header for the samples in the > myData matrix > Thanks, but this still isn't complete. Can you send the code that reads your data file into R, and also the code that creates 'myData'. In other words, all the code starting from the beginning of the R session to the error you get. Thanks, Dan > thanks!! > > Seb > > > > > On Thu, Nov 29, 2012 at 5:58 PM, Dan Tenenbaum <dtenenba at="" fhcrc.org=""> wrote: >> >> Hi Sebastiano, >> >> >> On Thu, Nov 29, 2012 at 2:34 PM, Sebastiano [guest] >> <guest at="" bioconductor.org=""> wrote: >> > >> > hi all >> > >> > i'm using the EBcoexpress package to analyze a series of 29 Tumor vs 29 >> > Normal cancer microarray data. >> > >> > following the directions in the pdf file i can create the first >> > coexpression matrix with no errors, however, when i run the initializeHP() >> > function (as decscribed in the package file) i get the following error: >> > >> > Error in mvnX(data = data, prior = prior): >> > NA/NaN/Inf in foreign function call (arg 1) >> > >> > i removed all the zeroes (i had 8) in the input matrix but still i get >> > the same error. >> > >> >> Can you attach or post your input data and send the code that produced >> the errror? >> >> > -- output of sessionInfo(): >> > >> > R version 2.15.1 (2012-06-22) >> > Platform: x86_64-pc-mingw32/x64 (64-bit) >> > >> > locale: >> > [1] LC_COLLATE=English_United States.1252 LC_CTYPE=English_United >> > States.1252 LC_MONETARY=English_United States.1252 LC_NUMERIC=C >> > [5] LC_TIME=English_United States.1252 >> > >> > attached base packages: >> > [1] splines stats graphics grDevices utils datasets methods >> > base >> > >> > other attached packages: >> > [1] DCGL_1.02 igraph_0.6-3 Hmisc_3.10-1 >> > survival_2.36-14 EBcoexpress_1.0.0 minqa_1.2.1 Rcpp_0.10.1 >> > mclust_4.0 EBarrays_2.20.0 >> > [10] lattice_0.20-10 Biobase_2.16.0 BiocGenerics_0.2.0 >> > BiocInstaller_1.4.9 >> > >> >> Looks like you are still running BioC 2.10. You might want to upgrade >> to BioC 2.11 as described here: >> >> http://bioconductor.org/install/#bioc-version >> >> Dan >> >> >> > loaded via a namespace (and not attached): >> > [1] cluster_1.14.3 grid_2.15.1 tools_2.15.1 >> > >> > -- >> > Sent via the guest posting facility at bioconductor.org. >> > >> > _______________________________________________ >> > Bioconductor mailing list >> > Bioconductor at r-project.org >> > https://stat.ethz.ch/mailman/listinfo/bioconductor >> > Search the archives: >> > http://news.gmane.org/gmane.science.biology.informatics.conductor > >
ADD COMMENTlink written 7.0 years ago by Dan Tenenbaum8.2k
oh, of course, sorry! library(EBcoexpress) # read my data file into R (note: i used na.strings="n/a" cause a gene was named NA in an old dataset, but it's anyway NOT there anymore in the one imported) myData <- read.table("myFile.txt", header=T, row.names=1, na.strings="n/a") # create the conditions file cond <- c(rep(1, times=29), rep(2, times=29)) # create first correlation matrix, this works fine D <- makeMyD (myData, cond) # try to use initializeHP function myHP <- initializeHP(D, cond) --> here is where i get the error after a few sec that it's running <-- pls let me know if you need more info!...and thanks! Seb On Thu, Nov 29, 2012 at 6:17 PM, Dan Tenenbaum <dtenenba@fhcrc.org> wrote: > On Thu, Nov 29, 2012 at 3:08 PM, Seb <seba.bat@gmail.com> wrote: > > sure, the file is attached (it's 1.9mb 2796 rows per 58cols) > > > > the code that generated the error is: > > > > myHP <- initializeHP(D, cond) > > > > - D is the output matrix from > > D <- makeMyD (myData, cond) > > > > - cond is the conditions file, containing the header for the samples in > the > > myData matrix > > > > > Thanks, but this still isn't complete. Can you send the code that > reads your data file into R, and also the code that creates 'myData'. > In other words, all the code starting from the beginning of the R > session to the error you get. > > Thanks, > Dan > > > > thanks!! > > > > Seb > > > > > > > > > > On Thu, Nov 29, 2012 at 5:58 PM, Dan Tenenbaum <dtenenba@fhcrc.org> > wrote: > >> > >> Hi Sebastiano, > >> > >> > >> On Thu, Nov 29, 2012 at 2:34 PM, Sebastiano [guest] > >> <guest@bioconductor.org> wrote: > >> > > >> > hi all > >> > > >> > i'm using the EBcoexpress package to analyze a series of 29 Tumor vs > 29 > >> > Normal cancer microarray data. > >> > > >> > following the directions in the pdf file i can create the first > >> > coexpression matrix with no errors, however, when i run the > initializeHP() > >> > function (as decscribed in the package file) i get the following > error: > >> > > >> > Error in mvnX(data = data, prior = prior): > >> > NA/NaN/Inf in foreign function call (arg 1) > >> > > >> > i removed all the zeroes (i had 8) in the input matrix but still i get > >> > the same error. > >> > > >> > >> Can you attach or post your input data and send the code that produced > >> the errror? > >> > >> > -- output of sessionInfo(): > >> > > >> > R version 2.15.1 (2012-06-22) > >> > Platform: x86_64-pc-mingw32/x64 (64-bit) > >> > > >> > locale: > >> > [1] LC_COLLATE=English_United States.1252 LC_CTYPE=English_United > >> > States.1252 LC_MONETARY=English_United States.1252 LC_NUMERIC=C > >> > [5] LC_TIME=English_United States.1252 > >> > > >> > attached base packages: > >> > [1] splines stats graphics grDevices utils datasets > methods > >> > base > >> > > >> > other attached packages: > >> > [1] DCGL_1.02 igraph_0.6-3 Hmisc_3.10-1 > >> > survival_2.36-14 EBcoexpress_1.0.0 minqa_1.2.1 > Rcpp_0.10.1 > >> > mclust_4.0 EBarrays_2.20.0 > >> > [10] lattice_0.20-10 Biobase_2.16.0 BiocGenerics_0.2.0 > >> > BiocInstaller_1.4.9 > >> > > >> > >> Looks like you are still running BioC 2.10. You might want to upgrade > >> to BioC 2.11 as described here: > >> > >> http://bioconductor.org/install/#bioc-version > >> > >> Dan > >> > >> > >> > loaded via a namespace (and not attached): > >> > [1] cluster_1.14.3 grid_2.15.1 tools_2.15.1 > >> > > >> > -- > >> > Sent via the guest posting facility at bioconductor.org. > >> > > >> > _______________________________________________ > >> > Bioconductor mailing list > >> > Bioconductor@r-project.org > >> > https://stat.ethz.ch/mailman/listinfo/bioconductor > >> > Search the archives: > >> > http://news.gmane.org/gmane.science.biology.informatics.conductor > > > > > [[alternative HTML version deleted]]
ADD REPLYlink written 7.0 years ago by TriS200
On Thu, Nov 29, 2012 at 3:25 PM, Seb <seba.bat at="" gmail.com=""> wrote: > oh, of course, sorry! > > library(EBcoexpress) > > # read my data file into R (note: i used na.strings="n/a" cause a gene was > named NA in an old dataset, but it's anyway NOT there anymore in the one > imported) > myData <- read.table("myFile.txt", header=T, row.names=1, na.strings="n/a") > OK, first of all you are reading in myFile.txt but the file you sent is called Filter_MSKCC_PCa_mRNA.txt, hopefully we're talking about the same file? Also, na.strings means "missing values are represented in my file by this string". The string "n/a" does not occur in your text file. Was it "NA" or "n/a" that was in the file before? > # create the conditions file > cond <- c(rep(1, times=29), rep(2, times=29)) > > # create first correlation matrix, this works fine > D <- makeMyD (myData, cond) > > # try to use initializeHP function > myHP <- initializeHP(D, cond) > --> here is where i get the error after a few sec that it's running <-- > > pls let me know if you need more info!...and thanks! OK, I am getting the same error (on a Mac running BioC 2.11). I don't know what's going on, I'm guessing something bogus in the input data. Anyone else have a suggestion? Dan > > Seb > > > On Thu, Nov 29, 2012 at 6:17 PM, Dan Tenenbaum <dtenenba at="" fhcrc.org=""> wrote: >> >> On Thu, Nov 29, 2012 at 3:08 PM, Seb <seba.bat at="" gmail.com=""> wrote: >> > sure, the file is attached (it's 1.9mb 2796 rows per 58cols) >> > >> > the code that generated the error is: >> > >> > myHP <- initializeHP(D, cond) >> > >> > - D is the output matrix from >> > D <- makeMyD (myData, cond) >> > >> > - cond is the conditions file, containing the header for the samples in >> > the >> > myData matrix >> > >> >> >> Thanks, but this still isn't complete. Can you send the code that >> reads your data file into R, and also the code that creates 'myData'. >> In other words, all the code starting from the beginning of the R >> session to the error you get. >> >> Thanks, >> Dan >> >> >> > thanks!! >> > >> > Seb >> > >> > >> > >> > >> > On Thu, Nov 29, 2012 at 5:58 PM, Dan Tenenbaum <dtenenba at="" fhcrc.org=""> >> > wrote: >> >> >> >> Hi Sebastiano, >> >> >> >> >> >> On Thu, Nov 29, 2012 at 2:34 PM, Sebastiano [guest] >> >> <guest at="" bioconductor.org=""> wrote: >> >> > >> >> > hi all >> >> > >> >> > i'm using the EBcoexpress package to analyze a series of 29 Tumor vs >> >> > 29 >> >> > Normal cancer microarray data. >> >> > >> >> > following the directions in the pdf file i can create the first >> >> > coexpression matrix with no errors, however, when i run the >> >> > initializeHP() >> >> > function (as decscribed in the package file) i get the following >> >> > error: >> >> > >> >> > Error in mvnX(data = data, prior = prior): >> >> > NA/NaN/Inf in foreign function call (arg 1) >> >> > >> >> > i removed all the zeroes (i had 8) in the input matrix but still i >> >> > get >> >> > the same error. >> >> > >> >> >> >> Can you attach or post your input data and send the code that produced >> >> the errror? >> >> >> >> > -- output of sessionInfo(): >> >> > >> >> > R version 2.15.1 (2012-06-22) >> >> > Platform: x86_64-pc-mingw32/x64 (64-bit) >> >> > >> >> > locale: >> >> > [1] LC_COLLATE=English_United States.1252 LC_CTYPE=English_United >> >> > States.1252 LC_MONETARY=English_United States.1252 LC_NUMERIC=C >> >> > [5] LC_TIME=English_United States.1252 >> >> > >> >> > attached base packages: >> >> > [1] splines stats graphics grDevices utils datasets >> >> > methods >> >> > base >> >> > >> >> > other attached packages: >> >> > [1] DCGL_1.02 igraph_0.6-3 Hmisc_3.10-1 >> >> > survival_2.36-14 EBcoexpress_1.0.0 minqa_1.2.1 >> >> > Rcpp_0.10.1 >> >> > mclust_4.0 EBarrays_2.20.0 >> >> > [10] lattice_0.20-10 Biobase_2.16.0 BiocGenerics_0.2.0 >> >> > BiocInstaller_1.4.9 >> >> > >> >> >> >> Looks like you are still running BioC 2.10. You might want to upgrade >> >> to BioC 2.11 as described here: >> >> >> >> http://bioconductor.org/install/#bioc-version >> >> >> >> Dan >> >> >> >> >> >> > loaded via a namespace (and not attached): >> >> > [1] cluster_1.14.3 grid_2.15.1 tools_2.15.1 >> >> > >> >> > -- >> >> > Sent via the guest posting facility at bioconductor.org. >> >> > >> >> > _______________________________________________ >> >> > Bioconductor mailing list >> >> > Bioconductor at r-project.org >> >> > https://stat.ethz.ch/mailman/listinfo/bioconductor >> >> > Search the archives: >> >> > http://news.gmane.org/gmane.science.biology.informatics.conductor >> > >> > > >
ADD REPLYlink written 7.0 years ago by Dan Tenenbaum8.2k
Thanks for trying it out Dan! Yes, i used myFile.txt in the mail as it was quicker to write You are also correct that "n/a" does not occurred in my file. However, the initial data file was bigger with more genes, one of them was called NA and I couldn't read the file cause R warned me of an NA in the row.names... so to have R accept it I used the na.strings parameter. Thanks again and if anyone has any more suggestions it would be just great Seb -- sent from my DROID - - On Nov 29, 2012 6:42 PM, "Dan Tenenbaum" <dtenenba@fhcrc.org> wrote: > On Thu, Nov 29, 2012 at 3:25 PM, Seb <seba.bat@gmail.com> wrote: > > oh, of course, sorry! > > > > library(EBcoexpress) > > > > # read my data file into R (note: i used na.strings="n/a" cause a gene > was > > named NA in an old dataset, but it's anyway NOT there anymore in the one > > imported) > > myData <- read.table("myFile.txt", header=T, row.names=1, > na.strings="n/a") > > > > > OK, first of all you are reading in myFile.txt but the file you sent > is called Filter_MSKCC_PCa_mRNA.txt, hopefully we're talking about the > same file? > > > > Also, na.strings means "missing values are represented in my file by > this string". The string "n/a" does not occur in your text file. Was > it "NA" or "n/a" that was in the file before? > > > # create the conditions file > > cond <- c(rep(1, times=29), rep(2, times=29)) > > > > # create first correlation matrix, this works fine > > D <- makeMyD (myData, cond) > > > > # try to use initializeHP function > > myHP <- initializeHP(D, cond) > > --> here is where i get the error after a few sec that it's running <-- > > > > pls let me know if you need more info!...and thanks! > > > OK, I am getting the same error (on a Mac running BioC 2.11). > I don't know what's going on, I'm guessing something bogus in the input > data. > > Anyone else have a suggestion? > > Dan > > > > > > Seb > > > > > > On Thu, Nov 29, 2012 at 6:17 PM, Dan Tenenbaum <dtenenba@fhcrc.org> > wrote: > >> > >> On Thu, Nov 29, 2012 at 3:08 PM, Seb <seba.bat@gmail.com> wrote: > >> > sure, the file is attached (it's 1.9mb 2796 rows per 58cols) > >> > > >> > the code that generated the error is: > >> > > >> > myHP <- initializeHP(D, cond) > >> > > >> > - D is the output matrix from > >> > D <- makeMyD (myData, cond) > >> > > >> > - cond is the conditions file, containing the header for the samples > in > >> > the > >> > myData matrix > >> > > >> > >> > >> Thanks, but this still isn't complete. Can you send the code that > >> reads your data file into R, and also the code that creates 'myData'. > >> In other words, all the code starting from the beginning of the R > >> session to the error you get. > >> > >> Thanks, > >> Dan > >> > >> > >> > thanks!! > >> > > >> > Seb > >> > > >> > > >> > > >> > > >> > On Thu, Nov 29, 2012 at 5:58 PM, Dan Tenenbaum <dtenenba@fhcrc.org> > >> > wrote: > >> >> > >> >> Hi Sebastiano, > >> >> > >> >> > >> >> On Thu, Nov 29, 2012 at 2:34 PM, Sebastiano [guest] > >> >> <guest@bioconductor.org> wrote: > >> >> > > >> >> > hi all > >> >> > > >> >> > i'm using the EBcoexpress package to analyze a series of 29 Tumor > vs > >> >> > 29 > >> >> > Normal cancer microarray data. > >> >> > > >> >> > following the directions in the pdf file i can create the first > >> >> > coexpression matrix with no errors, however, when i run the > >> >> > initializeHP() > >> >> > function (as decscribed in the package file) i get the following > >> >> > error: > >> >> > > >> >> > Error in mvnX(data = data, prior = prior): > >> >> > NA/NaN/Inf in foreign function call (arg 1) > >> >> > > >> >> > i removed all the zeroes (i had 8) in the input matrix but still i > >> >> > get > >> >> > the same error. > >> >> > > >> >> > >> >> Can you attach or post your input data and send the code that > produced > >> >> the errror? > >> >> > >> >> > -- output of sessionInfo(): > >> >> > > >> >> > R version 2.15.1 (2012-06-22) > >> >> > Platform: x86_64-pc-mingw32/x64 (64-bit) > >> >> > > >> >> > locale: > >> >> > [1] LC_COLLATE=English_United States.1252 LC_CTYPE=English_United > >> >> > States.1252 LC_MONETARY=English_United States.1252 LC_NUMERIC=C > >> >> > [5] LC_TIME=English_United States.1252 > >> >> > > >> >> > attached base packages: > >> >> > [1] splines stats graphics grDevices utils datasets > >> >> > methods > >> >> > base > >> >> > > >> >> > other attached packages: > >> >> > [1] DCGL_1.02 igraph_0.6-3 Hmisc_3.10-1 > >> >> > survival_2.36-14 EBcoexpress_1.0.0 minqa_1.2.1 > >> >> > Rcpp_0.10.1 > >> >> > mclust_4.0 EBarrays_2.20.0 > >> >> > [10] lattice_0.20-10 Biobase_2.16.0 BiocGenerics_0.2.0 > >> >> > BiocInstaller_1.4.9 > >> >> > > >> >> > >> >> Looks like you are still running BioC 2.10. You might want to upgrade > >> >> to BioC 2.11 as described here: > >> >> > >> >> http://bioconductor.org/install/#bioc-version > >> >> > >> >> Dan > >> >> > >> >> > >> >> > loaded via a namespace (and not attached): > >> >> > [1] cluster_1.14.3 grid_2.15.1 tools_2.15.1 > >> >> > > >> >> > -- > >> >> > Sent via the guest posting facility at bioconductor.org. > >> >> > > >> >> > _______________________________________________ > >> >> > Bioconductor mailing list > >> >> > Bioconductor@r-project.org > >> >> > https://stat.ethz.ch/mailman/listinfo/bioconductor > >> >> > Search the archives: > >> >> > http://news.gmane.org/gmane.science.biology.informatics.conductor > >> > > >> > > > > > > [[alternative HTML version deleted]]
ADD REPLYlink written 7.0 years ago by TriS200
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 227 users visited in the last hour