Search
Question: Error in getGEO command with GSEMatrix=TRUE
0
gravatar for Marwaha, Shruti marwahsi
5.6 years ago by
Dear Developers, I am trying to get an ExpressionSet from a GSEfile using getGEO command with GSEMatrix=TRUE. It sometimes gives an error (Connection was reset) if I use GSEMatrix=TRUE however sometimes it works smooth. I have the latest version of R, Bioconductor and GEOquery. Please advise if I am missing some library or need to change some settings. Thanks in advance. My Code library(Biobase) library(GEOquery) library(limma) gset <- getGEO("GSE27347", GSEMatrix =TRUE) Error: Error in function (type, msg, asError = TRUE) : Send failure: Connection was reset Session Info > sessionInfo() R version 2.15.2 (2012-10-26) Platform: x86_64-w64-mingw32/x64 (64-bit) locale: [1] LC_COLLATE=English_India.1252 LC_CTYPE=English_India.1252 [3] LC_MONETARY=English_India.1252 LC_NUMERIC=C [5] LC_TIME=English_India.1252 attached base packages: [1] stats graphics grDevices utils datasets methods base other attached packages: [1] limma_3.14.4 GEOquery_2.24.1 Biobase_2.18.0 BiocGenerics_0.4.0 loaded via a namespace (and not attached): [1] RCurl_1.95-4.1 tools_2.15.2 XML_3.95-0.2 System Properties OS: Windows 7 RAM: 4GB Processor: 2GHz Methods already attempted * I have tried it on both RStudio and GUI * I have also tried using the command "setInternet2(use=FALSE)" but it doesn't help. * I have tried this command with other GSEfiles also and get the same error. * GEOquery works fine and downloads the GSEfiles if I give GSEMatrix=FALSE * I have also tried downloading the file and provide the file path of the file to getGEO with GSEMatrix=TRUE but it does not give an ExpressionSet as output. Thanks & Regards, Shruti Marwaha Graduate Student Systems Biology and Physiology University of Cincinnati Medical Science Building, 231 Albert Sabin Way Cincinnati, OH, USA 45267
ADD COMMENTlink modified 5.6 years ago by Sean Davis21k • written 5.6 years ago by Marwaha, Shruti marwahsi40
0
gravatar for Sean Davis
5.6 years ago by
Sean Davis21k
United States
Sean Davis21k wrote:
On Tue, Mar 12, 2013 at 9:55 PM, Marwaha, Shruti (marwahsi) < marwahsi@mail.uc.edu> wrote: > Dear Developers, > > I am trying to get an ExpressionSet from a GSEfile using getGEO command > with GSEMatrix=TRUE. It sometimes gives an error (Connection was reset) if > I use GSEMatrix=TRUE however sometimes it works smooth. I have the latest > version of R, Bioconductor and GEOquery. Please advise if I am missing some > library or need to change some settings. Thanks in advance. > > My Code > library(Biobase) > library(GEOquery) > library(limma) > gset <- getGEO("GSE27347", GSEMatrix =TRUE) > > Error: > Error in function (type, msg, asError = TRUE) : > Send failure: Connection was reset > > Hi, Marwaha. While I cannot be sure, I suspect that these are intermittent connection problems between you and NCBI. You could try wrapping your getGEO call in something like this to catch this condition : gse = NULL while(!inherits(gse,'list')) {gse=tryCatch( getGEO('GSE27347'), error=function(e) {Sys.sleep(5); message('retrying'); return(e)})} This will continuously retry the getGEO call every 5 seconds until the outcome is a list, which is what we expect getGEO to return in this case. Hopefully, this will make your code a bit more robust. Sean > Session Info > > > sessionInfo() > > R version 2.15.2 (2012-10-26) > > Platform: x86_64-w64-mingw32/x64 (64-bit) > > > > locale: > > [1] LC_COLLATE=English_India.1252 LC_CTYPE=English_India.1252 > > [3] LC_MONETARY=English_India.1252 LC_NUMERIC=C > > [5] LC_TIME=English_India.1252 > > > > attached base packages: > > [1] stats graphics grDevices utils datasets methods base > > > > other attached packages: > > [1] limma_3.14.4 GEOquery_2.24.1 Biobase_2.18.0 > BiocGenerics_0.4.0 > > > > loaded via a namespace (and not attached): > > [1] RCurl_1.95-4.1 tools_2.15.2 XML_3.95-0.2 > > System Properties > OS: Windows 7 > RAM: 4GB > Processor: 2GHz > > Methods already attempted > > * I have tried it on both RStudio and GUI > > * I have also tried using the command "setInternet2(use=FALSE)" > but it doesn't help. > > * I have tried this command with other GSEfiles also and get the > same error. > > * GEOquery works fine and downloads the GSEfiles if I give > GSEMatrix=FALSE > > * I have also tried downloading the file and provide the file path > of the file to getGEO with GSEMatrix=TRUE but it does not give an > ExpressionSet as output. > > Thanks & Regards, > Shruti Marwaha > > Graduate Student > Systems Biology and Physiology > University of Cincinnati > Medical Science Building, > 231 Albert Sabin Way > Cincinnati, OH, USA 45267 > > > > _______________________________________________ > Bioconductor mailing list > Bioconductor@r-project.org > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: > http://news.gmane.org/gmane.science.biology.informatics.conductor > [[alternative HTML version deleted]]
ADD COMMENTlink written 5.6 years ago by Sean Davis21k
Thanks Sean. My code is running smoothly today without any errors. However I shall use the code you have provided if get the error in future. Thanks for your help. Regards, Shruti Marwaha Graduate Student Systems Biology and Physiology University of Cincinnati Medical Science Building, 231 Albert Sabin Way Cincinnati, OH, USA 45267 From: seandavi@gmail.com [mailto:seandavi@gmail.com] On Behalf Of Sean Davis Sent: 13 March 2013 06:27 To: Marwaha, Shruti (marwahsi) Cc: bioconductor@r-project.org Subject: Re: [BioC] Error in getGEO command with GSEMatrix=TRUE On Tue, Mar 12, 2013 at 9:55 PM, Marwaha, Shruti (marwahsi) <marwahsi@mail.uc.edu<mailto:marwahsi@mail.uc.edu>> wrote: Dear Developers, I am trying to get an ExpressionSet from a GSEfile using getGEO command with GSEMatrix=TRUE. It sometimes gives an error (Connection was reset) if I use GSEMatrix=TRUE however sometimes it works smooth. I have the latest version of R, Bioconductor and GEOquery. Please advise if I am missing some library or need to change some settings. Thanks in advance. My Code library(Biobase) library(GEOquery) library(limma) gset <- getGEO("GSE27347", GSEMatrix =TRUE) Error: Error in function (type, msg, asError = TRUE) : Send failure: Connection was reset Hi, Marwaha. While I cannot be sure, I suspect that these are intermittent connection problems between you and NCBI. You could try wrapping your getGEO call in something like this to catch this condition : gse = NULL while(!inherits(gse,'list')) {gse=tryCatch( getGEO('GSE27347'), error=function(e) {Sys.sleep(5); message('retrying'); return(e)})} This will continuously retry the getGEO call every 5 seconds until the outcome is a list, which is what we expect getGEO to return in this case. Hopefully, this will make your code a bit more robust. Sean Session Info > sessionInfo() R version 2.15.2 (2012-10-26) Platform: x86_64-w64-mingw32/x64 (64-bit) locale: [1] LC_COLLATE=English_India.1252 LC_CTYPE=English_India.1252 [3] LC_MONETARY=English_India.1252 LC_NUMERIC=C [5] LC_TIME=English_India.1252 attached base packages: [1] stats graphics grDevices utils datasets methods base other attached packages: [1] limma_3.14.4 GEOquery_2.24.1 Biobase_2.18.0 BiocGenerics_0.4.0 loaded via a namespace (and not attached): [1] RCurl_1.95-4.1 tools_2.15.2 XML_3.95-0.2 System Properties OS: Windows 7 RAM: 4GB Processor: 2GHz Methods already attempted * I have tried it on both RStudio and GUI * I have also tried using the command "setInternet2(use=FALSE)" but it doesn't help. * I have tried this command with other GSEfiles also and get the same error. * GEOquery works fine and downloads the GSEfiles if I give GSEMatrix=FALSE * I have also tried downloading the file and provide the file path of the file to getGEO with GSEMatrix=TRUE but it does not give an ExpressionSet as output. Thanks & Regards, Shruti Marwaha Graduate Student Systems Biology and Physiology University of Cincinnati Medical Science Building, 231 Albert Sabin Way Cincinnati, OH, USA 45267 _______________________________________________ Bioconductor mailing list Bioconductor@r-project.org<mailto:bioconductor@r-project.org> https://stat.ethz.ch/mailman/listinfo/bioconductor Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor [[alternative HTML version deleted]]
ADD REPLYlink written 5.6 years ago by Marwaha, Shruti marwahsi40
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 455 users visited in the last hour