Question: Problems with SVGAnnotation package
0
gravatar for Kevin Ushey
6.4 years ago by
Kevin Ushey10
United States
Kevin Ushey10 wrote:
Hi, I'm having trouble using the SVGAnnotation package with R 3.0.0. In particular, I'm unable to run any of the examples available at http://www.omegahat.org/SVGAnnotation/tests/examples.html ; these all worked AFAIK with R prior to 3.0.0. Here's some example output from trying to run the first example on the page: > ?SVGAnnotation > svg("pairs_link.svg", 14, 10) > pairs(mtcars[,1:3], cex = 2) > dev.off() RStudioGD 2 > > doc = xmlParse("pairs_link.svg") > linkPlots(doc) Error in tmp[i] : invalid subscript type 'list' > saveXML(doc, "pairs_link.svg") [1] "pairs_link.svg" Note the error occuring with 'linkPlots(doc)'. Tracebacks suggest the error occurs in 'getPlotRegionNodes'; however, I am not familiar enough with the package to debug further. > sessionInfo() R version 3.0.0 (2013-04-03) Platform: x86_64-apple-darwin10.8.0 (64-bit) locale: [1] en_CA.UTF-8/en_CA.UTF-8/en_CA.UTF-8/C/en_CA.UTF-8/en_CA.UTF-8 attached base packages: [1] stats graphics grDevices utils datasets methods base other attached packages: [1] SVGAnnotation_0.93-1 XML_3.95-0.2 loaded via a namespace (and not attached): [1] tools_3.0.0 Any insight would be helpful. Thanks, -Kevin [[alternative HTML version deleted]]
• 743 views
ADD COMMENTlink modified 6.4 years ago by Dan Tenenbaum8.2k • written 6.4 years ago by Kevin Ushey10
Answer: Problems with SVGAnnotation package
0
gravatar for Dan Tenenbaum
6.4 years ago by
Dan Tenenbaum8.2k
United States
Dan Tenenbaum8.2k wrote:
Hi Kevin, On Mon, Apr 29, 2013 at 2:10 PM, Kevin Ushey <kevinushey at="" gmail.com=""> wrote: > Hi, > > I'm having trouble using the SVGAnnotation package with R 3.0.0. In > particular, I'm unable to run any of the examples available at > http://www.omegahat.org/SVGAnnotation/tests/examples.html ; these all > worked AFAIK with R prior to 3.0.0. Here's some example output from trying > to run the first example on the page: > >> ?SVGAnnotation >> svg("pairs_link.svg", 14, 10) >> pairs(mtcars[,1:3], cex = 2) >> dev.off() > RStudioGD > 2 >> >> doc = xmlParse("pairs_link.svg") >> linkPlots(doc) > Error in tmp[i] : invalid subscript type 'list' >> saveXML(doc, "pairs_link.svg") > [1] "pairs_link.svg" > > Note the error occuring with 'linkPlots(doc)'. Tracebacks suggest the error > occurs in 'getPlotRegionNodes'; however, I am not familiar enough with the > package to debug further. > >> sessionInfo() > R version 3.0.0 (2013-04-03) > Platform: x86_64-apple-darwin10.8.0 (64-bit) > > locale: > [1] en_CA.UTF-8/en_CA.UTF-8/en_CA.UTF-8/C/en_CA.UTF-8/en_CA.UTF-8 > > attached base packages: > [1] stats graphics grDevices utils datasets methods base > > other attached packages: > [1] SVGAnnotation_0.93-1 XML_3.95-0.2 > > loaded via a namespace (and not attached): > [1] tools_3.0.0 > > Any insight would be helpful. > I recommend contacting packageDescription("SVGAnnotation")$Maintainer as this is not a Bioconductor package (it's not a CRAN package either). Dan > Thanks, > -Kevin > > [[alternative HTML version deleted]] > > _______________________________________________ > Bioconductor mailing list > Bioconductor at r-project.org > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor
ADD COMMENTlink written 6.4 years ago by Dan Tenenbaum8.2k
On 04/29/2013 06:58 PM, Dan Tenenbaum wrote: > Hi Kevin, > > > > On Mon, Apr 29, 2013 at 2:10 PM, Kevin Ushey <kevinushey at="" gmail.com=""> wrote: >> Hi, >> >> I'm having trouble using the SVGAnnotation package with R 3.0.0. In >> particular, I'm unable to run any of the examples available at >> http://www.omegahat.org/SVGAnnotation/tests/examples.html ; these all >> worked AFAIK with R prior to 3.0.0. Here's some example output from trying >> to run the first example on the page: >> >>> ?SVGAnnotation >>> svg("pairs_link.svg", 14, 10) >>> pairs(mtcars[,1:3], cex = 2) >>> dev.off() >> RStudioGD >> 2 >>> >>> doc = xmlParse("pairs_link.svg") >>> linkPlots(doc) >> Error in tmp[i] : invalid subscript type 'list' >>> saveXML(doc, "pairs_link.svg") >> [1] "pairs_link.svg" >> >> Note the error occuring with 'linkPlots(doc)'. Tracebacks suggest the error >> occurs in 'getPlotRegionNodes'; however, I am not familiar enough with the >> package to debug further. >> >>> sessionInfo() >> R version 3.0.0 (2013-04-03) >> Platform: x86_64-apple-darwin10.8.0 (64-bit) >> >> locale: >> [1] en_CA.UTF-8/en_CA.UTF-8/en_CA.UTF-8/C/en_CA.UTF-8/en_CA.UTF-8 >> >> attached base packages: >> [1] stats graphics grDevices utils datasets methods base >> >> other attached packages: >> [1] SVGAnnotation_0.93-1 XML_3.95-0.2 The example above 'worked for me' with XML 3.96-1.1, which is available in source but binary from CRAN; it could be that biocLite("XML", type="source") does the trick (or perhaps causes more headaches...; probably it requires a 'devel' version of libxml installed, and I don't know how that works on Mac...) Martin >> >> loaded via a namespace (and not attached): >> [1] tools_3.0.0 >> >> Any insight would be helpful. >> > > I recommend contacting > packageDescription("SVGAnnotation")$Maintainer > as this is not a Bioconductor package (it's not a CRAN package either). > Dan > > >> Thanks, >> -Kevin >> >> [[alternative HTML version deleted]] >> >> _______________________________________________ >> Bioconductor mailing list >> Bioconductor at r-project.org >> https://stat.ethz.ch/mailman/listinfo/bioconductor >> Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor > > _______________________________________________ > Bioconductor mailing list > Bioconductor at r-project.org > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor > -- Computational Biology / Fred Hutchinson Cancer Research Center 1100 Fairview Ave. N. PO Box 19024 Seattle, WA 98109 Location: Arnold Building M1 B861 Phone: (206) 667-2793
ADD REPLYlink written 6.4 years ago by Martin Morgan ♦♦ 23k
On Mon, Apr 29, 2013 at 7:40 PM, Martin Morgan <mtmorgan at="" fhcrc.org=""> wrote: > On 04/29/2013 06:58 PM, Dan Tenenbaum wrote: >> >> Hi Kevin, >> >> >> >> On Mon, Apr 29, 2013 at 2:10 PM, Kevin Ushey <kevinushey at="" gmail.com=""> wrote: >>> >>> Hi, >>> >>> I'm having trouble using the SVGAnnotation package with R 3.0.0. In >>> particular, I'm unable to run any of the examples available at >>> http://www.omegahat.org/SVGAnnotation/tests/examples.html ; these all >>> worked AFAIK with R prior to 3.0.0. Here's some example output from >>> trying >>> to run the first example on the page: >>> >>>> ?SVGAnnotation >>>> svg("pairs_link.svg", 14, 10) >>>> pairs(mtcars[,1:3], cex = 2) >>>> dev.off() >>> >>> RStudioGD >>> 2 >>>> >>>> >>>> doc = xmlParse("pairs_link.svg") >>>> linkPlots(doc) >>> >>> Error in tmp[i] : invalid subscript type 'list' >>>> >>>> saveXML(doc, "pairs_link.svg") >>> >>> [1] "pairs_link.svg" >>> >>> Note the error occuring with 'linkPlots(doc)'. Tracebacks suggest the >>> error >>> occurs in 'getPlotRegionNodes'; however, I am not familiar enough with >>> the >>> package to debug further. >>> >>>> sessionInfo() >>> >>> R version 3.0.0 (2013-04-03) >>> Platform: x86_64-apple-darwin10.8.0 (64-bit) >>> >>> locale: >>> [1] en_CA.UTF-8/en_CA.UTF-8/en_CA.UTF-8/C/en_CA.UTF-8/en_CA.UTF-8 >>> >>> attached base packages: >>> [1] stats graphics grDevices utils datasets methods base >>> >>> other attached packages: >>> [1] SVGAnnotation_0.93-1 XML_3.95-0.2 > > > The example above 'worked for me' with XML 3.96-1.1, which is available in > source but binary from CRAN; it could be that > > biocLite("XML", type="source") > > does the trick (or perhaps causes more headaches...; probably it requires a > 'devel' version of libxml installed, and I don't know how that works on > Mac...) > I have no trouble installing xml 3.96-1.1 from source on a Mountain Lion system, but I have the same error as Kevin, unfortunately. Dan > Martin > > >>> >>> loaded via a namespace (and not attached): >>> [1] tools_3.0.0 >>> >>> Any insight would be helpful. >>> >> >> I recommend contacting >> packageDescription("SVGAnnotation")$Maintainer >> as this is not a Bioconductor package (it's not a CRAN package either). >> Dan >> >> >>> Thanks, >>> -Kevin >>> >>> [[alternative HTML version deleted]] >>> >>> _______________________________________________ >>> Bioconductor mailing list >>> Bioconductor at r-project.org >>> https://stat.ethz.ch/mailman/listinfo/bioconductor >>> Search the archives: >>> http://news.gmane.org/gmane.science.biology.informatics.conductor >> >> >> _______________________________________________ >> Bioconductor mailing list >> Bioconductor at r-project.org >> https://stat.ethz.ch/mailman/listinfo/bioconductor >> Search the archives: >> http://news.gmane.org/gmane.science.biology.informatics.conductor >> > > > -- > Computational Biology / Fred Hutchinson Cancer Research Center > 1100 Fairview Ave. N. > PO Box 19024 Seattle, WA 98109 > > Location: Arnold Building M1 B861 > Phone: (206) 667-2793
ADD REPLYlink written 6.4 years ago by Dan Tenenbaum8.2k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 141 users visited in the last hour