Unable to load xps...
1
0
Entering edit mode
Bas Jansen ▴ 150
@bas-jansen-2966
Last seen 8.2 years ago
Hi, In order to analyze some Mouse Gene ST arrays, I would like to use xps. I have installed ROOT as well, but every time I try to start xps in the Terminal, I get an error message (see below). Embedded in the message is a phrase 'Symbol not found', and I have no idea how to solve this. I've googled around, but I did not find any reference to my particular problem. I'm on a Mac, Snow Leopard (OS X 10.6.8). Here's what I get, as well as the output from sessionInfo() > library(xps) Error in dyn.load(file, DLLpath = DLLpath, ...) : unable to load shared object '/Library/Frameworks/R.framework/Versions/3.0/Resources/library/xps/li bs/xps.so': dlopen(/Library/Frameworks/R.framework/Versions/3.0/Resources/library/ xps/libs/xps.so, 6): Symbol not found: __ZN10TCanvasImp11ShowMembersER16TMemberInspectorPc Referenced from: /Library/Frameworks/R.framework/Versions/3.0/Resources/library/xps/lib s/xps.so Expected in: /usr/local/root/lib/libCore.so in /Library/Frameworks/R.framework/Versions/3.0/Resources/library/xps/lib s/xps.so Error: package or namespace load failed for ‘xps’ > sessionInfo() R version 3.0.2 (2013-09-25) Platform: x86_64-apple-darwin10.8.0 (64-bit) locale: [1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8 attached base packages: [1] parallel stats graphics grDevices utils datasets methods [8] base other attached packages: [1] Biobase_2.22.0 BiocGenerics_0.8.0 loaded via a namespace (and not attached): [1] tools_3.0.2 Many thanks in advance for any pointers. Kind regards, Bas [[alternative HTML version deleted]]
xps xps • 1.3k views
ADD COMMENT
0
Entering edit mode
cstrato ★ 3.9k
@cstrato-908
Last seen 4.2 years ago
Austria
Dear Bas, Which version of ROOT did you install, especially, which file did you download? The README file says that you should install root_v5.34.05, e.g. from: ftp://root.cern.ch/root/root_v5.34.05.macosx106-x86_64-gcc-4.2.tar.gz However, I just realized that on the Bioconductor production machine perceval, which is used to build the xps binary, an old version of root is installed, which did escape my attention, see: http://bioconductor.org/checkResults/release/bioc-LATEST/xps/perceval- buildbin.html So maybe you need to install the old version root_v5.26.00c from: ftp://root.cern.ch/root/root_v5.26.00c.macosx106-x86_64-gcc-4.2.tar.gz Alternatively you could download the xps source and build the binary yourself. However, this would require that you have Xcode installed on your Mac. Please let me know if this info could solve your problem. I apologize for the inconvenience, and I will ask the Bioconductor maintainers if it would be possible to install root_v5.34.05 although it is the production machine. Best regards, Christian _._._._._._._._._._._._._._._._._._ C.h.r.i.s.t.i.a.n S.t.r.a.t.o.w.a V.i.e.n.n.a A.u.s.t.r.i.a e.m.a.i.l: cstrato at aon.at _._._._._._._._._._._._._._._._._._ On 10/31/13 1:45 PM, Bas Jansen wrote: > Hi, > > In order to analyze some Mouse Gene ST arrays, I would like to use xps. I > have installed ROOT as well, but every time I try to start xps in the > Terminal, I get an error message (see below). Embedded in the message is a > phrase 'Symbol not found', and I have no idea how to solve this. I've > googled around, but I did not find any reference to my particular problem. > I'm on a Mac, Snow Leopard (OS X 10.6.8). Here's what I get, as well as the > output from sessionInfo() > >> library(xps) > Error in dyn.load(file, DLLpath = DLLpath, ...) : > unable to load shared object > '/Library/Frameworks/R.framework/Versions/3.0/Resources/library/xps/ libs/xps.so': > > dlopen(/Library/Frameworks/R.framework/Versions/3.0/Resources/librar y/xps/libs/xps.so, > 6): Symbol not found: __ZN10TCanvasImp11ShowMembersER16TMemberInspectorPc > Referenced from: > /Library/Frameworks/R.framework/Versions/3.0/Resources/library/xps/l ibs/xps.so > Expected in: /usr/local/root/lib/libCore.so > in > /Library/Frameworks/R.framework/Versions/3.0/Resources/library/xps/l ibs/xps.so > Error: package or namespace load failed for ?xps? > >> sessionInfo() > R version 3.0.2 (2013-09-25) > Platform: x86_64-apple-darwin10.8.0 (64-bit) > > locale: > [1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8 > > attached base packages: > [1] parallel stats graphics grDevices utils datasets methods > [8] base > > other attached packages: > [1] Biobase_2.22.0 BiocGenerics_0.8.0 > > loaded via a namespace (and not attached): > [1] tools_3.0.2 > > Many thanks in advance for any pointers. > > Kind regards, > Bas > > [[alternative HTML version deleted]] > > > > _______________________________________________ > Bioconductor mailing list > Bioconductor at r-project.org > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor >
ADD COMMENT
0
Entering edit mode
Hi Christian, I have installed ROOT version 5.34.10. I also built the xps binary myself from source, at no avail. I will give ROOT v5.34.05 a try. I'll get back at you as soon as I have more, and thanks for your help. Kind regards, Bas On Thu, Oct 31, 2013 at 3:21 PM, cstrato <cstrato@aon.at> wrote: > Dear Bas, > > Which version of ROOT did you install, especially, which file did you > download? > > The README file says that you should install root_v5.34.05, e.g. from: > ftp://root.cern.ch/root/root_**v5.34.05.macosx106-x86_64-gcc-**4.2.t ar.gz<ftp: root.cern.ch="" root="" root_v5.34.05.macosx106-x86_64-gcc-4.2.t="" ar.gz=""> > > However, I just realized that on the Bioconductor production machine > perceval, which is used to build the xps binary, an old version of root is > installed, which did escape my attention, see: > http://bioconductor.org/**checkResults/release/bioc-** > LATEST/xps/perceval- buildbin.**html<http: bioconductor.org="" checkresults="" release="" bioc-="" latest="" xps="" perceval-buildbin.html=""> > So maybe you need to install the old version root_v5.26.00c from: > ftp://root.cern.ch/root/root_**v5.26.00c.macosx106-x86_64-**gcc-4.2. tar.gz<ftp: root.cern.ch="" root="" root_v5.26.00c.macosx106-x86_64-gcc-4.2="" .tar.gz=""> > > Alternatively you could download the xps source and build the binary > yourself. However, this would require that you have Xcode installed on your > Mac. > > Please let me know if this info could solve your problem. > > I apologize for the inconvenience, and I will ask the Bioconductor > maintainers if it would be possible to install root_v5.34.05 although it is > the production machine. > > Best regards, > Christian > _._._._._._._._._._._._._._._.**_._._ > C.h.r.i.s.t.i.a.n S.t.r.a.t.o.w.a > V.i.e.n.n.a A.u.s.t.r.i.a > e.m.a.i.l: cstrato at aon.at > _._._._._._._._._._._._._._._.**_._._ > > > > > On 10/31/13 1:45 PM, Bas Jansen wrote: > >> Hi, >> >> In order to analyze some Mouse Gene ST arrays, I would like to use xps. I >> have installed ROOT as well, but every time I try to start xps in the >> Terminal, I get an error message (see below). Embedded in the message is a >> phrase 'Symbol not found', and I have no idea how to solve this. I've >> googled around, but I did not find any reference to my particular problem. >> I'm on a Mac, Snow Leopard (OS X 10.6.8). Here's what I get, as well as >> the >> output from sessionInfo() >> >> library(xps) >>> >> Error in dyn.load(file, DLLpath = DLLpath, ...) : >> unable to load shared object >> '/Library/Frameworks/R.**framework/Versions/3.0/** >> Resources/library/xps/libs/**xps.so': >> >> dlopen(/Library/Frameworks/R.**framework/Versions/3.0/** >> Resources/library/xps/libs/**xps.so, >> 6): Symbol not found: __**ZN10TCanvasImp11ShowMembersER1** >> 6TMemberInspectorPc >> Referenced from: >> /Library/Frameworks/R.**framework/Versions/3.0/** >> Resources/library/xps/libs/**xps.so >> Expected in: /usr/local/root/lib/libCore.so >> in >> /Library/Frameworks/R.**framework/Versions/3.0/** >> Resources/library/xps/libs/**xps.so >> Error: package or namespace load failed for ‘xps’ >> >> sessionInfo() >>> >> R version 3.0.2 (2013-09-25) >> Platform: x86_64-apple-darwin10.8.0 (64-bit) >> >> locale: >> [1] en_US.UTF-8/en_US.UTF-8/en_US.**UTF-8/C/en_US.UTF-8/en_US.UTF-**8 >> >> attached base packages: >> [1] parallel stats graphics grDevices utils datasets methods >> [8] base >> >> other attached packages: >> [1] Biobase_2.22.0 BiocGenerics_0.8.0 >> >> loaded via a namespace (and not attached): >> [1] tools_3.0.2 >> >> Many thanks in advance for any pointers. >> >> Kind regards, >> Bas >> >> [[alternative HTML version deleted]] >> >> >> >> ______________________________**_________________ >> Bioconductor mailing list >> Bioconductor@r-project.org >> https://stat.ethz.ch/mailman/**listinfo/bioconductor<https: stat.e="" thz.ch="" mailman="" listinfo="" bioconductor=""> >> Search the archives: http://news.gmane.org/gmane.** >> science.biology.informatics.**conductor<http: news.gmane.org="" gmane="" .science.biology.informatics.conductor=""> >> >> [[alternative HTML version deleted]]
ADD REPLY

Login before adding your answer.

Traffic: 698 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6