Question: devel version: rtracklayer depends on GenomicRanges 1.19.3 but that's not available
0
gravatar for Janet Young
5.1 years ago by
Janet Young740
Fred Hutchinson Cancer Research Center, Seattle, WA, USA
Janet Young740 wrote:

Hi there,

I'm guessing you folks know this already, and have probably already fixed it for the overnight builds, but thought I'd bring it up just in case.  

I've re-installed R from scratch today (new linux version on the servers here).  I'm now having trouble installing packages in the devel version: rtracklayer won't install because it depends on GenomicRanges version 1.19.3 but only 1.19.2 is currently available (looks like the build failed for 1.19.3).  This also means I can't install any of the BSgenome packages as they're dependent on rtracklayer.

thanks,

Janet

ADD COMMENTlink modified 5.1 years ago by Marc Carlson7.2k • written 5.1 years ago by Janet Young740

I had the same issue earlier today and checked out GenomicRanges 1.19.3 directly from svn and installed it.

ADD REPLYlink written 5.1 years ago by Laurent Gatto1.2k

Thanks, Laurent - that worked. 

ADD REPLYlink written 5.1 years ago by Janet Young740
Answer: devel version: rtracklayer depends on GenomicRanges 1.19.3 but that's not availa
1
gravatar for Marc Carlson
5.1 years ago by
Marc Carlson7.2k
United States
Marc Carlson7.2k wrote:

Hi Janet,

I just checked in some revisions for GenomicRanges that should resolve this issue.  It was caused because the interface for AnnotationHub in devel is quite different from before.  So some of the vignette chunks in GenomicRanges needed to be updated.

 

 Marc

ADD COMMENTlink written 5.1 years ago by Marc Carlson7.2k

thanks, Marc - looks good this morning

ADD REPLYlink written 5.0 years ago by Janet Young740
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 194 users visited in the last hour