Error with featureCounts
1
0
Entering edit mode
syrttgump ▴ 20
@syrttgump-7367
Last seen 17 months ago
United States

Hi,

I am using featureCounts to count reads for every gene from refSeq annotation file. But it went to error:

featureCounts -a ../refGeneReviewed.gtf -t exon -g gene_id -p -Q 10 -o ../../result/fc_accepted_hits.txt accepted_hits.bam

        ==========     _____ _    _ ____  _____  ______          _____  
        =====         / ____| |  | |  _ \|  __ \|  ____|   /\   |  __ \
          =====      | (___ | |  | | |_) | |__) | |__     /  \  | |  | |
            ====      \___ \| |  | |  _ <|  _  /|  __|   / /\ \ | |  | |
              ====    ____) | |__| | |_) | | \ \| |____ / ____ \| |__| |
        ==========   |_____/ \____/|____/|_|  \_\______/_/    \_\_____/
      v1.4.6

//========================== featureCounts setting ===========================\\
||                                                                            ||
||             Input files : 1 BAM file                                       ||
||                           P accepted_hits.bam                              ||
||                                                                            ||
||             Output file : ../../result/fc_accepted_hits.txt                ||
||             Annotations : ../refGeneReviewed.gtf (GTF)                     ||
||                                                                            ||
||                 Threads : 1                                                ||
||                   Level : meta-feature level                               ||
||              Paired-end : yes                                              ||
||         Strand specific : no                                               ||
||      Multimapping reads : not counted                                      ||
|| Multi-overlapping reads : not counted                                      ||
||                                                                            ||
||          Chimeric reads : counted                                          ||
||        Both ends mapped : not required                                     ||
||                                                                            ||
\\===================== http://subread.sourceforge.net/ ======================//

//================================= Running ==================================\\
||                                                                            ||
|| Load annotation file ../refGeneReviewed.gtf ...                            ||
||    Features : 304046                                                       ||
||    Meta-features : 24154                                                   ||
||    Chromosomes : 35                                                        ||
||                                                                            ||
|| Process BAM file accepted_hits.bam...                                      ||
||    Paired-end reads are included.                                          ||
||    Assign fragments (read pairs) to features...                            ||
||    Found reads that are not properly paired.                               ||
||    (missing mate or the mate is not the next read)                         ||
Cannot load read part from the tmp file!
featureCounts: input-files.c:2216: sort_SAM_finalise: Assertion `0' failed.
Aborted

 

This bam and gtf file should be right, because I have used them to run HTSeq-count

featurecounts rnaseq rsubread • 3.2k views
ADD COMMENT
0
Entering edit mode

Hi,

I found similar error:

featureCounts: input-files.c:4675: SAM_pairer_run: Assertion `0 == corrected_run' failed.

And tried the -p and -P option, but still run into this error. Can you suggestion why and what could be the solution?

ADD REPLY
0
Entering edit mode

Also having the same problem, and not able to fix it with -p -P ...

ADD REPLY
3
Entering edit mode
Yang Liao ▴ 280
@yang-liao-6075
Last seen 9 days ago
Australia

It looks that the current directory has no enough space, or some reads in the SAM file are extremely long (e.g., longer than 1200 bps). 

ADD COMMENT
0
Entering edit mode

That is the problem, I used the parameter -p -P, and it works now. Thanks.

ADD REPLY
0
Entering edit mode

I can confirm that changing the tmpDir option to featureCounts to a drive where I have storage solved the issue for me, no longer terminating the with the error:

 

||    Assign reads to features...                                             ||
ERROR: cannot write into the temporary file. Please check the empty space in the output directory.
||                                                                            ||

 

 

ADD REPLY

Login before adding your answer.

Traffic: 345 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6