Ringo Plots Only Partially Made
1
0
Entering edit mode
bruce.moran ▴ 30
@brucemoran-8388
Last seen 17 months ago
Ireland

Hi,

I have been following the standard guides for Starr and Ringo for analysis of my Affy tiling array data. It works well, and I get enriched regions and so forth. I would like to make plots from 'cher' (code chunk number 25: plotCher form Ringo link).

I run:

plot(chers[[1]], expst_ratio_smooth, probeAnno=probeAnno, gff=transcriptAnno, paletteName="Spectral")
Error in if (x == -1) return("-") : missing value where TRUE/FALSE needed

Traceback of which is:

8: FUN(X[[i]], ...)
7: lapply(X = X, FUN = FUN, ...)
6: sapply(gff$strand, translateStrand)
5: plotFeatures(gff = gff, chr = chrom, xlim = xlim, strand = strand,
       featureExclude = featureExclude, featureColorScheme = 1,
       vpr = which(names(VP) == sprintf("gff%s", strand)), ...)
4: chipAlongChrom(y, chrom = x@chromosome, samples = samples, xlim = c(x@start -
       extent, x@end + extent), probeAnno = probeAnno, gff = gff,
       ...)
3: .local(x, y, ...)
2: plot(chers[[1]], expst_ratio_smooth, probeAnno = probeAnno, gff = transcriptAnno,
       paletteName = "Spectral")
1: plot(chers[[1]], expst_ratio_smooth, probeAnno = probeAnno, gff = transcriptAnno,
       paletteName = "Spectral")

The plots are partially made, with y-axis and points/lines for some data but not others. No x-axis (chromosome, position) is plotted. I use annotation from an Ensembl GFF that does not have feature names (all are 'regulatory region' for types), but I presume this is not an issue. Otherwise analysis uses 'stock' input (CEL, bpmap).

Help much appreciated,

Thanks,

Bruce.

 

R version 3.2.0 (2015-04-16)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 14.04.2 LTS

locale:
 [1] LC_CTYPE=en_IE.UTF-8       LC_NUMERIC=C
 [3] LC_TIME=en_IE.UTF-8        LC_COLLATE=en_IE.UTF-8
 [5] LC_MONETARY=en_IE.UTF-8    LC_MESSAGES=en_IE.UTF-8
 [7] LC_PAPER=en_IE.UTF-8       LC_NAME=C
 [9] LC_ADDRESS=C               LC_TELEPHONE=C
[11] LC_MEASUREMENT=en_IE.UTF-8 LC_IDENTIFICATION=C

attached base packages:
[1] grid      parallel  stats     graphics  grDevices utils     datasets
[8] methods   base

other attached packages:
 [1] Starr_1.24.0        affxparser_1.40.0   affy_1.46.1
 [4] Ringo_1.32.0        lattice_0.20-31     Matrix_1.2-2
 [7] limma_3.24.13       RColorBrewer_1.1-2  Biobase_2.28.0
[10] BiocGenerics_0.14.0

loaded via a namespace (and not attached):
 [1] AnnotationDbi_1.30.1  MASS_7.3-42           splines_3.2.0
 [4] zlibbioc_1.14.0       IRanges_2.2.5         pspline_1.0-17
 [7] xtable_1.7-4          GenomeInfoDb_1.4.1    tools_3.2.0
[10] DBI_0.3.1             genefilter_1.50.0     survival_2.38-3
[13] preprocessCore_1.30.0 affyio_1.36.0         S4Vectors_0.6.1
[16] RSQLite_1.0.0         BiocInstaller_1.18.3  stats4_3.2.0
[19] XML_3.98-1.3          annotate_1.46.1       vsn_3.36.0

 

Ringo affy tilingarray plot starr • 795 views
ADD COMMENT
0
Entering edit mode
bruce.moran ▴ 30
@brucemoran-8388
Last seen 17 months ago
Ireland

Sorry, just caught the issue, transcriptAnno had no strand info so changing all to "+" removes the error.

Apologies.

Also this is why to use traceback() =D

Bruce.

ADD COMMENT

Login before adding your answer.

Traffic: 338 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6