Search
Question: read.FCS error on FCS import
0
gravatar for Kipper Fletez-Brant
2.1 years ago by
United States
Kipper Fletez-Brant140 wrote:

I am trying to use flowCore's read.FCS() to import data into an R session.  When I do this, I get the following error:

 

library(flowCore)

fs <- list.files(path="~/data_temp", pattern="fcs", full.names=TRUE)

!> read.FCS(fs[[1]])

 Error in .readFCSdataRaw(con, dattype, count = as.integer(offsets["dataend"] -  :
   object 'splitInt' not found

 

However, when I try do the following, I do not get this error:

> library(flowClean)
 > data(synPerturbed)
 > write.FCS("~/Desktop/temp.fcs")

 [1] "~/Desktop/temp.fcs"
 Warning message:
 In write.FCS(synPerturbed, "~/Desktop/temp.fcs") :
   'write.FCS' is not fully tested and should be considered as experimental.
!> read.FCS("~/Desktop/temp.fcs")
 flowFrame object '9301d9e4-a160-477f-a5fb-ee7d785d5655'
 with 76466 cells and 17 observables:
          name          desc  range   minRange maxRange
 $P1     FSC-A          <NA> 262144    0.00000   262144
 $P2     FSC-H          <NA> 262144    0.00000   262144
 $P3     SSC-A          <NA> 261589    0.00000   261589
 $P4      Time          <NA>   2048    0.00000     2048
 $P5  <B515-A>     CD27 FITC 260954  -26.88460   260954
 $P6  <V705-A>    CD57 QD705 261947 -111.00000   261947
 $P7  <G560-A>       CD95 PE 261196 -111.00000   261196
 $P8  <G660-A>   CD28 Cy5 PE 261507 -111.00000   261507
 $P9  <G710-A> CD244 Cy55 PE 261763 -111.00000   261763
 $P10 <G780-A>   CD31 Cy7 PE 261402 -111.00000   261402
 $P11 <R710-A>    CCR7 Ax680 261602 -111.00000   261602
 $P12 <R780-A>    CD3 H7 APC 261301 -111.00000   261301
 $P13 <V450-A>   CD127 BV421 260964  -35.98385   260964
 $P14 <V545-A>        Aq Blu 260949  -22.20724   260949
 $P15 <V585-A>     CD8 QD585 261965 -111.00000   261965
 $P16 <R660-A>    CD45RA APC 261023  -96.50925   261023
 $P17 <V605-A>     CD4 BV605 261131 -111.00000   261131
 212 keywords are stored in the 'description' slot

That is, this problem happens sometimes.  Any troubleshooting advice would be appreciated.

!> sessionInfo()
 R version 3.2.2 (2015-08-14)
 Platform: x86_64-pc-linux-gnu (64-bit)
 Running under: Ubuntu 14.04.3 LTS

 locale:
  [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C
  [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8
  [5] LC_MONETARY=en_US.UTF-8    LC_MESSAGES=en_US.UTF-8
  [7] LC_PAPER=en_US.UTF-8       LC_NAME=C
  [9] LC_ADDRESS=C               LC_TELEPHONE=C
 [11] LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C

 attached base packages:
 [1] stats     graphics  grDevices utils     datasets  methods   base

 other attached packages:
 [1] flowClean_1.6.0 flowCore_1.36.0

 loaded via a namespace (and not attached):
  [1] Rcpp_0.12.1         lattice_0.20-33     mvtnorm_1.0-3
  [4] changepoint_2.1.1   corpcor_1.6.8       zoo_1.7-12
  [7] rrcov_1.3-8         grid_3.2.2          stats4_3.2.2
 [10] pcaPP_1.9-60        graph_1.48.0        robustbase_0.92-5
 [13] tools_3.2.2         Biobase_2.30.0      bit_1.1-12
 [16] DEoptimR_1.0-4      sfsmisc_1.0-28      parallel_3.2.2
 [19] compiler_3.2.2      BiocGenerics_0.16.0 cluster_2.0.3

 

 

 

 
ADD COMMENTlink modified 2.1 years ago • written 2.1 years ago by Kipper Fletez-Brant140
1

It is a bug. I've pushed the fix to flowCore 1.36.1.

ADD REPLYlink written 2.1 years ago by Jiang, Mike1.0k
0
gravatar for Kipper Fletez-Brant
2.1 years ago by
United States
Kipper Fletez-Brant140 wrote:

Thanks Mike, this works now!

ADD COMMENTlink written 2.1 years ago by Kipper Fletez-Brant140
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 97 users visited in the last hour