Problem updating flowWorkspace -- error: unrecognized command line option "-ftemplate-depth=900"
1
0
Entering edit mode
@sebastianlunavalero-9152
Last seen 6.2 years ago
United Kingdom

 

After updating Bioconductor to the latest version:

> biocLite()
BioC_mirror: http://bioconductor.org
Using Bioconductor 3.2 (BiocInstaller 1.20.0), R 3.2.2 (2015-08-14).
Old packages: 'flowWorkspace'
Update all/some/none? [a/s/n]: y

I get the following error message:

g++ -I/ifs/apps/apps/R-3.2.2/lib64/R/include -DNDEBUG -DROUT -I/usr/include/libxml2 -Iprotobuf-2.6.0/src -ftemplate-depth=900 -Iboost_serialization -I/usr/local/include -I"/ifs/apps/apps/R-3.2.2/lib64/R/library/Rcpp/include" -I"/ifs/apps/apps/R-3.2.2/lib64/R/library/BH/include"   -fpic  -g -O2  -c GatingHierarchy.cpp -o GatingHierarchy.o
cc1plus: error: unrecognized command line option "-ftemplate-depth=900"
make: *** [GatingHierarchy.o] Error 1
ERROR: compilation failed for package 'flowWorkspace'

Does anybody know why?

Many thanks in advance for your help.

flowWorkspace • 882 views
ADD COMMENT
2
Entering edit mode
Jiang, Mike ★ 1.3k
@jiang-mike-4886
Last seen 3 months ago
(Private Address)

I just pushed the fix yesterday and flowWorkspace 3.16.2 should appear at bioconductor site by the end of today. 

ADD COMMENT
0
Entering edit mode

It works now, many thanks!

ADD REPLY

Login before adding your answer.

Traffic: 277 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6