Question: cellHTS2 configure error
0
gravatar for eduardo.andres.leon
3.5 years ago by
eduardo.andres.leon0 wrote:

Dear all, I’m trying to analyse 7 plates in a siRNA experiment.

These plates have 48 wells but only 24 are used. Wells on the edges are empty (all wells from A01 to A08, F01 to F08 and X01 and X08. Where X goes from A to F).

 

I’m trying to analyse this using cellHTS2 from Huber’s lab.

First I tried to explain the wells in the PlateConf.txt file 

Wells: 48

Plates: 7

Plate    Well    Content

*    *    sample

*    A0[1-8]    empty

*    F0[1-8] empty

*    B01 empty

*    B08 empty

*    C01 empty

*    C08 empty

*    D01 empty

*    D08 empty

*    E01 empty

*    E08 empty

 

This give a Error in well[[i]] : subscript out of bounds

 

Only wells from A are valid :

 

Wells: 48

Plates: 7

Plate    Well    Content

*    *    sample

*    A0[1-8]    empty

 

So I tried then to include this empty wells in the Screenlog.txt, e.g. (for 2 plates):

 

Plate    Sample    Well    Flag    Comment

1    1    A01    NA    Empty

2    1    A01    NA    Empty

1    1    A02    NA    Empty

2    1    A02    NA    Empty

1    1    A03    NA    Empty

2    1    A03    NA    Empty

1    1    A04    NA    Empty

2    1    A04    NA    Empty

1    1    A05    NA    Empty

2    1    A05    NA    Empty

1    1    A06    NA    Empty

2    1    A06    NA    Empty

1    1    A07    NA    Empty

2    1    A07    NA    Empty

1    1    A08    NA    Empty

……...

 

In this case I obtain : Error in convertWellCoordinates(slog$Well, pdim(object)) : 

  Invalid position IDs in 'x’.

 

And again if I use only A wells, it works. So my question is … How do I have to specify this empty wells to avoid errors in normalisation and other subsequent analysis ?

 

my sessionInfo is :

 

> sessionInfo()

R version 3.2.2 (2015-08-14)

Platform: x86_64-apple-darwin13.4.0 (64-bit)

Running under: OS X 10.11.3 (El Capitan)

 

locale:

[1] C

 

attached base packages:

[1] grid      parallel  stats     graphics  grDevices utils     datasets  methods   base     

 

other attached packages:

[1] cellHTS2_2.32.0     locfit_1.5-9.1      hwriter_1.3.2       vsn_3.36.0          splots_1.34.0       genefilter_1.50.0   Biobase_2.28.0      BiocGenerics_0.14.0 RColorBrewer_1.1-2 

 

loaded via a namespace (and not attached):

 [1] pcaPP_1.9-60          prada_1.44.0          BiocInstaller_1.18.5  DEoptimR_1.0-4        GenomeInfoDb_1.4.3    tools_3.2.2           zlibbioc_1.14.0       annotate_1.46.1       RSQLite_1.0.0        

[10] preprocessCore_1.30.0 lattice_0.20-33       Matrix_1.2-3          graph_1.46.0          DBI_0.3.1             Category_2.34.2       mvtnorm_1.0-5         cluster_2.0.3         S4Vectors_0.6.6      

[19] IRanges_2.2.9         stats4_3.2.2          robustbase_0.92-5     GSEABase_1.30.2       rrcov_1.3-11          AnnotationDbi_1.30.1  RBGL_1.44.0           XML_3.98-1.4          survival_2.38-3      

[28] limma_3.24.15         splines_3.2.2         MASS_7.3-45           xtable_1.8-2          affy_1.46.1           affyio_1.36.0        That’s all

 

 

Thank you very much in advance

 

cellhts2 • 454 views
ADD COMMENTlink modified 3.5 years ago by Joseph Barry160 • written 3.5 years ago by eduardo.andres.leon0
Answer: cellHTS2 configure error
0
gravatar for Joseph Barry
3.5 years ago by
Joseph Barry160
Dana-Farber Cancer Institute, Boston, USA
Joseph Barry160 wrote:

Hi Eduardo,

Thanks for posting this. Just to let you know that I've recreated the error locally and am working towards a solution.

ADD COMMENTlink written 3.5 years ago by Joseph Barry160
Answer: cellHTS2 configure error
0
gravatar for eduardo.andres.leon
3.5 years ago by
eduardo.andres.leon0 wrote:

Dear Joshep,

Thanks for your help. I think that I know the problem.

My data, has no values for the empty wells. I've create a well line with value NA and it didn't work, but using 0, seems to be fine. But .. am I including some kind of error by using 0 values ?.

Thanks again in advance

 

 

ADD COMMENTlink written 3.5 years ago by eduardo.andres.leon0
Answer: cellHTS2 configure error
0
gravatar for Joseph Barry
3.5 years ago by
Joseph Barry160
Dana-Farber Cancer Institute, Boston, USA
Joseph Barry160 wrote:

There's a high chance that your error is due to formatting problems in your plateConf file. Please try to read in the plateConf file directly using

read.table("PlateConf.txt", sep="\t", header=TRUE, as.is=TRUE, na.strings="", fill=TRUE, skip=2)

You should see a table with your three columns: Plate, Well, Content. Check that each value in the table is in the correct column. If any aren't you are probably using spaces rather than a tab to separate the fields.

I generally don't recommend using zeros where the true value is NA although it probably won't make a difference in your case since these wells are annotated as being empty (and probably won't be considered for the normalization steps).

 

ADD COMMENTlink modified 3.5 years ago • written 3.5 years ago by Joseph Barry160
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 150 users visited in the last hour