Search
Question: Making package compatible with old version of R/Bioconductor
0
gravatar for gabriel.hoffman
17 months ago by
United States
gabriel.hoffman0 wrote:

I wrote the Bioconductor package variancePartition (http://bioconductor.org/packages/variancePartition/) which is currently available for Bioconductor >=v3.2 and corresponds to R >=v3.2.  I submitted a manuscript based on this software to a peer-reviewed journal, but a reviewer only has R v3.1 and was not able to install the software.  Of course, the reviewer could have just installed a new version of R, but they incorrectly believed that v3.1 was the newest version available on OS X.

Is there any way to make my package available on older versions of Bioconductor?  Obviously, this is not ideal, but it is currently a barrier to publishing

Thanks,

- Gabriel 

 

 

ADD COMMENTlink modified 17 months ago • written 17 months ago by gabriel.hoffman0
1
gravatar for Dan Tenenbaum
17 months ago by
Dan Tenenbaum ♦♦ 8.2k
United States
Dan Tenenbaum ♦♦ 8.2k wrote:

The short answer is no. At any given time we only build two versions of Bioconductor release (currently 3.3) and devel (currently 3.4). 

We stopped 3.2 builds before the most recent release this spring. 

ADD COMMENTlink written 17 months ago by Dan Tenenbaum ♦♦ 8.2k
0
gravatar for Steve Lianoglou
17 months ago by
Genentech
Steve Lianoglou12k wrote:

Yes, it is theoretically possible. If your package doesn't rely on anything else from the new ecosystem (base R features, or other bioc packages) then you could simply install the package using manual means (ie. how you might install any other package from source (not using biocLite))

But it can also open a whole can of worms which you shouldn't have to deal with. If I were you I'd just politely tell the reviewer that s/he is running a version of R that's > 1 year old, and trying to support that is more trouble than it's likely worth (for all parties involved)

 

ADD COMMENTlink written 17 months ago by Steve Lianoglou12k

Theoretically possible (in some cases) but completely not supported and very likely to cause problems. I would NOT tell your reviewer to install a package in this unsupported manner. They should upgrade R.

ADD REPLYlink written 17 months ago by Dan Tenenbaum ♦♦ 8.2k

Yes -- exactly what I said ;-)

ADD REPLYlink written 17 months ago by Steve Lianoglou12k
0
gravatar for gabriel.hoffman
17 months ago by
United States
gabriel.hoffman0 wrote:

I really appreciate your feedback.  I agree with you, I just wanted to see if I was missing anything

Thanks,

- Gabriel 

ADD COMMENTlink written 17 months ago by gabriel.hoffman0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 174 users visited in the last hour