Search
Question: Error in loading rsbml
0
gravatar for enrico.moiso
17 months ago by
enrico.moiso0 wrote:

Dear Bioconductor community,

I'm a biologist and a quite new, R user. Thus I apologize in advance for improper lexicon and personal naivety.

I'm encountering difficulties in loading the BiGGR pckg.

If I've understood correctly I need:

  • libSBML
  • rsbml
  • BiGGR

libSBML is downloaded and installed successfully, following instructions found here: 
http://sbml.org/Software/libSBML/Downloading_libSBML
for R language, using shell command.

rsmbl is then downloaded as follow:

BiocInstaller::biocLite("rsbml")

with the following result:

BioC_mirror: http://bioconductor.org
Using Bioconductor 3.2 (BiocInstaller 1.20.3), R 3.2.1 (2015-06-18).
Installing package(s) ‘rsbml’
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0100 1102k  100 1102k    0     0  2971k      0 --:--:-- --:--:-- --:--:-- 3139k

The downloaded binary packages are in
    /var/folders/21/_9mqw7tx7jxc0yw8b8wnxh680000gn/T//RtmpEZvXYc/downloaded_packages

when I load rsbml via:

library(rsbml)

the following error arises:

Error : .onLoad failed in loadNamespace() for 'rsbml', details:
  call: dyn.load(file, DLLpath = DLLpath, ...)
  error: unable to load shared object '/Library/Frameworks/R.framework/Versions/3.2/Resources/library/rsbml/libs/rsbml.so':
  dlopen(/Library/Frameworks/R.framework/Versions/3.2/Resources/library/rsbml/libs/rsbml.so, 6): Library not loaded: /usr/local/lib/libsbml.5.dylib
  Referenced from: /Library/Frameworks/R.framework/Versions/3.2/Resources/library/rsbml/libs/rsbml.so
  Reason: Incompatible library version: rsbml.so requires version 16.0.0 or later, but libsbml.5.dylib provides version 5.0.0
Inoltre: Warning message:
package ‘rsbml’ was built under R version 3.2.2
Errore: package or namespace load failed for ‘rsbml’

traceback()

2: stop(gettextf("package or namespace load failed for %s", sQuote(package)),
       call. = FALSE, domain = NA)
1: library(rsbml)

and I cannot get through this.

sessioninfo()

R version 3.2.1 (2015-06-18)

Platform: x86_64-apple-darwin10.8.0 (64-bit)
Running under: OS X 10.8.5 (Mountain Lion)

locale:
[1] it_IT.UTF-8/it_IT.UTF-8/it_IT.UTF-8/C/it_IT.UTF-8/it_IT.UTF-8

attached base packages:
[1] parallel  stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] libSBML_5.13.0      BiocGenerics_0.16.1

loaded via a namespace (and not attached):
[1] BiocInstaller_1.20.3 tools_3.2.1          stats4_3.2.1         graph_1.48.0
 

Any kind of help would be very appreciated.
Thank you in advance.

Enrico

ADD COMMENTlink modified 17 months ago • written 17 months ago by enrico.moiso0

Which version of libsbml? Looks like it's older than the one on the Bioc build machine.

ADD REPLYlink written 17 months ago by Michael Lawrence9.8k

Yes, you're right. However it is the latest I've found so far.

ADD REPLYlink written 17 months ago by enrico.moiso0

So I guess you're using libsbml 5.13? Dan could comment on what the Bioc build machine is using. I also noticed that you have a "libSBML" package attached. Perhaps that is causing some sort of conflict.

ADD REPLYlink written 17 months ago by Michael Lawrence9.8k

The build macs use version 5.10.x

ADD REPLYlink written 17 months ago by Dan Tenenbaum ♦♦ 8.2k

Yes,it is correct, I've downloaded and installed libSBML 5.13.0. If I've understood correctly you're suggesting to downgrade to e.g. libSBML 5.10.2, and retry? Now I've also tried to load "rsbml" package without "libSBML" package attached and I get the same error reported in the original question. I think the core of the problem is "Reason: Incompatible library version: rsbml.so requires version 16.0.0 or later, but libsbml.5.dylib provides version 5.0.0" , but it is not clear to me from where can I obtain v16

ADD REPLYlink written 17 months ago by enrico.moiso0

Sorry, I have no idea why it would require v16, which seems too far beyond v5 to make sense.

ADD REPLYlink written 17 months ago by Michael Lawrence9.8k

Yeah, something sounds wrong. According to http://sbml.org/Software/libSBML, the latest stable version is 5.13.0.  Please thoroughly remove libsbml and then install version 5.10 from here.

ADD REPLYlink written 17 months ago by Dan Tenenbaum ♦♦ 8.2k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 103 users visited in the last hour