Search
Question: Questions on using clusterProfiler
0
gravatar for zhangducsu
13 months ago by
zhangducsu0
zhangducsu0 wrote:

Hi,I've just using the clusterProfiler to enrichGO,and I 'm sure I have followed the guide.the problems is as follows:

> Rhinopithecus
OrgDb object:
| DBSCHEMAVERSION: 2.1
| DBSCHEMA: NOSCHEMA_DB
| ORGANISM: Rhinopithecus roxellana
| SPECIES: Rhinopithecus roxellana
| CENTRALID: GID
| Taxonomy ID: 61622
| Db type: OrgDb
| Supporting package: AnnotationDbi

Please see: help('select') for usage information
> sample_gene <- sample(keys(Rhinopithecus), 100)
> str(sample_gene)
 chr [1:100] "104660679" "104681732" "104678044" "104665499" ...
> library(clusterProfiler)
Loading required package: DBI

Warning message:
replacing previous import by ‘graph::.__C__dist’ when loading ‘topGO’
> sample_test <- enrichGO(sample_gene, OrgDb=Rhinopithecus, pvalueCutoff=1, qvalueCutoff=1)
Error in enrichGO(sample_gene, OrgDb = Rhinopithecus, pvalueCutoff = 1,  :
  unused argument (OrgDb = Rhinopithecus)
> head(summary(sample_test))
Error in head(summary(sample_test)) :
  error in evaluating the argument 'x' in selecting a method for function 'head': Error in summary(sample_test) :
  error in evaluating the argument 'object' in selecting a method for function 'summary': Error: object 'sample_test' not found

Any help will be appreciated,thank you very much!

ADD COMMENTlink modified 13 months ago • written 13 months ago by zhangducsu0
0
gravatar for Guangchuang Yu
13 months ago by
Hong Kong
Guangchuang Yu800 wrote:
unused argument (OrgDb = Rhinopithecus)

This is obvious.

 

You are using out-dated version of clusterProfiler. OrgDb parameter was introduced in BioC 3.3. see here and here

ADD COMMENTlink modified 13 months ago • written 13 months ago by Guangchuang Yu800
Hi Mr.Yu, I have get another setback when i test the OrgDb. There is my problem: 

> sample_gene [1] "104659199" "104658306" "104654873" "104662215" "104667982" "104665123" "104658425" "104661932" "104680600" "104677726" "104668349" "104664576" "104677319" "104654658" "104659464" "104681493" "104681350" "104678064" [19] "104675152" "104680321" "104671073" "104671689" "104676265" "104680856" "104655997" "104662047" "104680607" "104658449" "104675573" "104657093" "104669852" "104656815" "104673498" "104682591" "104671893" "104676454" [37] "104680003" "104676724" "104663920" "104668959" "104678617" "104656984" "104653536" "104681184" "104672099" "104657169" "104655594" "104667513" "104657689" "104661332" "104681942" "104675551" "104659877" "104677539" [55] "104666968" "104677063" "104675555" "104674613" "104677554" "104667119" "104675054" "104681641" "104678133" "104668418" "104657038" "104667473" "104664966" "104653523" "104655850" "104666532" "104673914" "104658929" [73] "104671165" "104668558" "104667271" "104662905" "104661248" "104663732" "104679501" "104655202" "104668708" "104676253" "104660400" "104669597" "104671013" "104679136" "104667476" "104663452" "104658325" "104663441" [91] "104674181" "104655270" "104676072" "104672920" "104657353" "104668519" "104656327" "104676512" "104668169" "104677577" 
> sample_test <- enrichGO(sample_gene, OrgDb=Rhinopithecus, pvalueCutoff=1, qvalueCutoff=1) 
No gene can be mapped.... 
--> return NULL... 

No result feedback at all, can you help me? Thank you!
ADD REPLYlink modified 13 months ago • written 13 months ago by zhangducsu0
No gene can be mapped.... 

the msg is also obvious, your input genes can't be mapped to GO annotation.

This can be caused by 2 reasons:

1. your input gene type is not available in OrgDb or the `keytype` parameter is not set correctly.

2. Your OrgDb object doesn't contain GO annotation or without enough annotation.

 

Your issue is due to reason 2. Your OrgDb contains 29530 genes and only 18 of them have GO annotation.

I remember you post such question 9 months ago and I already answered it.

see https://guangchuangyu.github.io/2016/01/go-analysis-using-clusterprofiler/#comment-2454929667

 

don't repeatedly asking same question, otherwise I will just ignore it.

ADD REPLYlink modified 13 months ago • written 13 months ago by Guangchuang Yu800

Thank you for your reply.I feel so sorry to bother you again...

Anyway,what should I do to do the GO and KEGG analysis of this species whlile clusterprofiler is not work for this?Thanks!

ADD REPLYlink written 13 months ago by zhangducsu0
0
gravatar for zhangducsu
13 months ago by
zhangducsu0
zhangducsu0 wrote:

Thank you very much! I will try to make it.

ADD COMMENTlink written 13 months ago by zhangducsu0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 146 users visited in the last hour